Wing Commander Prophecy: Secret Ops Model Update Pack

DefianceIndustries

Rear Admiral
The open/GL does wonders with the original models @Panther1.0, I just ran the intro again to make sure there wasn't a missing model or something but everything works as intended. Do you have the most current drivers for your card?

This is probably an issue in the open/gl as AFAIK the vision updates are working. @Pedro ^^
 

Panther1.0

Ensign
Thanks friend, I keep my drivers etc up to date, I have a new PC with latest Windows 10 installed, I have many older and newer games, busy playing Gears of war 5 (Xbox gamepass for PC)

Yes, on WCP and SO both work fine, I finished SOP with OpenGL 1.22, it looks better than WCP especially the large alien cap vessels.

I tried WCP again after some guys asked me about the high res or DVD version, so I was eager to see if my game will still work with my new setup and OS, so I thought let me try your pack but without success, I did everything you said, it could be that I dont have the gog version, I understand that version is pre-updated with the DVD pack and some other updates so that might be it.

Ill keep a eye out for the gog version, I will try again.

I must add WCP is a good overall game, I just played the first 5 missions and now I want to continue playing, it still runs so good considering its age, I get constant frame rate at the highest possible settings -both the game and added AMD driver settings. I'm impressed with AMD's IPS/ freesync fps control, it works in most games now, even the oldies.
 

Pedro

Admiral
Thanks friend, I keep my drivers etc up to date, I have a new PC with latest Windows 10 installed, I have many older and newer games, busy playing Gears of war 5 (Xbox gamepass for PC)

Yes, on WCP and SO both work fine, I finished SOP with OpenGL 1.22, it looks better than WCP especially the large alien cap vessels.

I tried WCP again after some guys asked me about the high res or DVD version, so I was eager to see if my game will still work with my new setup and OS, so I thought let me try your pack but without success, I did everything you said, it could be that I dont have the gog version, I understand that version is pre-updated with the DVD pack and some other updates so that might be it.

Ill keep a eye out for the gog version, I will try again.

I must add WCP is a good overall game, I just played the first 5 missions and now I want to continue playing, it still runs so good considering its age, I get constant frame rate at the highest possible settings -both the game and added AMD driver settings. I'm impressed with AMD's IPS/ freesync fps control, it works in most games now, even the oldies.

Could be an AMD issue I guess? I don’t have access to an AMD card (tend to avoid them as their drivers are flakier and cost a lot of development time).
Did you enable all the options in the OpenGL setup? Try turning some off such as FSAA and 32bit depth.

1568598839756.png


There was a 32 bit z-buffer issue with an earlier version, I hope the right one has been included in this release.
 
Last edited:

Panther1.0

Ensign
I have tried that already, if i override the beta with an older openGL patch the game works, dont even have to re install
 

Panther1.0

Ensign
@DefianceIndustries & @Pedro,, what graphics cards are you using? I might buy a cheaper nVidia card like a 1050 even 1060 are cheaper now with all the new releases, just a thought, I have some parts to build a 2nd pc and/or will this work on one of those iCPU's from Intel? eg. Intel G610/630 integrated graphics from i3's etc...?
 

Pedro

Admiral
@DefianceIndustries & @Pedro,, what graphics cards are you using? I might buy a cheaper nVidia card like a 1050 even 1060 are cheaper now with all the new releases, just a thought, I have some parts to build a 2nd pc and/or will this work on one of those iCPU's from Intel? eg. Intel G610/630 integrated graphics from i3's etc...?

A 1070 (I also have an old laptop with a 960/intel combo that I can check intel with) but don't worry - if there's really an AMD specific issue I'll try and find an old card and fix it. I'm not going to just leave that issue in place if that is the cause (I've been pretty distracted by the WCIV project lately, should have confirmed sooner)

I'm also attaching the last dll I made; I just checked the dates and the one in the beta release is a week older. I don't remember what I changed but please try this one to be sure.
 

Attachments

  • OglDll - Release Candidate.zip
    130.6 KB · Views: 61

Panther1.0

Ensign
Thank you Pedro!

If you can please test the new WCP beta with new ships models on your intel laptop, will be great! Then I can salvage something if not working but Ill first test out the gog version also, I found two zipped files on a old backup dvd of mine,;its small less than 1gb files, wing commander prophecy gold looks like, maybe im lucky, i might have downloaded the gog version some 15 plus years back :-/

How is the WCIV project going?

Cheers.
 
Last edited:

Pedro

Admiral
Thank you Pedro!

If you can please test the new WCP beta with new ships models on your intel laptop, will be great! Then I can salvage something if not working but Ill first test out the gog version also, I found two zipped files on a old backup dvd of mine,;its small less than 1gb files, wing commander prophecy gold looks like, maybe im lucky, i might have downloaded the gog version some 15 plus years back :-/

How is the WCIV project going?

Cheers.

Did you test that zip that I attached? There were some issues with z-buffer creation issues with one of the versions so I'm really curious is that works.
I'll try and test on my intel at the weekend.

WCIV is going really well, making lots of progress on reading original file formats and supporting DVD video etc; but it's lots of ground work laying.
Lots of work with nothing to show for it other than confirmation that it's a viable direction to take.

Definance is doing some cool experimentation; maybe he'll have test models to show but until the fundamentals are in place it doesn't make sense to focus on the visuals and so there isn't much in-game to show (we want to improve the lighting, particles etc) so you won't see much from it this year (probably for the best as between the MUP and Wing Leader the fan project of the year award has overly stiff competition).
 

Panther1.0

Ensign
Ok cool ! Sounds very fun like and frustrations also, lol

Thanks for all the help, will test the zip file when I get home, currently at work, I have a long weekend coming 😑
 
Last edited:

Panther1.0

Ensign
Ok, I tested the Dll from the zipfile and it makes no difference, I also uninstalled the game completely and I installed the gog version (WCP Gold)

It does exactly the same thing and when I revert back to ver 1.2.2 it works again 100% with DVD movie playback, no other problems at all. Plus both WCP and SOP looks fantastic with 4xAA and 16xAnis and everything else enabled, like a new game, you guys must play SOP, good ingame storyline.

So I guess it related to something way different, graphics card driver or so? Maybe, let me know if you get time testing on Intel graphics, no worries, I've played through SOP, still lots of fun but done for now, playing some Freespace 2 and checking out Saga via FSO,

Cheers!!
 

DefianceIndustries

Rear Admiral
I believe that's your issue. There's a conflict between the DVD patch and the open GL patches currently. I know @Pedro and Grim are currently working on it. So do a clean install of both wcp and SO and only install the beta candidate, do not install any other add ons and see if that works.
 

Panther1.0

Ensign
I will try sometime the weekend, i dont really get it, I tried at first on SOP because its a quick install without the DVD patch and it did not work,

I think we are missing something else.
 

Panther1.0

Ensign
does it look better?

both retail and gog ver. works, installed on my core i3, I forgot my laptop's CPU also had internal graphics acceleration, much slower but it works.

ne-models.jpg
 
Top