Wing Commander and Wine 5.0 (stable)

Wedge009

Rogue Leader
Hello folks.

I know a number of people have been playing WC via Wine for quite some time now - I've read some of those adventures in my research - but I'm hoping for some help/advice for replaying WC in 2020.

Background: I migrated to Linux as my primary OS with the end of general support for Windows 7 a couple of months ago. (I still have Win7 machines running, but obviously I'm not keeping my most important data or day-to-day operations on them any more.) I've since been going through some of my older games (pre-Internet authentication era) with Wine and decided it was time to replay Wing Commander.

Early games were easy: WC1, WC2, Academy, Privateer, Armada, and WC3 all worked fine on DOSbox (just needed to use loadfix for WC2). All of them were my original retail copies, not GOG releases.

For WC4, I wanted to go with the double-sided DVD version so I think that means Wine. After patching the 'VirtualProtect()' error the game itself worked fine but it kept complaining about missing movies. Even with the DXMCI patch and AC3Filter installed, I still couldn't get it working properly. As a work-around, I just watched the movies in VLC - not ideal, but I just wanted to get on with playing the game. (I also tried a GOG installation but same result.)

But now I'm stuck on Prophecy (I have the original non-Gold retail CD release). I couldn't get the set-up to work so I just copied all the files and manually added the Registry entries. Starting the game asks me to insert CD1 even though all necessary files (or so I believe - this includes wcpdisc1/2/3.iff) are already installed. Regardless, I tried installing the following enhancements:
  1. HCl's original Enhancement Pack.
  2. The MUP-augmented version of the OpenGL patch (the most recent one I could find, from 2019-08-26, rather than the - older? - one from WCpedia).
  3. The DVD movie upgrade.
After all that, I still have the same problem: 'Looking for CD 1. Please insert CD to continue.' (Oh, and Wine throws an exception upon quitting.) Is this simply the copy-protection at work? It's been a while since I played WCP on Windows but I thought I previously had it running from hard disk without needing the CDs...

I assume Secret Ops, being originally distributed via Internet, won't have this problem but I'd rather get through Prophecy first before revisiting SO and Standoff.
 

Wedge009

Rogue Leader
After writing all that, I just tried WCP on Win7 and it asks for CDs there too. So I assume this is part of copy-protection and can't be avoided. ~sigh~
 

Wedge009

Rogue Leader
So I used winecfg to make a pretend-CD with the necessary files. Now I have the same problem as for WC4 - game works but VOB movies don't (the original logos from the CD-based movies did). Oh well, I'll just have to work-around that too.

The Midway looks different from how I remember it, so I assume that's the MUP at work.
 
Last edited:
Top