WCP Video Cutscene Skipping Solution Fix

Discussion in 'Tech Support' started by TCSTigersClaw, Jan 18, 2003.

  1. Black_Knight

    Black_Knight Spaceman

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NB, Canada
    Click the Start button (in Windows), then Run, then type DXDiag - on the sound tab there is an acceleration slider. Try dropping that for WCP, and raising it back up for newer games...
     
  2. Hamlet

    Hamlet Spaceman

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Chicago, Illinois, USA
    Ok thanks. That did help, but the problem still remains. I tried it out on the video where we first see Maniac in the game. Maniac is telling some pilots a story, hawk and spider are sitting at a table, Casey walks in and tries to introduce himself, spider and hawk walk away, maniac gets pissed, etc.

    Anyway, what happened was now the video did move at a slower, correct speed...but now it kinda stops every other second, like I had a lower end computer...and every one and then it did the choppy skippy video thing again. I tried expierimenting with the 3d acceleration bar, but with not luck. Are there any other solutions?
     
  3. Black_Knight

    Black_Knight Spaceman

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NB, Canada
    Hmm, not sure about that - I think this is beyond me now. :( Maybe someone else knows...
     
  4. Akrovah

    Akrovah Guest

    Ok, Seriously, I wa having this problemn and it reaelly bugged me, so i came to this web site looking for help, and i found it by looking through this whole thread. People are making this way to complicated.

    This is what i did(you have to have 2 sound cards or an onboard sound driver for this to work.)

    In WinXP Pro, i opened "control panel", opened "Sounds and Audio Devices"

    Click on "Audio" tab

    Under sound playback, change you default device to whatever other sound device you have, just so it isn't the Live! or Audigy.
    click apply

    Problem Solved, for me at least. No messing with acceleration, no config files or bios altering. I didn't even have to get the Win2k Patch (since XP is built off of 2k) Just leave the Audio window open and then when youre done playing Prophecy just cange it back to you Live or Audigo.
    Other people with multiple sounds devices let me know if this worked for you.

    I don't know how to change the default audio device in other versions of windows since it has been so long since i've used any of them, but the options are there somewhere.
     
  5. FirstBorg

    FirstBorg Guest

    I have, as you can imagine, the same problem :)

    Im using Win2k, but my sounddevice is neither SB or Audigy, it is the Nvidia Nforce 2 auio which is onboard on that chipset.
    I tried everything here to have a smooth video playback, nothing works :(

    I think it has nothing to do with a specific sound device, but with Direct X... because I counted now 4 different soundcards, but I guess, that all had Dx 9.0 or 9.0b, so I think that would be the starting point in solving the puzzle.
     
  6. Akrovah

    Akrovah Guest

    I don't know. I have directx 9.0b and i was able to solve my problem by using my sbpci128 instead of the audigy when playing prophecy. Have you tried the win2k patch?
     
  7. FirstBorg

    FirstBorg Guest

    Yes, because without the patch, I cant even start the game.


    I found a "solution"... I built up a Virtual PC inside Win 2000... installed Win98 on it... and that works... But, the virtual pc has not the right videoadapter installed, and I dont know how to change that, so I have not the best graphics possible... and it has no usb, so I cant play with joystick.... but the game works.... now if you would know a solution for the video adapter and the usb thing, this "solution" would work.
     
  8. Unregistered

    Unregistered Guest

    I have the video problem in Prophecy as well. I've read through all of these posts and tried everything (I can- as said either xp won't allow you to use a seperate .cfg file). When I turn sound hardware acceleration down to nothing the videos no longer "fast-forward" but instead skip about every 2-5 seconds; it makes the virtually impossible to watch. I tried every other setting of sound hardware acceleration- all to fast. I tried changing the sample rate bu that too did nothing. Finally I downloaded CPUKiller 2.0 and tryed using that-on my computer I have to turn the Cpu speed down so low that the rest of the game is unplayable and also at about the point the sound gets ok the image starts to lag. Using in CPUKiller in conjunction with the hardware acceleration being down (not off) and it helped but the game was still to slow. On my family computer I can get it going almost playably with CPUKiller and with some tweeking that might work. I also have yet to try my laptop, that might also work. My questions are, however, different.

    Is it possible for someone, anyone, to patch Prophecy ( as done with Privateer 2: Delexe Edition) to not have video problem by prehaps adding timing, or using HCl's wcvideo player, or by using maybe Privateer 2's video engine (I don't know how similar they are)? If it is possible why has it not been done? If it is not possible then why is it not possible? I would think that if someone can patch Prophecy to run at 1024x768 then someone could patch the videos. Does anybody know?

    By the way here the specs of my two systems:
    My System :) : AMD Athon XP 3000+, 1024 mb DDR 400 GIeL Ram, Audigy 2, and ATI Radeon 9800 Pro 128 mb

    My Family System: AMD Athlon XP 2200+, 512 mb DDR 333 Ram, Nvidia NForce Audio Codec, and Nvidia Geforce 4 Ti 128 mb
     
  9. tweak

    tweak Guest

    if anyone is curious, setting rasterMajor=2 should cover you if you're using a voodoo based card. i changed mine to 2, video and sound acceleration to normal hardware modes and it works fine. no skipping video and no more locking up on video/audio during missions.

    great job figuring out the config file peter.
     
  10. Evil_Spock

    Evil_Spock Spaceman

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I think I have found a solution for those who are using any of the newer sound boards from Creative Labs (ie Live! and up, I tested on an audigy mp3+).

    Use 3rd party drivers, so far I only found drivers made by the kx project their site is http://kxproject.lugosoft.com/, but there might be other 3rd party drivers that also work.

    However, hardware acceleration must be turned down to none.
     
  11. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    Someone suggested to simply disable EXTERNAL CPU Cache. - I can only disable both external AND internal Cache with my Shuttle XPC SB51G :( - Anyway, now the sound was to fast and had to be repeated (PC booting took 20mins+ btw :/ ). So my guess is: Only disabling the External should really work.

    Btw, the CPU I tested was a 3.066Ghz. I'll try the trick later on with my 3.2Ghz (hope I can disable External only, otherwise it's useless :( )

    P.S.: Yes, I have tried all tricks mentioned here, but they don't work for me. And btw, I've got NO Creative Card in this PC, but a Plantronics DSP-500. - I hope I can find a solution for this rig, cause it's my main gaming rig at the moment :(
     
  12. y2k

    y2k Spaceman

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    this sucks,
     
  13. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    Ok, I've tested the "Disable Cache" tip with two more PCs, but no go.
    Summary:
    1. my 3.067GHz: could only disable BOTH Internal and external - too slow
    2. my 3.2Ghz: couldn't disable Cache at all
    3. my AMD Athlon XP 1700+: disabling External only: still too fast
    disabling: internal only: too slow
    disabling both: too slow
    OS was always Win XP SP1, so might work with other OS, but to be honest I doubt that it will do so in general. All oin all it isn't a "Just switch off CPU Cache" to fix it.
    Oh well, at least I now got it running via using my Onboard sound card in the 3.067Ghz rig (only need to pull out my HS under desktop, so quite easy to change) but I would have loved to see a solution that works at leadst for 90%+ - the sound hardware acc. trick didn't work for any of the 6 PCs I tested (all totally diff. except OS), so no 90% there, I'd guess.
    @y2k: Yes, this bug sux, but we have to live with it :(
     
  14. Edfilho

    Edfilho Cry some more!

    Messages:
    3,526
    Likes Received:
    0
    Trophy Points:
    36,985
    Gender:
    Male
    Location:
    Curitiba
    Funny, I distinctly recall the W2k patch working for me, but now only the sound accel trick makes the video work.
     
  15. Ultimatar

    Ultimatar Spaceman

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California
    Ok. Well the Sound Hardware acceleration doesn't work for me. When the acceleration is off I get no sounds at all. And without any sound I can't even be sure movies are playing correctly. Is there something else I need to do after changing acceleration settings? I'm also still running Windows 98SE so I cannot easily switch audio devices, set compatibility modes, etc.
    I have a SB Audigy 2 on a P4 1.x GHz with 256MB RAM, nVidia Geforce2 GTS/Pro
     
  16. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    You might want to give HCl's Video-Patch a try. - It normally should fix your problem, no more other settings needed. You can find it in the wcnews files section, if I remember right.
     
  17. Ultimatar

    Ultimatar Spaceman

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    California
    Video Patch? I didn't see one. Only the Hi-Res patch. I didn't even think there was any fix for this with all the action this topic is getting. Everyone is having this problem, but I can't adjust sound acceleration because a 'none' setting disables my sound totally.
     
  18. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    Well, the patch isn't that old, and this Thread here is VERY old.
    Here is the link to the Patch:
    http://www.wcrevival.de/hcl/
    It's from April, 27th btw. And as you can see from the posting dates, nearly all posts are way older than that one.

    P.S.: You are right, they didn't add it to the download section. That's VERY strange :confused:
     
  19. Edfilho

    Edfilho Cry some more!

    Messages:
    3,526
    Likes Received:
    0
    Trophy Points:
    36,985
    Gender:
    Male
    Location:
    Curitiba
    well, just dl'ed it again, I've lost it (weird)

    But considering how I have already played the game several times, and so the story doesn't matter much to me, the D3D crosshair bug is a lot more disrupting.
     
  20. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    Hmm. Have you tried out the Glide wrapper linked in some Threads here? - If you don't know it nor can find the link, I can look it up again...
     

Share This Page