Running Privateer/rf/armada/pg In Windows: Howto

Unregistered said:
Okay...I have the latest version of DosBOX installed and can load that up no problem. I mount e e:\priv, type e:, then type priv to run the game. Once I do that I get the following message and I go no further.

Protected mode driver is not responding to EMS function calls.
Make sure your EMS driver is not configured with the NOEMS option.
If it is, replace the option "NOEMS" with RAM

And I changed the EMS call in DosBox to false...

Thanks in advance
Now that is very strange. Normally changing the DOSBox.conf line from EMS=True to EMS=False does the trick. Hmm, sorry, no idea what's going wrong there :( Maybe it's not calling the config-file? Your shortcut has to link to it. If it does, I don't have any further ideas at the moment :(
please post your dosbox config.
Armada space flight engine is INDEED working in DOSBOX, albeit slow and with bad joystick calibration. But it worked. And it is faster than Priv.

Now that is very strange. Normally changing the DOSBox.conf line from EMS=True to EMS=False does the trick. Hmm, sorry, no idea what's going wrong there :( Maybe it's not calling the config-file? Your shortcut has to link to it. If it does, I don't have any further ideas at the moment :(
Hrm...what do you mean by my shortcut has to link to it? That could very well be the problem I guess. I changed the dosbox.cfg file but I assumed that it would load DosBox using hte cfg file automatically.

Thanks for the help.
Simply righclick on your DOSBox shortcut and check whether it links to something similar to this:
C:\Programme\DOSBox-0.61\dosbox.exe -conf "C:\Programme\DOSBox-0.61\dosbox.conf"
To let the proggy use the config, the -conf part is needed. Otherwise it will use the default, if I got the proggy right.

Got the shortcut set up and everything is fine with that. I can even run MechWarrior (The Old school game) with DoxBox...Priv still gives me the same warning. :-(
:confused: That is REALLY strange now. Guess it is best when you post your Dosbox.conf file here. Maybe something else is wrong.

Here's the entire text of the Dosbox.conf file... and this is the command line that I call my shortcut with when I load DosBox.

D:\DOSBox-0.61\dosbox.exe -conf "d:\dosbox-0.61\dosbox.conf" -fullscreen

# fullscreen -- Start dosbox directly in fullscreen.
# fulldouble -- Use double buffering in fullscreen.
# fullfixed -- Don't resize the screen when in fullscreen.
# fullwidth/height -- What resolution to use for fullscreen, use together with fullfixed.
# output -- What to use for output: surface,overlay,opengl,openglnb.
# hwscale -- Extra scaling of window if the output device supports hardware scaling.
# autolock -- Mouse will automatically lock, if you click on the screen.
# sensitiviy -- Mouse sensitivity.
# waitonerror -- Wait before closing the console if dosbox has an error.


# language -- Select another language file.
# memsize -- Amount of memory dosbox has in megabytes.
# machine -- The type of machine tries to emulate:auto,hercules,cga,tandy,vga.
# Try a specific type if your game has problems with auto.


# frameskip -- How many frames dosbox skips before drawing one.
# snapdir -- Directory where screenshots get saved.
# aspect -- Do aspect correction.
# scaler -- Scaler used to enlarge/enhance low resolution modes.
# Supported are none,normal2x,advmame2x


# core -- CPU Core used in emulation: normal,full,dynamic.
# cycles -- Amount of instructions dosbox tries to emulate each millisecond.
# Setting this higher than your machine can handle is bad!
# cycleup -- Amount of cycles to increase/decrease with keycombo.
# cycledown Setting it lower than 100 will be a percentage.


# nosound -- Enable silent mode, sound is still emulated though.
# rate -- Mixer sample rate, setting any devices higher than this will
# probably lower their sound quality.
# blocksize -- Mixer block size, larger blocks might help sound stuttering
# but sound will also be more lagged.
# wavedir -- Directory where saved sound output goes when you use the
# sound record key-combination, check README file.


# mpu401 -- Enable MPU-401 Emulation.
# device -- Device that will receive the MIDI data from MPU-401.
# This can be default,alsa,oss,win32,coreaudio,none.
# config -- Special configuration options for the device.


# sblaster -- Enable the soundblaster emulation.
# base,irq,dma -- The IO/IRQ/DMA address of the soundblaster.
# sbrate -- Sample rate of soundblaster emulation.
# adlib -- Enable the adlib emulation.
# adlibrate -- Sample rate of adlib emulation.
# cms -- Enable the Creative Music System/Gameblaster emulation.
# Enabling both the adlib and cms might give conflicts!
# cmsrate -- Sample rate of cms emulation.


# gus -- Enable the Gravis Ultrasound emulation.
# base,irq1,irq2,dma1,dma2 -- The IO/IRQ/DMA addresses of the
# Gravis Ultrasound. (Same IRQ's and DMA's are OK.)
# rate -- Sample rate of Ultrasound emulation.
# ultradir -- Path to Ultrasound directory. In this directory
# there should be a MIDI directory that contains
# the patch files for GUS playback. Patch sets used
# with Timidity should work fine.


# pcspeaker -- Enable PC-Speaker emulation.
# pcrate -- Sample rate of the PC-Speaker sound generation.
# tandy -- Enable Tandy 3-Voice emulation.
# tandyrate -- Sample rate of the Tandy 3-Voice generation.
# disney -- Enable Disney Sound Source emulation.


# Nothing to setup yet!

# xms -- Enable XMS support.
# ems -- Enable EMS support.


# modem -- Enable virtual modem emulation.
# comport -- COM Port modem is connected to.
# listenport -- TCP Port the momdem listens on for incoming connections.


# Lines in this section will be run at startup.
To check whether it really uses your dosbox.cofn, you could change your command line to:
D:\DOSBox-0.61\dosbox.exe -conf "d:\dosbox-0.61\dosbox.conf"
And then change your conf-file line to:

You also may try out whether it works with less RAM (maybe 16Mb instead of 32):

And while you are at it, up your cycles "a bit", let's say:

cause Privateer needs a lot of CPU power (in 0.61, that is)
And I'm not sure whether DOSBox cares about the difference between small and capital letters, but might be possible (not at home, so I can't test it myself). So try ems=false instead of ems=FALSE.
Still no luck

I have still been trying to get these two games working. I have never played armada before (never been able to get it to work) and I never got very far in privateer so I really wanted to try and play them again. I've tried DOSbox with the various settings mentioned here as well as make a pure dos installation on my machine, the most i could do is get the game to say "Loading privateer..." or "Loading Armada.." and then crash with memory errors (not EMS errors, mind you) I'm starting to think it could be my disks, all my other wc games work fine in pure dos and in dosbox, but I guess these games had strange memory configurations.

If anyone has any floppy boot disk images to play these games in pure dos, or DOSbox conf files, I would really appreciate any help to get these working.

I believe I have an old amd 400mhz pc with sb16 etc. I suppose if all else fails, i will set it up as a dos gaming rig, but i'd like to have all my wc games on the same machine if possible
yes the problem is the letter casing

use ems=false

not ems=FALSE
For using dosbox easier , download Boxer. it s a tool for dosbox.

Anyone have any idea when the next version of dosbox will be up?
BTW they have done a really superb works with this tool.. I hope they will keep doing.

Privateer and master of magic are running with my computer and win XP.
They are just too slow atm. I hope the next Dosbox version will do something about that.

I want to thx ppls arround here too for sharing help.
I'm trying to get Armada going in DOSBox .62 to no avail. :(

I'm running XP Professional, SP1 on a P4 2.4GHz with 1GB of RAM, on an Asus mobo, with a SB Audigy, and a Logitech Wingman Extreme Digital 3D.

I've set the ems to false, and set it to run full screen. I've tried memsizes of 100, 16, and 8.

When I have sound enabled in the Armada install (through the installer), it starts to load, gets to the point about loading EMS (or however it's worded), and it crashes DOSBox. When I set the sound devices to none using install.exe in the Armada directory and launch it, it hangs at the point where it had crashed.

Also, Strike Commander loads, but won't get past joystick calibration. (I also have a TM Cougar HOTAS plugged in at the moment, but don't use it for anything other than flight sims (IL2, FB, PF, LOMAC, etc). The calibration routine responds to trigger clicks from both sticks, so I'm not sure if that's part of it or not.

Any help would be greatly appreciated. I'd love to run Armada. I've had it for some time now but never played it (ever).
Not sure for Strike Commander, but IIRC you need to be in WINDOWED mode NOT full screen for Armada to work.

Kazan said:
ok.. i have it running - but it locks up after a minute or two *sigh*

windows 98 - full reboot into dos
[BTW I dual boot win98/linux, but that shouldn't make a difference - it hasn't before]

Pentium III 800mhz
768 Megs of ram [16MB EMS]
ATI Radeon 32meg DDR
SB Live! Value
10 Gig Windows/DOS [fat32] partition on hda [primary master]
priv.tre and rf.tre copied to harddrive

DeviceHigh=C:\WINDOWS\EMM386.Exe 16384 HIGHSCAN ram /m3 /I=b000-b7ff

SET PATH=C:\windows\command
SET BLASTER=A220 I5 D1 H5 P330  T6
rem lh net start ipx
lh c:\windows\command\mscdex.exe /D:IDECD000
lh c:\gmouse\
REM The following lines have been created by Windows. Do not modify them.

all of the sb lives values are correct - and the game successfuilly uses the card while it does run... but then after a minute or two hard lock up. gar.....
I have a really dumb question

Ok Im not very bright i despratly want to change the DOSBox config file but how do i do it?? i have the new 6.2 version on a p4 266 w 512 ram and a 128 vid card and XP.I havt this not pad thing that when i bring it up its blank but it says its the conf file and when i type ems=false DOSBox wont run untill i clear it off.Also i have a 486 with win 3.1 for work groups on it and a cd rom any tips on a boot disk for the old dog???


DosBox 0.63 was just released. Armada runs, but I have no sound effects (only music). It's a little bit slower than I would have liked, and the joystick doesn't function properly, but it works.
Set this configuration:
ems = false

Then, when loading armada, instead of typing "armada," type
loadfix -65 armada.
It has worked for me. Finally I get to play one of my favorite WC games!!!!!!111112
Possible Good news

Guys, I might have some good news:
I have a bootable CD I made that uses Win98's dos which has 590k available after loading a CD driver a XMS disk (4096k but can be made bigger) Sound Blaster Live support, and a mouse driver, it is currently setup to run Privateer and Rightous Fire off the CD after it copys a pre-setup version of the game's main files off the CD to the XMS disk. Only one issue still exists, for some reason WAVE output sounds like garbage. Most joysticks that work from DOS should work, and with some tweaking this thing oughta be helpfull to ppl who have a fat32 drive, but is designed to run off of a highend machine running an ntfs disk. The XMS disk is configured as C:, the cd copys all of the CD's \privater directory to the XMS disk along with \DOSDRV which also exists on the CD, then runs what ever game you selected from the bootmenu (PRIV, RF or DOS) the problem is I can't find a place that'll host the floppy image, the CD image, and I also have issues with time to work on those things. I do plan on implementing some more stuff, including support for other games (ARMADA, ACADEMY, SYSTEM SHOCK), support for USB joystick (its a long shot, but maybe) but I first want to crush the WAVE issue, tho MIDI works just fine. This disk was made specifically for WinXP machines with NTFS drives and a SB Live or similar sound card.

On a side note:
I have gotten ARMADA, ACADEMY and SPACE ROGUE all working under DOSBOX 0.63 using D-Fend, I could also easily put the config files up if I can get a site going, none of them run with good sound save SPACE ROGUE as it only needs a PC Speaker to work. WCSAGA is available from multiple ABANDON ware sites and usually has only WC1 and 2, both run perfectly for me in XP.
The sound problem can probably be fixed by limiting the EMM memory to 16MB or less...
I'll give that a try, I've consulted multiple sites covering SB Live issues from dos and tried positivly EVERYTHING but nothing seemed to work, I'll mod emm386 entry and test it ASAP, but it's gonna be later today if at all since I have a major test. (8 hour long test)
There seems to be some limit..

Major thanks cff,
Its working, I have a functional privateer boot disk. I am going to reburn the cd with the new disk image, all sound seems to work 100% so far. I am also going to make an iso or at least a nero image using the floppy version of privateer available from HOTU and post it on a small site I have. My profiles for academy, armada and so on for DOSBox will also be added. I'll update with a url soon. (I'M GONNA GO PLAY SOME FRICKEN PRIVATEER!)

After playing for 45 minutes the sound regarbled, I exit and restarted Privateer but sound remained messed up, rebooting off the cd seems the only way to fix it.
This may be an isolated incident, as I was being harassed by four pirates loaded with missiles, particle cannons and mass drivers. Add in my tachyons, missiles and afterburn, I prolly just over taxed it a bit. I'm going to test for it again, if i can make it repeat then it will be the only issues I have left to deal with.