Running Privateer/rf/armada/pg In Windows: Howto

Discussion in 'Tech Support' started by Darkmage, Jul 16, 2002.

  1. Vengeance

    Vengeance Spaceman

    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Oregon
    Armada Joystick in DOSBOX using XP

    Does anyone know why the Joystick will not work in Armada? DosBox doesn't know why either. Using DOSBOX in XP I have tried a USB and Game Port Joystick, I have viewed miles of threads on people wanting to make this work. I would be willing to pay someone to develop a patch. Anyone who has the ability let me know.
     
  2. Ghostcloak

    Ghostcloak Spaceman

    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Behind You...
    Aye.. I've gone through the same trouble of looking through other threads... My problem is i can pass the cailbration in-game fine... But it doesn't calibrate it exactly perfect... I have a little turn to the right, sometimes downward. I'm using the USB Microsoft Sidewinder Force Feedback II. It worked fine in Privateer... I don't get it.. I've calibrated it in Windows.. I've calibrated it a billion times in Armada... But always when i go fly in armada, i'm slowly turning to the right or diving downwards (and its not a constant motion.. its jerky when it does it...) I dunno what to do.. :'( Flying with the keyboard is hardcore tough yo.... can't coordinate my rolls/dives/slides all at the same time! HOW DO THEY DO IT IN STAR TREK!?!?!? :p
     
  3. Vengeance

    Vengeance Spaceman

    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Oregon
    Armada Joystick

    I don't know Ghostcloak, you have gotten farther than anyone I know. My USB Logitech Freedom just goes nuts. DOSBOX handles the same joystick in everything else I have running in DOSBOX from WC1 to Privateer. What are your Machine Spec's?

    With all the smart programmers I read about in these sites it is a wonder that nobody can figure out how to make it work. That's why I offered to pay someone to write a patch but have had no reponses from any of the talented programmers. :(
     
  4. THE_WUQKED

    THE_WUQKED Spaceman

    Messages:
    582
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Germany
    Now you know two, who got so far. - I can get it to actually run under Armada as well, but with the exact same problems like Ghostcloak has. And I've read about other persons in other forums who got so far, btw.
    Anyway, you were interested in the system specs:

    Abit IC7-G
    Pentium IV 3.2Ghz
    2x 1GB DDR 400Mhz
    Radeon X800Pro Vivo @XT
    Audigy2 ZS
    2x WD Raptor 74GB in Raid 0
    Windows XP SP2
    Dosbox 0.63
    Armada Floppy Version
    and most important for the prob, I'd guess:
    Microsoft Precision Pro USB Joystick

    So my guess is: Maybe it's cause we both have got MS joysticks (USB) and so can at least pass the Calibration. But that doesn't help us at all :(

    For my dosbox.conf, see here:
    http://www.crius.net/zone/showthread.php?t=16383
     
  5. Vengeance

    Vengeance Spaceman

    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Oregon

    Thanks for the spec and your comments. I still wish we could find someone to dig into the problem and write us a patch. The game is just a great game but just unplayable without a calibrated joystick.
     
  6. Ghostcloak

    Ghostcloak Spaceman

    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Behind You...
    My fault... out of town for a while :p

    Comp specs:

    2.80 GHz Pentium 4
    512 MB PC3200 DDR SDRAM memory
    160 GB 7200 RPM Ultra DMA Hard Drive
    8x- DVD/CD-RW Drive
    48x- CD-ROM Drive
    1MB L2 Cache
    800 MHz Front Side Bus
    Fully updated Microsoft Windows XP Home Ed.
    Microsoft Force Feedback 2 (USB)

    Armada Floppy Disk Edition
    Dosbox 0.63


    Hope this helps guys...
     
  7. wiffle

    wiffle Spaceman

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    in the bushes
    tried to run on hardrive

    Hi guys,
    tried to mount the game on hardrive but doesn't respond.
    All works well except is glitchy and locks up on some missions. increased frame rate to 11000. What is protocol for dos settings for poiting to hardrive rather than running cdrom I wonder?
     
  8. Ghostcloak

    Ghostcloak Spaceman

    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Behind You...

    I dunno exactly what your asking for.. but here's what i had to do.

    I had saved the original info. of the diskette version of Armada on my computer (I have over 25 gigs of just old games stored on my computer h/d lol...) and had copied those to another folder for easy location in dos... Then i did the following in dosbox:

    mount a c:\dos\armada
    mount c c:\dos\armada
    cd\
    c:
    install

    now when i typed in those commands, i got ready to install the armada diskette information. KEEP IN MIND, you have mounted the disks under an "a:" drive as well. So, dos thinks you have a diskette there in your a: drive and can install the game accordingly.

    You can mount a drive to any name from "a-z" lets say your cd drive is labled "e:", but you want/need to install from it as if it were your "a:" drive, you type in the command:

    mount a e:\

    basically the first letter stands for the drive letter you wish to assign the mount. The second "phrase" if you will, helps to designate which pathway will be mounted into the drive. Thus, if you say

    mount b c:\dos

    Everything in c:\dos is now the root directory of b:\

    Get it? I hope this somehow helped.. as it is past 2:10 am in the morning and I'm next to my lovely bed and should probably zzzzZZzzZZzZZzzzZZZZzZZzzz.... *passes out*

    *wakes up*
    oh.. and if you want to switch between your mounted directories, just type

    cd\
    "drive letter"

    ie: I want to go from my mounted a:\ drive to another drive i mounted under c:\

    cd\
    c:

    there ya go... now i die >_<
     
  9. Unregistered

    Unregistered Guest

    Joysticks

    I have had problems with the joystick - when you fly it shoots fine but there is no directional control at all. Spiralling all the way...


    I have been told by my friend, who got this game otherwise up and running in 2 hours from scratch!?!?!?!?, that dosbox only supports the 2 button joysticks. Is this true?

    I use the mouse which actually works real well once you get used to it, for me its almost as good as a joystick.

    Other thing is: the game runs fine but

    - a bit jerky when lots is happening e.g. in dogfights, nearing planets, whilst using afterburners

    - All videos in game have static flashing on screen every 3-4 seconds

    - All animations are slow and sometimes jerky

    Any ideas how to fix this? Sorry if this is repeating stuff my technical knowledge is laughable.
     
  10. Unregistered

    Unregistered Guest

    Armada Questions

    I had two questions about armada. I got it running in dosbox .63, although I can't get the sound working, so theres the first one. Second, I downloaded the joystick/ipx patch and when it starts up I calibrate my joystick and it asks to calibrate a second one, which won't calbrate ( I tried plugging in a second one). When I try to skip or click on something, the game crashes. Any help would be appreciated
     
  11. Unregistered

    Unregistered Guest

    Privateer Remake

    Hi,
    If you want to play Privateer again, check out the following website.
    http://priv.solsector.net/
    There you will find a Privateer Remake which includes the Expansion Pack and an extra Plot which you will encounter in the Expansion Pack.

    This Remake runs under WinXP without any problems. This is almost exactly like the old Privateer.

    Just download version 1.2 and enjoy playing.

    Have Fun
     
  12. AD

    AD Finder of things, Doer of stuff

    Messages:
    4,956
    Likes Received:
    115
    Trophy Points:
    36,885
    Location:
    BC, Canada
    Needlessly advertising your mod in a two year old thread is cheap. Besides which it is *NOT* exactly like the original version. And this doesn't in any way help anyone running the originals they already have.

    Don't do it again.
     
  13. Unregistered

    Unregistered Guest

    Wing Commander Armada crashes when playing Armada Mode

    Hi there.

    First off, i've not read the complete thread yet, but far enough to see that most likely none of you have experienced the following problem:

    Wing Commander Armada runs smoothly on DosBox 0.70 at 16000 cycles in original speed and in full screen, while it totaly sucked on DosBox 0.63 on the very same Computer. All I needed to do was setting ems=false. On DosBox 0.70 I've run armada both with and without the loadfix. Plus, I played Armada with the DosBox patches for Joysticks and IPX Network, but since I experienced massive problems in calibrating and using my gamepad (simple 10 buttons 2 axis gamepad USB from logitech) i just went along with armada.

    Now, my REAL problem. The game runs really good. But whenever i play the armada mode (armada or campaign), the game randomly crashes when I end a turn. Not weird enough, it happens mostly when playing on ace difficulty level. So far it seems NOT to have anything to do with the faction you play or how large the map is.

    When it crashes it has something to do with memory and cpu registers, as I am presented an error code as well as the values of cpu registers such as eax etc...

    Due to this, cpu core and memsize were my main suspects. I've set memsize to 32 mb and set the cpu core to normal, using 16000 cycles ever. But that didn't help. The game runs well in gauntlet mode, ocasionally crashes in battle mode / split screen and since the original game doesn't run well i did not yet even try to use armada proving grounds.

    I would be thankful if someone could help me with that.

    You can also contact me by email (tpechtel@web.de)

    Best regards,
    an unregistered Guest (being deeply in love with wing commander armada since 1994)
     
  14. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,551
    Likes Received:
    361
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    I've had a few random crashes that sound like that. They seemed to go away moving from 0.63 to 0.65. I would suspect the core too, but since you're already at normal, that should be fine. Maybe crank the memsize down to 8 megs. Are you running with the Origin Armada patch? Have you tried different loadfix settings? No number, 1, 32, 64, 65 are candidates.
     
  15. Unregistered

    Unregistered Guest

    Hiya,

    Already had the same idea, since i've read about memsize in dosbox on several other forums. Setting memsize too big could cause crashes. So i already reduced the memsize to 8 and that seemed to work out for a while. Yesterday I played 3 matches in armada mode to the end, each one taking 60-90 minutes, one with the origin patch, the other ones without it. I can't stand the origin patch, since it instantly kills the already tricky joystick support in dosbox. Using my gamepad with that patch lead the well known problem of being stuck to fly down and left all the time. Since I reduced memsize to 8 megs AND used the armadapatch at the same time playing the first armada match without crashes, I can't say wether the memsize or the patch (or both?) solved the problem. Without the patch I could play 2 matches as well. I will try the different loadfix values you cited here. Cant' use armada patch because of the gamepad (which heavily increases my accuracy in kickin' some butt out there), can't use the dosbox patched exe files for the very same reason. I need to get that game rub stable without all this stuff around.

    Thanks so far,
    Unregistered Guest
     
  16. Unregistered

    Unregistered Guest

    Changing loadfix values didn't help. *sry for spamming*
     
  17. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,551
    Likes Received:
    361
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    Does that mean you went back to having crashes? You should register so other people can keep track of which messages are yours, and then you can also edit posts within a couple hours of when you made them.

    Have you tried running without sound? It could be some odd incompatibility. DOSBox is pretty good at emulating a soundblaster, but occasional some new sound chipsets can cause conflicts.
     
  18. Unregistered

    Unregistered Guest

    It's me again. Yes, it went back to crash. But one other thing: I finally found out on WHY that damn dosbox patch set messed up my Joystick Config. It wasn't the DosBox patch after all but the timer settings in the dosbox.conf. After deactivating this aspect (i set every aspect i didn't fully understand to false and readjusted the joystick back to auto. it was 2-axis before that) i did the following.

    I installed the Origin Armada Patch I found on the net. The one offering the AJ.exe for Jostick Calibration and Passwords for the Gauntlet. After that I overwrote the included joy*.dat files with the dosbox patch ones. I tested this config, found out about the dosbox timer setting, experimentally tried a recalibration first with AJ (it sucked), then deleted the .dat files again and used simply the armadadb.exe which started calibration by itself. This time, two joysticks were found. I calibrated the first one - my gamepad - and tadaaa! This time i didn't get the weird "bad calibration data" error message again! After this i ignored the none existing second joystick by pressing escape. After that I played Gauntlet Mode for testing my settings and ... well .. it works. I can use the Armada Patches now with my gamepad working within normal parameters. I will test now on how this armada patch will increase the stability of the armada mode.

    Well, you are right. I should register. But tell you somethin'

    I'm happy you helped me out, but why should I register ? Yes, i love wing commander, played most of the games on different systems. But i am not such a fan like most of you are. I like the games and I like to play them ... but that's it. I don't see any reason to register here because I would simply not write that much here, would not engage in this community worthy to be mentioned. I would only be kinda trash in the account database. I had a question. I posed it. I was helped in a friendly way. I am thankful. But, by all due respect to the work of the fans and the community, thats it.

    Don't take it personal, wilco ?

    MfG
    Grayfox, the unregistered Guest
     
  19. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,551
    Likes Received:
    361
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    Well, registering would take less time than it took to write this out. And there's five thousand accounts here registered to people who don't post, so one more won't clutter anything. It just helps others who might come by to try to read up on your situation (either to help or fix their own problem).
     
  20. Unregistered

    Unregistered Guest

    Trouble with Armada: PG multiplayer

    Hi all,

    I'm stuck trying to pull a multiplayer match together for Armada's Proving Grounds. My friend and I can both get into the game fine when EMS=true, but when EMS=false, we both get the same error message: "Network driver detected. Cannot switch to protected mode safely." If we leave EMS=true, we are unable to see each other in the Proving Grounds interface. We both have IPX=true. Any ideas?

    -Chris
     

Share This Page