Prophecy and Secret Ops in XP (was: WCP video question)

ChrisReid

Super Soaker Collector / Administrator
The next versions of the high resolution patches will allow you to input higher custom resolutions. I believe 1280x1024 will be a limitation of the 3dfx mode, but Direct3D has been tested in higher/alternate resolutions such as 1680x1050 widescreen.
 

Tigerhawk

Captain
THE_WUQKED said:
Try out the "video skip fix" made by HCl - it's in the wcnews files section:
https://www.wcnews.com/files.shtml#wcp
Normally that should work ;)
Good luck.

Call me JohnnyComeLately...

I'd pasted that fix file probably six months ago, and just last night got around to actually trying it out. Haven't turned off a thing or dumbed down any part of my computer (1.4G Athlon, GeForce 6800, SoundBlaster Audigy 2, 2GB of RAM) and it does run the movies like they used to run on my old Pentium II. It was great seeing the movies at regular speed again, and especially listening to Maestro...that dude's hilarious.

--------------------------------------------------------------------------------------------------------
Casey: "Guess it really was his private reserve, huh?"
 
Last edited by a moderator:

Moonbars

Spaceman
This would appear to be the right thread.. dont want to start a duplicate.

I have recently decided that I need to play Prophecy again. I'd like to use the Hi-Res patches, for WCProp and Secret Ops. However, I have 2 problems:

1) Prophecy - Hi-Res patch "install.exe" crashes after I type in a res (have tried numerous different resolutions - 800 x 600 being the usual) and press "install". It makes a new file called "patch.tre" which is 88Kb in size, before it crashes. I've tried the fix from HCI's website - same problem. I've tried renaming the files in the patch folder, and can generate error msgs telling me those files are not present - so I am confident that the installer can see the patch folder and it's contents - Any ideas guys? How large are your patch.tre files? Does the installer modify any other files? If not, could somebody post me their patch.tre for direct3D 1024 res??

Secret Ops works, which is annoying as it has me excited to see what prophecy looks like in hi-res... However, in secret ops I cannot get 32bit to work, I get a crash when starting the game that says: "GL_d3d_5::createZBuffer attach failed 87". Any ideas what I can do about that?


My system:
Windows XP 64bit (rather thinking this might be the problem..)
2 gig ram
Nvidia Geforce 6800 gpu
3 Ghz Intel P4 extreme edition

Any help or suggestions very much appreciated.
 

ChrisReid

Super Soaker Collector / Administrator
Moonbars said:
1) Prophecy - Hi-Res patch "install.exe" crashes after I type in a res (have tried numerous different resolutions - 800 x 600 being the usual) and press "install". It makes a new file called "patch.tre" which is 88Kb in size, before it crashes. I've tried the fix from HCI's website - same problem. I've tried renaming the files in the patch folder, and can generate error msgs telling me those files are not present - so I am confident that the installer can see the patch folder and it's contents - Any ideas guys? How large are your patch.tre files? Does the installer modify any other files? If not, could somebody post me their patch.tre for direct3D 1024 res??
Do you have the install file in the regular Prophecy folder, and are you sure you copied over the four necessary files to the patch subdirectory?

Moonbars said:
Secret Ops works, which is annoying as it has me excited to see what prophecy looks like in hi-res... However, in secret ops I cannot get 32bit to work, I get a crash when starting the game that says: "GL_d3d_5::createZBuffer attach failed 87". Any ideas what I can do about that?
The game was made in 16 bit color, so certain video cards and driver sets conflict if you try to force higher.
 
U

Unregistered

Guest
ChrisReid said:
Do you have the install file in the regular Prophecy folder, and are you sure you copied over the four necessary files to the patch subdirectory?
install.exe is in E:/games/Prophecy
data, gf, gf2 and gf3 are in E:/games/prophecy/patch

If I rename or remove any of those files, the installer will give me an error saying it cannot find the file - so I am 100% that the files are in the right area.. Any chance you could post your patch.tre file, which appears to be the only file that the installer makes?? Might be worth a shot for me.

ChrisReid said:
The game was made in 16 bit color, so certain video cards and driver sets conflict if you try to force higher.
Ah, that explains that one then.
 

ChrisReid

Super Soaker Collector / Administrator
My patch.tre is 230 megabytes. It's also created specifically for my 3dfx selection and resolution. I'm typically hesitant to introduce unstable variables into these situations, but you could try installing the 3dfx glide wrapper. https://www.wcnews.com/news/update/6525 If the game itself then runs in the superior 3dfx mode, you might try installing the high res patch for 3dfx. If that doesn't work, I wonder if some part of your Prophecy installation is just corrupted. Have you tried un/reinstalling it recently? Maybe in the default directory?
 
Last edited by a moderator:

Moonbars

Spaceman
It's freshly installed and I've tried reinstalling it. I also tried the glide wrapper for the same results when using the install.exe. I just dont think that install wants to work on my 64bit XP.

Anybody with a D3D 1024 x 768 patch.tre file willing to email it to me? james AT mcquiggan DOT demon DOT co DOT uk

Possibly the 230mb size could be reduced by zipping.. but maybe not if it's compressed already.
 

cff

Kilk'dymga'qith laq Ik'vikvi
64 bit version of XP? Ohohoh... Thats at least a very possible reason for the problem.
 

PopsiclePete

Mission programmer
cff said:
64 bit version of XP? Ohohoh... Thats at least a very possible reason for the problem.
The patch DLLs were made with 32bits memory space in mind; while I am not sure how WinXp 64 bits handles 32 bits applications, I am pretty sure it could cause problems. Gotta ask HCl.
 

michall

Spaceman
Hello, I have some strange problem here, cut scenes run by normal speed without any sound problem but after few minutes some of them crash at all with windows error message, im using win xp sp2, i have tried turning off sound acceleration, and win 95 compatibily with no effect, pls if anyone know how to fix it let me now, pls
 

ChrisReid

Super Soaker Collector / Administrator
What game are you playing? Did you also try Windows 98 compatibility mode? Also try turning off video acceleration. What is the error message that you get?
 

michall

Spaceman
im playing Prophecy, i have tried win 98 compatibily as well, with no efect, and tried turn off video acceleration, but game wount run at all with messig:please reinstall (GL :: resize quary failed), that messige from failed FMVs is standard win xp error like :"AppName: prophecy.exe AppVer: 0.0.0.0 ModName: prophecy.exe
ModVer: 0.0.0.0 Offset: 000c4179" some of cut scenes goes perfect, but some of them crashed, and i love that small movies, pls if you know how can i fix it help pls
 

ChrisReid

Super Soaker Collector / Administrator
Try playing in software rendering mode or uninstalling the game and reinstalling with a different setting (minimum/medium/maximum). Are the same clips crashing each time? You could also try seeing if it's related to the sound by adding these two lines to prophecy.cfg:
useDirectSound=0
useStreamer=0
And then starting the game with a batch file with the text:
prophecy.exe @prophecy.cfg
 

drrichard24

Spaceman
Secret Ops on XP

I have a Centrino duo toshiba with intel graphic accelerator card of 128mb, and windows media center edition 2005, previosly on another laptop with WXPMCE 2004 i had the same problem than most of you of having problem with video skipping. But now the prophecy run just right but the secret ops don't even starts. It crashes because an unknown error and needs to close. Can anybody help me?
 

AD

Finder of things, Doer of stuff
drrichard24 said:
I have a Centrino duo toshiba with intel graphic accelerator card of 128mb, and windows media center edition 2005, previosly on another laptop with WXPMCE 2004 i had the same problem than most of you of having problem with video skipping. But now the prophecy run just right but the secret ops don't even starts. It crashes because an unknown error and needs to close. Can anybody help me?

Did you install the hi-res patch for secret ops? Did you remember to set the compatability mode on the secretops executable and not just the Prophecy one?
 
U

Unregistered

Guest
G'day all,

I have the same problem as Moonbars above which I have displayed below.

1) Prophecy - Hi-Res patch "install.exe" crashes after I type in a res (have tried numerous different resolutions - 800 x 600 being the usual) and press "install". It makes a new file called "patch.tre" which is 88Kb in size, before it crashes. I've tried the fix from HCI's website - same problem.

I've tried the glide wrapper, tried reinstalling, tried every method on the other problem threads, all to no avail.

Computer specs:

32bit XP
Nvidia 7900 GT
SB Audigy2
AMD 4200
 

AD

Finder of things, Doer of stuff
G'day all,

I have the same problem as Moonbars above which I have displayed below.

1) Prophecy - Hi-Res patch "install.exe" crashes after I type in a res (have tried numerous different resolutions - 800 x 600 being the usual) and press "install". It makes a new file called "patch.tre" which is 88Kb in size, before it crashes. I've tried the fix from HCI's website - same problem.

Did you copy the required Tre files to the harddrive before running the patch installer?
 

ChrisReid

Super Soaker Collector / Administrator
Might not be related to your problem, but I don't think the glide wrapper works with the Geforce 7.
 
U

Unregistered

Guest
Same guy (Jim) with the problem similar to Moonbars.

All the tre files I need are in the patch folder so that's not the problem. I've tried different size installs, disabling sound acceleration, using the prophecy.cfg file with different option to no avail.

More info on the crash. In Prophecy, the game crashes at exactly the same point every time during the cutscene straight after you type your log in. The two guys walk into the elevator and then the game crashes.

I've also downloaded the DVD VOB files and applied the patch to replace the old cutscenes with the high quality videos, however the old cutscenes always play. I've followed the instructions at CIC to the letter so I'm not sure why it isn't displaying the new movies.

I have just installed Secret Ops and that works fine with Win95 compatibility mode.
 
Top