Wing Commander 4 DVD in WindowsXP (w/ DirectShow)

Small Question regarding the video...

This may seem like a kind of stupid question, but i don't have the DVD version yet...Having owned the 6-cd version of the game, is the quality of the video on the DVD version better than that of the 6 disc version, or is the DVD simply a repack of the 6-disc version?
There are two versions of the DVD.
The single sided one is just the 6 CDs on one DVD
The double sided one has something close to DVD-Movie quality. That one needs special hardware however. Thanks to the recent DirectShow patch it should however work on all systems now.
OK, now here I am with my fresh new copy of the WC4 dual-sided DVD and, of course, it doesn't work:

I installed the game normally (running XP on a Notebook), applied the patch from this thread and that AC3-thingy and set to WIN98 compatibilty-mode. When I double-click the icon, my display switches to a larger resolution, then back to normal and nothing happens. I'm back to Windows.

I rather ignorant about technical things so you might have to be patient with me. Or ignore me - but I hope you chose the former option. :)

On a side note: is the DVD thicker than a normal CD? I have the impression that my slot-in (are they called that? Those that are only a small slit in which you push the CD/DVD) has more problems giving the WC4 DVD back and sucking it in.
Ok, new problem. Although I am not sure it has to do anything with the patch to make the WC4 DVD work. And this problem is truly breaking my heart as I am so close to beating the game.

I am running Win XP with the WC4 DVD. I installed the v1.0 patch last week and the game as been playing flawlessly since then... until now. I am in the Ella system where I get to choose if I want to use the flashpack on the Starbase or fight my way through the hard way. I have tried both missions no less than 8 times. No matter which I choose, I will go through, win the mission, land on the Intrepid and that is it. The screen goes blank like it is about to play a movie and never does. When I ALT-TAB out to my desktop my system has the WC4 window and a Direct Show window active.

I have tried the following to get past this and nothing works:

1. Changed the process priority of the program
2. Ejected after winning the mission (Plays ejection video, then stops)
3. Turning off my anti-virus
4. Cleaning the disc (didn't need cleaning though)
5. Letting the blank windows sit for about 5 minutes.
6. Pressing a bunch of keys on the keyboard.
7. Rebooting my computer

Nothing works! Except if I fail the mission, I get the bad ending to the game. That works. It's almost if just that video in particular is hosed. I just don't know what to do at this point. Help?
Edfilho said:
Mekt, did you read the rest of the thread? lot's of troubles were solved already.

Yep but nobody seemed to have the same problem as me (game not starting). Changing the Mpeg decoder helped solve that problem. Now still there are movies not playing: starting with the Orlanda Depot cutscene not showing, then the scene to Confed HQ is fine, as is the Eisen conversation. But then the jump sequence to Hellespont again is screwed up. I tried out all of the versions and upgrade 3 seems to work best for me, i.e.: Depot and Jump sequence play about 5 seconds before stopping.

I'll run later the debug build.

But no matter what: it's really cool that you managed that patch! :cool:

Edit: Here's the debug log (rename to zip), I hope I did it right. Will be in German too probably...


    7.4 KB · Views: 240
ok some notes:

for those having sound issues where the video plays soo damn low u cant hear it, and then blair BLASTS you with his voice when a choice comes up... this is b/c your soundcard settings are high for voice, and the FMV decoder u are using is set low.. if u are using the ac3filter (which u should!) go to start menu, then ac3filter, then config and set all the gains to high... then voila.. awesome sound parity !

also, i had issues with the game where when a fmv scene was queued it would crash to a blank screen... switching off sound acceleration in dxdiag (same issue in wc prophecy) solved this for me...

good luck !

win 2k

I am running win 2k

I the paches work fine till i get onboard the lexington and then i only get the sound and a navy blue screen. after that i go to another movie and i get a still image of the last dvd movie that worked!

i am using win DVD 4

can any one help
WC 4 DVD Patch

I've got a different problem possibly -- whenever it's time for a movie to run on my system the game says 'E:\wcdvd\' not found. The disc is in, the files are there (I can even load them and watch them on Win DVD).

Help? I'm running Windows XP on a 2.6 GHz Athlon.

Now i am using wimblowz XP and i get you to the mission where you have to get past the super base (side 2) and the movie stop working again (black screen) pressing Esc dosnt do a thing
(must use Ctrl + Alt + Del)

Hi Gulikoza

the link in your mail to the returns 'cannot find...'. Any suggestions.
My little son has been trying to run WC4DVD without success and has Windows XP. I was wondering if you could help. Thanks for your earliest attention.
WC4DVD Double-sided

Hi all,

There is some additional information about my little son's problem with running WC4DVD. Its a double sided DVD and returns the VirtualProtect() error. We have tried the Fix for the error provided by NStriker; it sits idle in a window with 'Patch' and 'End' icons after saving and running the unzip programs; when we click 'Patch' it returns the message 'couldn't open the file'. Your suggestions are most welcome. As I said earlier, he has Windows XP Home edition.
my exe file is dated the 16th of september 1997 and the mpeg2.dllis the same date, program works until the choice is given and the program crashes.

any ideas?
Sorry ment to post error message:

The Instruction at "0x7484c946" referenced memory at "0x02d07fd8" The Memory could not be "read" Click Ok to Terminate.

Hope someone can help....
reed20 said:
I have wing commander prophecy and will this work with it also when i run it on my pc ???

I have no idea what your asking... If you are saying yo have the WC prophecy DVD (one of the WC holy grails as it was never distributed) then we would LOVE LOVE LOVE to hear from you.

Otherwise the wc4 dvd patch from Gulikoza will be absolutely usesless your running wc4 of course. Otherwise search the CIC for HCLs Prophecy highres patches and possibly if you wish a link for a glide wrapper to run the game in full 3dfx emulation on current generation video cards. (You might need to set the compatabiliy mode for the prophecy executable to win95 or 98 as well)
Sorry for resurrecting this old thread, but it seemed best to post here. I've released one final version of DXMCI and the sources under GNU GPL. The latest version adds support for Starfleet Academy DVD (maybe not so interesting on this board :D) and an option in the configuration for forcing mpeg2dec (so dxmci can work alongside PowerDVD, forcing mpeg2dec to be used). I don't have time to work on it (haven't had time in a while, but WC4 seems to have worked pretty well, mostly just DirectShow and codec problems) but this way somebody can improve it or fix it in the future (Vista and beyond...). I still enjoy reading the wcnews site and this board, so I'll still drop in occasionally :)
Neato. Thanks again for making this whole thing gulikoza! It's a key part of of our modern bag of tricks to getting just about every WC game playable on modern computers.
I hope I'm not re-inventing the wheel, but.. I still have problems. I've tried it in WinME.. (yeah, laugh), but also XP Pro and got the same results.
What I have tried: dxmci, ac3filiter, dvdpatch,mpeg2dec, but nothing helps...
Result: Starts black. (sometimes it starts with the menu). Then I get the two choices, but with black background.. and it can't find the vob file...

I have the double sided DVD.. what other info would you need? (is there a sticky anywhere that tells you ALL the steps you can go thru to get this thing to work?)
We'd need to know more about your video card and its settings. How did you test it under two operating systems? Was this on two computers or some kind of dual boot setup?