WC4 DVD Problems

TurboTim07

Rear Admiral
yep... ok. first i had the first patch and got all excited. it didn't work. so i told gulikoza and he made the second patch. installed it and got the second mpeg2.dll file and put that in there. and got AC3Filter and installed it. the intro worked so i quit out assuming it all worked. this a while ago. recently i tried playing the game again. first movie scene worked and i got excited. picked my choices and got going to the first mission. beat maniac at the dogfight and got to the orlando depot. but then seether blows up the station and the cutscene's suppose to come up showing him launching the two torps and wrecking the base but all i get is a black screen and the game hangs :( . so i go back and download the newest patch for the alternate, stuck it in the same directory and tried running it. but then it says it couldn't open the file. :confused: so now what do i do?
 

ChrisReid

Super Soaker Collector / Administrator
Is there a joke I'm missing? I'd guess you probably want to clear out that install folder and copy stuff back over if the copying and recopying so far locks things up.
 

gulikoza

The DVD Patch Guy
yeah, i thought about this a little...but there's really no reason for it to work earlier and lock up now. Try using mpeg2dec...
 

TurboTim07

Rear Admiral
<sigh> ok... i've tried that... it didn't work. i even tried uninstalling WC4 and reinstalling and trying each of the patches. and it still doesn't work. when i try to use the alternate patch it says

Error!
Could'nt open File!

exactly like that. :( i remember you sent me an email with just the fixed exe file but i dunno where i put the extra. so now im stuck :( sorry for all this inconvenience.
 

gulikoza

The DVD Patch Guy
ah! you're talking about VirtualProtect() error patches? Those were created by NStriker. How about a clean install, install only dxmci & set compatibility mode to win98?
 

TurboTim07

Rear Admiral
ok. i did a clean install. tried the first few versions of dxmci and they worked except they couldn't show the movies saying there was a missing vob file or something like that. so then i tried version 1.0. i get

wc4dvd.exe - Entry Point Not Found
The procedure entry point ?openMovie@MPEG@@SAHPAXPAD@Z could not be located in the dynamic link library mpeg2.ddl

tried the latest version 1.2. get the same error

gonna try using the mpeg2dec.zip right now... nope didn't work still :( and i've already had AC3 Filter installed

downloading alt mpeg2.dll.... ok. it's working. but now when seether blows up the station, it show the little encounter between seether and blair at the bar... ok trying other versions. again. ok... they worked in their own ways but had problems such as not showing a video but hearing sound and such. now im gonna try them each with the alt mpeg2 still and the mpeg2decoder....

ok. original's a no go. update 1... no go either. update 2...negative. ok. update 3. nope. so far the intro movie works but after that it's sound only and no video. trying 1.0. ok first few works. then hangs at seether blowing the station. 1.1 is the same as the updates. 1.2 same as 1.1. so right now........... ok... i just tried 1.1 again without the decoder and it worked perfectly.... strange.... well so right now 1.1 is my best bet. im gonna try it one more time to see if it works right. again. and now it doesn't... odd. a second ago it worked and the video and sound played. and the right ones too... and now it doesn't show video but plays sound... i wonder... i dunno. i'll keep working on it to see if i can't figure out what's up. if you can help me i'd be really thankful. thanks.
 

gulikoza

The DVD Patch Guy
You need to use alt mpeg2.dll with every patch version. Your WC4 version seems to be somewhat different than mine so it might be impossible for me to fix it...But, dxmci actually is not that complicated - it just hands the video file to directshow for playback so manymany problems can be traced to dshow rather than dxmci :)
 

TurboTim07

Rear Admiral
i was using the alt one when i listed how each one was working. but i'll go back later today and try them all again with the alt and let you know how it goes.
 

TurboTim07

Rear Admiral
Alt mpeg2.dll
intro is the intro movie. cutscenes are the two scenes where you make choices (Help Him Out vs. Straighten Him Out and This Pisses Me Off vs. Ain’t My Business). Seether scene is the one where he blows up the station
1st try dxmci original
1st – intro - ok. cutscenes - skips first second or so then plays. seether - skips straight to shockwave part
2nd – intro - ok. cutscenes – sound but no video. seether – hangs on black screen
3rd – same as 2nd attempt
2nd try dxmci update
1st – same as 1st try attempt 2
2nd - same as 1st try attempt 2
3rd – into – ok. cutscenes – skips a second then plays. seether - freezes
3rd try dxmci update2
1st – same as 1st try attempt 2
2nd - same as 1st try attempt 2
3rd - same as 1st try attempt 2
4th try dxmci update 3
1st - same as 1st try attempt 2
2nd – into – ok. cutscenes – ok. seether - freeze
3rd – same as 1st try attempt 2
5th try dxmci 1.0
1st - same as 1st try attempt 2
2nd - same as 1st try attempt 2
3rd - same as 1st try attempt 2
6th try dxmci 1.1
1st – same as 2nd try attempt 3
2nd - same as 1st try attempt 2
3rd - same as 1st try attempt 2
7th try dxmci 1.2

1st - same as 1st try attempt 2
2nd - same as 1st try attempt 2
3rd - same as 2nd try attempt 3
 

gulikoza

The DVD Patch Guy
It's true I haven't checked wc4 in a while...perhaps there are some windows updates (sp2?) that are making life difficult...I'll check it out.
 

gulikoza

The DVD Patch Guy
sorry for the delay...I had to reinstall my machine :p

I have a test version here. It's not exactly what I want yet but it might work for you. The problem seems that something is not reset between cutscenes so the obvious first try is to restart DShow after every clip. This will also means a slight delay before each video since DShow is loaded again...please tell me if this cures some of the problems.
 

TurboTim07

Rear Admiral
ok. the videos play which is great. but there's skipping and the sound keeps going then the video continues and after a while goes fast and catches up. but i quit and tried it again just to be sure that it would work the same the second time and it does the same thing. so now the videos will play they just stutter. thanks for your help and sorry for more problems
 

gulikoza

The DVD Patch Guy
Another highly experimental version. This one is more like v1.2 but it will try to reset some dshow filters. I need you to test this to see which way to develop the next version (reset entire dshow or try to salvage it :) ). Also...is the delay between clips more noticable in the previous test version? I have a clean system, my dshow is lightning fast LOL
 

TurboTim07

Rear Admiral
ok. this one loads videos faster and it doesn't stutter like the previous one does. but it freezes on the second choice (Ain't my business vs. This pisses me off) whereas the previous one had no problems loading each of the cutscenes. :(

but don't try anything yet. i will try it again tomorrow to see if maybe i just needed to restart my computer (it's late over here now and im bout ready for bed) so i'll try it tomorrow and i'll let you know how it goes :)
 

gulikoza

The DVD Patch Guy
I don't think it'll work :) But anyways, here is hopefully the last test version. It should work like the first test version, maybe slightly faster and hopefully not skipping videos. If this works I'm probably gonna have to make some sort of compatibility slider for dxmci to choose the amount of optimizations before releasing 1.3 :p
 

TurboTim07

Rear Admiral
well actually.... it worked perfectly with this one :confused: thanks for you help and i hope that in saying it works i didn't just jynx it and broke it again :( thanks so much for your help
 

gulikoza

The DVD Patch Guy
Why the :( ... it'll work I'm sure :). Well, thanks to you for testing this extensivly..I'll try to implement some of this into the next version (just about for the 1st anniversary of 1.2 :D). Btw, how's the delay between clips in test3?
 
Top