Privateer Remake 1.0 - Bugs

fyodor

Spaceman
* Torpedo / Missile Launcher bug: The launchers have a severe propensity to get out of sync. That is, the left launcher always fires first, so when you fire over a single torpedo, wait a few seconds, fire another etc., you can actually run out of torpedos on the left launcher while not using the right launcher at all. When firing multiple torpedos, there's a 50/50 chance that the left launcher will fire last as well, leaving you (again) with more torpedos in the right launcher than the left. The bug appears for missiles as well, but is (in my experience) less annoying / noticeable.

The obvious solution would be to switch "active" launcher after each fire. Presumably, the code currently tries the left launcher and then only fires the right launcher if the left fire was unsuccessful. The proposed fix requires keeping tabs of which launcher fired most recently, which may or may not be easily available. An easier, alternative fix would be to simply fire from the launcher with the *most* ammo at the time.
 

Fatcat

Swabbie
Banned
Another thing is with armor. Once, I got hit so hard that all my forward armor was gone (ALL OF IT, the stats said 0 MJ). After repairing it, forward armor was still at zero. I had to sell the ruined one and buy another. Now, I'm not sure that's so wrong. I mean, it does look like a bug, but it actually makes sense (there's nothing left to repair, it's all gone).

But my ship only lost about half of it's armor, and the repairs still do nothing. Help me Privateer Remake Team, you're my only hope!
 

mesaana

Spaceman
sound and music at the same time in linux

Hello, great game! I'm having a problem playing sound effects and music at the same time in linux. I've read various other threads which advise making additions to .openalrc. This does not seem to work (with the binary distro of priv). The instructions seem to be completely ignored by vegastrike. I've included output from strace which illustrates the problem.

Here is the relevant output, it opens .openalrc, reads the contents, and then goes on its merry way opening /dev/dsp, completely ignoring the instructions in .openalrc. I tried this with esd, arts, alsa, etc. I tried it with ;; at the beginning, and without, nothing makes any difference, it never even tries to stat the esd/arts socket.
stat64("/home/eric/.openalrc", {st_mode=S_IFREG|0644, st_size=41, ...}) = 0
open("/home/eric/.openalrc", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=41, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40
aad000
read(3, "(define devices \'(alsa esd arts "..., 4096) = 41
close(3) = 0
munmap(0x40aad000, 4096) = 0
open("/dev/sound/dsp", O_WRONLY|O_NONBLOCK) = -1 ENOENT (No such file or directo
ry)
open("/dev/dsp", O_WRONLY|O_NONBLOCK) = -1 EBUSY (Device or resource busy)
write(2, "open /dev/[sound/]dsp: Device or"..., 47open /dev/[sound/]dsp: Device
or resource busy
) = 47
open("/dev/sound/dsp", O_WRONLY|O_NONBLOCK) = -1 ENOENT (No such file or directo
ry)
open("/dev/dsp", O_WRONLY|O_NONBLOCK) = -1 EBUSY (Device or resource busy)
write(2, "open /dev/[sound/]dsp: Device or"..., 47open /dev/[sound/]dsp: Device
or resource busy
) = 47
 

bluewizard

Spaceman
Fixed my problem

I was having control problems in the concourse and in space. Nothing was working right. Then a light dawned...[actually a small night light]. Another program was crashing every now and then with a program called ReClock. What the docs on this program say is that it adjusts the frame rate for various graphical display ie Windows Media Player. What if it was also affecting some games when they tried to run their own graphics protocol. So a quick uninstall and there seems to be no problems so far in privateer. Other than I have to learn how to play all over again. So anyone else having unexplained problems like that ,ight want to see what is affecting your graphics.
 

klauss

Spaceman
Here's a tip to the developers about the mission hostility bug (Mission enemies do not show as hostile sometimes).

I think it's the reputation system which interferes. I've recently seen a mission hostile briefly turn red, then green again. Since I was friends with them (pirates). Maybe the problem is that, although the mission scripts set them hostile, the reputation system sets them back to friendly. Perhaps there should be a way to override this behavior on some units (mission spawned units).

Hope it helps.
 

Kappa

Spaceman
Hi!

I don't know where to post this question so:
If you destroy a capship, you have a lot of parts floating around. You beam them in, but can't equip them, just sell for crap.
Or is there another way?

Thanks
 

catattack

Spaceman
jump drive

Having a great time with this game.

On the way back from Delta Prime (with no bases of any kind) my jump drive disappeared when attempting to jump to Delta? I couldn't jump out of the system so I just had to quit. I had the advanced repair but I don't know what happened.
 

fyodor

Spaceman
catattack said:
On the way back from Delta Prime (with no bases of any kind) my jump drive disappeared when attempting to jump to Delta? I couldn't jump out of the system so I just had to quit. I had the advanced repair but I don't know what happened.
This thread isn't really intended as a discussion (but rather just a *list* of bugs). However, let me quickly point out, that what you experienced is most certainly not a bug; you simply ran out of jump fuel. There's a huge, ugly, non-alpha-transparent bar showing your jump fuel status right in the middle of the screen (lower third) and every time you jump, it becomes one double-splotch shorter. When you run out, you can no longer jump. When you land, you are automatically refueled.

This behavior is identical to the original.
 

mischief

Spaceman
Bug I've experienced is when respawning I wind up with the 'default' Tarsus, i.e. all my customisations are gone.
Also appears to be 'saving on exit', i.e. if I die but quit instead of respawning, then loading my most recent game gives me the "You have died...." screen.

I have also lost all effects, can only hear music. Reboot, restart doesn't fix. Neither does change the settings to sound off and then back on again in the setup screen.

Running 1.0 (never installed a pre-release) on XP SP2.
 

henni

Spaceman
I have some problems with the campaign/special missions;
I did the Rygannon missions and got the Steltek, now:

Problem 1:
I didn't know what to do after Rygannon and after doing some research visited a mining base;
by coincidence, it was the base on Telar (IIRC) and there was not only Goodin (as I expected) but also a female pirate I never met before
- and she congratulated me for doing a (to me unknown) mission for her (killing someone IIRC) and wanted me to take her next mission.

Problem 2:
The dialog at that bar was totally messed up:
while talking to the pirate I got the audio of Goodin;
after accepting the pirate mission, I got Goodin's confirmation text
I think the game might have a bug if there are two "mission characters" in the same bar

There is another dialog mix up (Admiral and Goodin) if you talk to Goodin in the bar at Perry:
you get the admiral's text and voice instead of hers; if you reject the mission, you get her text
(to reproduce, simply use my save game below and visit the bar).


REAL problem 3:
(happened also after loading a game without visiting Telar and the mix-up above;
OTOH, loading a game doesn't reset a lot of values - like removing enemies that killed you etc, so..)
I can't finish the admiral's mission to destroy the drone;
I go to Perry, get the mission and head for the system he gave me (Nitir, I think) to meet the fleet .
In that system I am attacked by Kilrathis; after killing them I get a "defend mission accomplished"
and the Perry mission is removed from my computer; also there is no fleet. After returning to Perry,
the admiral is somewhat pissed that the mission wasn't finished (yet?) and gives me the same mission with a different system - and again:
no fleet and "defense mission accomplished".

Problem 4:
Like the pirate lady, I met "Murphy" (somewhere close to New Detroit),
dialogs indicating I met her before - but I didn't.


Since (my main) problem 3 happens after restarting the game and loading a "after-Rygannon-pre-Perry-missions" savegame,
I think that there might be some flags in the save game that are set wrong or missing..
My save game "test2" (after landing with Goodin on Perry, no talks) can be found here:
http://hendrik.spline.de/wc/

Maybe someone can give me a hint which value is wrong?
Or what I have to change to have that Perry mission accomplished without making a mess out of the save game?
 

Savage

Spaceman
You do not need to buy missile launchers to put missiles.
Heatseeker missiles almost always fail
Enemy strategies in which they rotate around you are annoying
Lasers too strong
You're ship is too resistant and does not lose pieces as quickly as in the original
No metric units in the distance to object counter (but that doesn't really matter)
Asteroids (athough this style is good for making a battle like the one in the intro)
In Sandoval's mission after accepting his mission, I talked with him again and he gave me a second artifact.
The last three dificulties have the same description in the manual.

Is it possible for the developers to make a folder for the ships that the player can have? This way it would be possible to make our ship look different from the others.

Great game by the way
 

hellcatv

Swabbie
Banned
make your ship look different by copying the texture in units/shipname to have privateer_ as a prefix
for instance

privateer_body.jpg in units/centurion has my modified privateer tricked out body image :) but enemy centurions get normal body.jpg
neat, huh?

henni: your problem was caused by your mishap on Jolson occuring *before* you defeated your follower--we jsut assumed people would procede in the proper order (i.e. drone dead then starting Righteous fire)
We will add safeguards for 1.01 to prevent this bug--as for you... best thing you can do is reload before you land on jolson
 

JKeefe

Spaceman
Galaxy turrets do not gimbal lock when passing through an axis that runs vertically through your ship.
Example:
If I am in the top Galaxy turret, facing to the rear, and a Talon approaches from 12 o'clock high with a speed that is greater than the Galaxy's, I am required to elevate my axis of fire higher and higher and the Talon gets closer and closer. At the moment my turret is pointed straight up, it should gimbal lock and I should be required to rotate it 180 degrees in the plane parallel to the top of my ship in order to continue tracking the Talon. What actually happens, though, is that the turret goes right on over, and the issue is further complicated because then the joystick left-right inputs are backwards.
 

klauss

Spaceman
Galaxy turrets do not gimbal lock when passing through an axis that runs vertically through your ship.

I just wanted to point out that they not always need to gimbal lock. Some turrent designs may avoid that issue. For instance, rear mounted turrets should not gimbal lock. Perhaps it could be a turret mount property.
 

henni

Spaceman
hellcatv:
henni: your problem was caused by your mishap on Jolson occuring *before* you defeated your follower
Interesting.
IIRC: I wasn't in Jolson to have a "mishap" and I didn't defeat my follower, it's still there - unless I uploaded the wrong save game (btw. feature request: please include a timestamp for savegames in the save/load screen).
Actually, I _did_ have a mishap (if you mean something got stolen..), so I decided to commit suicide, respawn, to avoid Jolson and to pick up Goodin instead; that's were the savegame came from.
I think the real bug (besides the dialog-mixup ones and the missing safeguards ) is that the game doesn't reset the campaign data properly (problems with "normal" data were already mentioned in some other thread) if you (re)load a game or respawn:
I took a clue from your answer and used a "prior-mishap" savegame, got to finish the Perry mission this time and travelled a little bit to check out the confed ships/to look whether the "leftover missions" I didn't do were still existing (s.a.: finding Murphy/the pirate lady).
Then I reloaded the above "prior mishap"-savegame again and surprise, surprise: this time my follower didn't exist anymore. So I guess the game might set a "drone destroyed"-flag and doesn't reset it if you load an old savegame; this would also explain the behavior with the "mishap" that you apparently observed but didn't actually happen in the uploaded savegame..
 

klauss

Spaceman
if rear turrets don't gimbal lock, why should dorsal turrets?

Because it depends on turret design, on how the turning servos are placed. I don't remember whether dorsal turrets did gimbal lock or not in the original Priv, but I do remember that rear turrets did not.
 

klauss

Spaceman
Compatibility bug

I'm having trouble setting 16-bit depth for graphics. When I do, vegastrike requests an unaccelerated pixel format in OpenGL resulting in utterly slow performance. It's probably asking for a 555 layout while my card supports only 565 (or vice-versa). Anyway, that's a bug that should be fixed: it should always try accelerated formats first, then fall back to unaccelerated ones. In fact, that's standard OpenGL practice, so it must be in, but buggy.

Although that's a vegastrike bug, it does affect Privateer users, especially those like me with old TNT2 cards (which perform rather poorly on 32 bit framebuffers).
 
Top