Privateer & myjemm

Ghostcloak

Spaceman
Here's my problem. I just built my new computer about 2 months ago. Its a 3.67 ghz pentium 4 (overclocked to those that didn't catch that :p) with 1 gig of ddr mem., Radeon 9800, water cooling system (Corsair hyrdropump 200), etc.... So its really hard to play old games! The computer I had before that (Athlon 700) just burned out so i don't really have a POS to run on.
 

Iceman16

Vice Admiral
hi, I have a similar problem. I have tried to get privateer to run on a new computer and I downloaded my jemm but when I ran it it said:

"EMS memory required

If you're using Windows 95 or 98, try adding the following line to your CONFIG.SYS file and reboot:
DEVICE=C:WINDOWS/EMM386.EXE RAM

If you're using Windows ME, then please see Microsoft Knowledge Base article Q275423.

MyJEMM Version 0.1.14
By Ross Ridge, Public Domain"

now, when I went to the EMM386.exe in the windows folder it said:

"Windows Expanded Memory Driver Version 4.95
Copyright 1988-1995 Microsoft Corp.

Expanded memory services unavailable.
EMM286 Active."

What does this mean and how can I fix it?
 

cff

Kilk'dymga'qith laq Ik'vikvi
emm386 has to be put into the config.sys. Starting it inside a DOS window won't do anything.
 

Iceman16

Vice Admiral
yeah, I know but it says something about EMS memory not being available and apparently privateer needs EMS memory to work so how can I turn on the EMS memory?
 

cff

Kilk'dymga'qith laq Ik'vikvi
By using EMM386.exe in your config.sys WITHOUT using the parameter NOEMS
 
M

MeMeMe

Guest
Hey, I got a different sort of problem running Privateer (the original one) under Myjemm. It loads up all fine, great, great. And I can go through the hangar and the main concourse, at first it crashed me back to windows when I went to the Repair/Upgrade area in the Ship Dealers area, but that works now (for some obscure reason) and im left with one niggly little problem... I can't launch my ship. Well I can. But then it just crashes me back to windows. And at first, it'd have the little animation of the ship blasting off the base, but now it doesn't even have that. The error comes up in a seperate box, down the bottom and its something like "09F8:000B". Yeah, anyways, thought you guys might be able to help.
 
U

Unregistered

Guest
XMS Manager==AWOL

So I'm going with the 'myjemm' solution on my WIN98SE box with a Athlon XP2000. I've added the 'DEVICE=C:/WINDOWS/EMM386.EXE RAM' line to my CONFIG.SYS like myjemm suggested, but when I reboot, windows pops up an error telling me that 'EMM386.EXE not installed - XMS manager not present'. Not much for all this hardcore DOS stuff. What's a wannabe Privateer to do?
 
U

Unregistered

Guest
Add line DEVICE=C:\Windows\HIMEM.SYS before the EMM386.EXE line.

Unregistered said:
So I'm going with the 'myjemm' solution on my WIN98SE box with a Athlon XP2000. I've added the 'DEVICE=C:/WINDOWS/EMM386.EXE RAM' line to my CONFIG.SYS like myjemm suggested, but when I reboot, windows pops up an error telling me that 'EMM386.EXE not installed - XMS manager not present'. Not much for all this hardcore DOS stuff. What's a wannabe Privateer to do?
 
U

Unregistered

Guest
Hi im having the ems problem when trying to run this game,ive looked over the previous posts but im having trouble locating the line
device=emm386 or anything about ems,can somone help plz?
Im using ME and when i run the game i get a black msdos box saying somthing like"Protected mode driver is not responding to EMS function calls.Make sure your EMS driver isnt configured with the NOEMS option.
If it is replace the option NOEMS with RAM"
This is my config sys file.........[menu]
menuitem=HELP, Help
menuitem=CD, Start computer with CD-ROM support.
menuitem=NOCD, Start computer without CD-ROM support.
menuitem=QUICK, Minimal Boot
menudefault=HELP,30
menucolor=7,0

[HELP]
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
devicehigh=ramdrive.sys /E 2048

[CD]
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
device=aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
devicehigh=ramdrive.sys /E 2048

[NOCD]
devicehigh=ramdrive.sys /E 2048

[QUICK]

[COMMON]
files=10
buffers=10
dos=high,umb
stacks=9,256
lastdrive=z

If any more info is needed just ask i really would like to play this game,thanks in advance
 
U

Unregistered

Guest
Disregard the last post ive managed to sort my problems by using myjemm and changing the sound device settings
 

ChrisReid

Super Soaker Collector / Administrator
hakkafusion said:
so much trouble just to run this game... is privateer 2 good? =P

On the front page, just today, I posted stop by step instructions for an even easier method. Both privateer 1 and 2 are great.
 
Top