Privateer & myjemm

P

Pan

Guest
I do exactly what the readme file says and i get the message when i run myjemm: "can't run program". What's wrong? I run it from a dos-box windows98. My config: p4/2,4ghz, sblive, 512mb RAM (i also tried limiting it to 16mb). How much conventional memory does it need? I have 580k with 512mb (not limited to 16) and 544k when limited to 16mb. And one more thing. I have the disk version of privateer. Does it matter? (The readme says it's for cd version). Where can i download cd version?
 

cff

Kilk'dymga'qith laq Ik'vikvi
Originally posted by Pan
I do exactly what the readme file says and i get the message when i run myjemm: "can't run program".

Please post the complete error message...
Most likely you have to use this:

myjemm PRIVATER.EXE
starts P1

myjemm PRSO.EXE
starts RF
 

Cassiel

Spaceman
are you sure we have to use "myjemm PRIVATER.EXE" to start P1? according to README 1.2 03/04/07 17:23:21...

HOW TO USE MYJEMM

Open an MS-DOS window, change directory to where you installed Privateer and run the "myjemm" command. To play the Righteous Fire expansion use the "myjemm r" command. You can also create a shortcut on your desktop or in your start menu to make it possible to start the game with a mouse click. Make sure the current working directory of the shortcut you create points to the directory where you installed Privateer.


btw, is it possible to use myjemm inside a 'virtual pc' environment, with a win98 guest o.s.?
 

TC

SubCrid
The program was written assuming you have the CD version of the game. It uses a different named exe than the disk version. So if you have the disk version, it isn't looking in the right place for the game unless you specifically give it to it.

Also I don't see why MyJEMM would have any problems running on a virtual Win98 system.
 

cff

Kilk'dymga'qith laq Ik'vikvi
Originally posted by hakkafusion
hi, i get an "error 2" when i try to run priv... any help guyz?

I didn't encounter that error so far, but you might check for the line
device=emm386.exe NOEMS in your config.sys
Replace that NOEMS with RAM if it is there.
 

Starkey

Avenging Rooster
If the game works fine, just leave your configurations alone. If it doesn´t, creating a config.sys in your root folder won´t harm, if you use the right settings (read the "Privateer bootdisk" stuck thread on this forum)
 

Lance Casey

Spaceman
hey guys im having a small problem with Privateer:RF i can't get it to boot up ill get the error and put into my next post because right now im at school
 

Lance Casey

Spaceman
ok heres the error "Protected mode driver is not responding to ems function calls make sure your ems driver is not configured with the noems option if it is replace the option noems with ram"

this error shows up with Privateer:RF
need help plz
 

J Man

Spaceman
For some reason, when I use the "myjemm r" the program gets "halted by code". I have the same version of myjemm that has a link found on this list.
BTW, the error is #1910.
 

Ghostcloak

Spaceman
Okay... So I have windows xp. I am using myjemm.exe to try to start Privateer, however i realize that myjemm was made for windows 95/98/ME. I have tried to use it, even under capatability mode in Windows Xp, however i still recieve the following text in DOS mode:

Windows 95/98/ME required

MyJEMM Version 0.1.11
By Ross Ridge, Public Domain


It there any way I could get MyJEMM to work, or is there another program that will allow me to run privateer smoothly with sound, etc....? Thanks for all your help guys! Please reply soon!
 

Ghostcloak

Spaceman
Oh also... After I installed the game, it said that I could possibly run it just by typing priv.exe. When I do, it comes up with the following error:

Protected mode driver is not responding to EMS function calls. Make sure your EMS driver is not configured with the NOEMS option. If it is, replace the option NOEMS with RAM.

I checked in bios and such and couldn't find it there... Could use some help with this if there is no solution to my Windows XP MyJEMM problem in the post above :)
 

Nappydman

Spaceman
Well, Ross Ridge is correct in this case. You need 95/98/ME to run MyJemm, since the JEMM memory manager REQUIRES a partition that knows what DOS is. NTFS can't deal with this, since NTFS doesn't even know what EMM386 or JEMM or EMS or XMS are. Compatibility mode will NOT work in this case. Sorry. You won't even be able to get Privateer running the good old fashioned way, since XP has no DOS base the way 95/98/ME do.
 

Ghostcloak

Spaceman
D'oh... Even more depressing... I not only have no avatar, but I'm just gonna have to go back to playing free-space for now... :( Thanks for the hasty reply however. I'm gonna do more research and see if I can get a couple buddies to help out if they can. If I find anything I"ll let ya's know.
 

Nappydman

Spaceman
Well, you're not entirely without options. You could set up a dual boot system, you could run an emulator like DOSBox, or you could snag yourself an old machine meant to play Wing Commander games in general, not just Privateer. Sorry the quick and easy solution didn't work for you though.
 
Top