Privateer 2: Can't talk to Angus at Interplanetary Aid


For a plot event, I'm supposed to talk to Angus Santana at Interplanetary Aid on Anhur. I went to the planet and the transit wouldn't let me go to IA. I thought maybe I had to look up Santana and IA in the database first. So I did that, but still won't let me go there. The destination just doesn't show up on the transit. What am I doing wrong?
Sure it helps. Figures I ran into a game killing bug and now I have to start the whole thing over.
My version of the game is the new download. You would think that would have the needed patch

Gee, I'm so glad they kept in the game-killing bug from the original CD version. If there is one thing everyone wants new versions of old games to keep, it's a game-killing, no-way-to-know about bug.

Oddly enough, I never had this problem in the original game back when I was a teenager. I never ran into this bug when I first got the game, even though I took the same plot actions (such as paying Hal Tiffin). And I never downloaded any patches.

As for the patch offered on this thread. I tried downloading it and extracting to my privateer 2 folder, but I didn't notice any change. Is there something else I have to do? I'm not really computer literate and don't know much about how you apply patches.
Last edited:
After unzipping the patch into the P2 folder, try running darkfix.exe instead of using the GOG icon (the patch installs side-by-side with the GOG installation and doesn't override the DOS EXE). This patch is based on the Win95 exe, so it should work better.

It's odd though, the DOS EXE released by GOG was apparently patched with an official Origin fix released back in 1997, which should have fixed the bug at least in theory.

You shouldn't need to start the game from scratch, if you have a savegame before paying Hal Taffin, going back to that point and choosing not to pay him should work i think.

In any case, I'd like to study this bug more in detail. Could you post your savegames so I could poke around a bit?

I'm not getting an unzip option. Only an extract files option. Is that the same thing?

Also, running Darkfix.exe doesn't help. The destination still doesn't show up on Anhur.

And no I don't have a savegame before I talked to Hal. If I had one, I would have just done that from the start. Not knowing about this doomsday game-killing bug, I saved as soon as I got to Anhur after I talked to Hal.

And how do I post savegames?

I f
Last edited: