Running Privateer/rf/armada/pg In Windows: Howto

wierd stuff...

i Tried the ME patch, but on the first file IO.sys, it says "pattern not found"

But anyway, i was able to run it from myjemm twice, but i ran it a third time, and have gotten this ever since:

'Memory: Original Current Used
'NEAR 29228 28698 530
'FAR 350764 316316 34448
'HIGH 1425056 1752768 -327712

Fatal error.

Error Code: D002-FFFF
Program halted by code.

MyJEMM Version 0.1.11
By Ross Ridge, Public Domain

I did not change any hardware or install anything between times. -thx
BootDisk Solution

I run a P III with windows xp prof. version.
There was no chance to get old dos stuff working properly, so i searched the web... and finally found a very good Boot Disk:



other bootdisks:

bootdisk: Important: you need a FAT32 Partition!!
open geocities link and download
then copy your sounddriver files to this disk (preferable to a:\drivers\sound; the drivers directory may not show up, but its installed correctly); i have, so it must be an executable file, not a *.sys;
Then install Priv2 to the FAT32 partition; wish u DOS Fun...
it should work with WC as well, please report back,my WC copy is 50 miles away...perhaps i tell u soon.
Privateer Hanging in DOS

I also have a dual boot system for the express purpose of running Privateer.

When I first tried to get my sound working, Privateer kept halting (Blank screen, Ctrl+Alt+Del wouldn't even work) I had to fiddle with the settings of my onboard sound card to stop it interfeering. This might be worth a try (if you have an onboard sound card as well as a decent one). Alternatively try changing the your sound card IRQ settings as I think it's a problem to do with multiple devices recieving the same interupt calls...

Anyway, good luck getting it running
XP user, need help

I've read too many of these threads to have much hope left for Priv1 ever running on my Windows XP. Still, the love of the game keeps me searching. If anyone finds something, share the wealth of knowledge.
USB in dos

ok i haven't seen it said, I played Privateer many moons ago, want to play again but I have yet to see anything for those of us who run USB mice,keyoards, and joysticks.Any help there would be good.I'm running now:

1.8GHz AMD Thunderbird/w 400MB ram
Windows 98 SE
USB Logitech Keyboard
USB Saitek 220 Joystick

Can I run Pirvateer?If so how?

When I start myjemm all I get is:

Win 95/98/ME required

Myjemm version 0.1.14
by ross ridge, pulic domain

thats it nothing else happens.What gives?!
Anyone tried....

Anyone tried installing Windows 98SE or something in a VMWare, and then doing the things needed to run Privateer through Windows 98SE through the VMWare installation?
this seems like an awfully complex method.

I'll stick to formatting the computer and using Windows 98 and DOS 6.11
I couldn't even figure out how to get a dos emulation in bosch, let alone get privateer to work in it
I didn't bother to read the whole post, but if you people still need help, I've been able to get Privateer to run on my new p4 machine with *gasp* music joystick and.. what?? voices?!.

I can still remember clicking away for siz hours straight on my laptop a few years ago trying to free up 4kb of memory to run Privateer :p
Oops.. I'm unregistered so I can't edit my post. To make a long story short, it will require either booting from a 2nd hard drive or a fat16 partition (of course). But at least EVERYTHING will work :)
WC Privateer (RUNS!) under XP

Hi folks the excellent DOSBox actually runs Wing Commander Privateer under windows XP.

once installed etc .. (i.e mounting drives and directories) if you change the line in the dosbox.cfg file from EMS=TRUE to EMS = FALSE then Privateer starts up, with glorious music.

Note it runs slowly on my machine (a Celeron 2.2Ghz 512 DDR) but I'd be interested to see what it's like under a fast machine.

here's the link that had the best news about privateer

It's still slow even on a fast machine(AMD 3000+), but the next version of dosbox (.62, I believe) is supposed to fix that, the testers report that it should run Privateer perfectly. *Crosses fingers(
I got privateer running flawlessly under windows xp... if its running slow for you hit ctrl F12 while dosbox is open and increase the performance of it to make it smoother, and also increase the frame skipping. I'm running a AMD 2500 with 1 gig ram. It runs really well at ~8000 cycles and 2frames skipped
For me it also runs smooth. My CPU is a PIV 3.067Ghz, btw. I use cycles at 9000-10000 and frameskip=0. But yes, with the next version and current CVS versions it's already reported to run much faster even on slower PCs.
I've been reading all the posts on this thread and it looks like a whole lot of work and trial-and-error with third party programs, slowing and all that jazz so I have a question to ask... :confused:
Should I try to go through all that on my current system or should I just go into my storage and dust off an old Pentium system I've got laying around? I know for sure it needs a soundcard but I still have my old ISA SoundBlaster 16 (didn't upgrade my soundcard until last year!) and maybe a OS install, but not much else. Will need an analog 9-pin joystick. What would you folks do?
When you get an old Pc, you also have to go through some troubles to get it running, if you are unlucky - just like with "3-party tools". That's always luck of the draw. I personally didn't have any probs getting privateer working with my old Pc nor with my new Pc via DOSBox. So best would be to try out once with DOSBox, and if it doesn't work at once (with the standard priv fix, of course. if you want to run privateer that is.) then you could still go with the old PC. Anyway, the worst thing that can happen is that you learn something new via trial and error ;)
Win XP

Okay...I have the latest version of DosBOX installed and can load that up no problem. I mount e e:\priv, type e:, then type priv to run the game. Once I do that I get the following message and I go no further.

Protected mode driver is not responding to EMS function calls.
Make sure your EMS driver is not configured with the NOEMS option.
If it is, replace the option "NOEMS" with RAM

And I changed the EMS call in DosBox to false...

Thanks in advance