Wing Commander Prophecy in Vista

paladin.oa

Spaceman
Hi, I've been trying to get WC:p to work in vista, but every time I start it, the game crashes and the following error message is displayed.

FileStreamer::read failed 0 0 998
Fs::read WaitForMultipleObjects13

What's the deal? More importantly how do I fix this?

I am using the non-gold cd version.
 

AD

Finder of things, Doer of stuff
Hi, I've been trying to get WC:p to work in vista, but every time I start it, the game crashes and the following error message is displayed.

FileStreamer::read failed 0 0 998
Fs::read WaitForMultipleObjects13

What's the deal? More importantly how do I fix this?

I am using the non-gold cd version.
Setting the compatability mode of the game should work. Find the exe of the game and set it to win95 or 98 compatability mode. Failing that, you might need to start clean and re-install. However make sure you set the compatability mode on the installer as well before running it.
 

paladin.oa

Spaceman
YESS!

AD, I did as you suggested, and it worked! Beautifully! Now my problem is that it's a real pain in the wrist to play WC:p keyboard only. So, has anyone succeeded in playing Prophecy w/ a gamepad?
 

AD

Finder of things, Doer of stuff
AD, I did as you suggested, and it worked! Beautifully! Now my problem is that it's a real pain in the wrist to play WC:p keyboard only. So, has anyone succeeded in playing Prophecy w/ a gamepad?
I find the mouse works great for me, so that's how I usually play it.

Gamepads work surprisingly well though, but you will need appropriate button mapping software. I've played prophecy with a logitech PS2 style USB controller but logitech always includes really great mapping software. I set the left stick as the joystick and then the rest of the buttons is really up to you. I try and map all the basics to the controler and that works pretty well. You'll only have to use the keyboard for a few things... (hint: autopilot is pretty non-combat essential and is easily left on the keyboard freeing up a different function)
 

forsake

Spaceman
Hi guys,

Im new here and I would like to thank for all the support and anything else, thats been done here to the proud wc fan community! :)

And now to my problem I've been facing :D

I thought I would give WCP another shot at with the HighRes patch along with so many before. My system is a Vista64sp1 with a geforce8 series card and fresh new K-Lite Mega Codec Pack 4.3.4 installed. (no special video software except VLC)

After reading in a lot, I tried the following:
- Install WCP clean and fresh
- try if it runs well -> it did (at least tried out the first 3 missions, everything well, without any speed problems or anything else mentioned)
- Installed the enhancement pack, as well as the vista install_gui.exe patch
- Configured it for different resolutions -> all worked well, could play without problems
- Now I got them HighRes VOB movie files downloaded
- Went in to the game, videos played perfectly, but after the video was finished, it would go black for a second or two, and then crash back to windows with WCP being killed as a process..
- Tried it out with a different video sequence to reproduce this error (first video was a scene in the bar, second one was a briefing for the next mission) -> same thing

Sooo, I thought, ok, try the movie patch, overwrote the dll file, went back into the game, and the problem repeated itself.. I even tried getting back to the 640x480 resolution, if that would change anything.. then I also tried a complete reinstall, tried all the compatibility modes for previous windows versions and even tried deinstalling the K-Lite Mega Codec Pack and installing different versions of the ac3 and mpeg2 codecs I could find, all without any luck.

The problem stayed the same, after a high res video scene, which would play perfectly till the end, the game would crash back to windows without any error message or any windows notification sound of errors.

Im guessing, that the included dll files have compatibility problems with vista64, but I realize, that nobody else in vista seems to have similar problems.

Hope anyone here can somehow think of a solution to this. I would be very thankful at the very least :)

P.S: is there a way to let the prophecy.exe spit out some debug information or a log file of some sort?

EDIT: ok, after remembering, that turning subtitles "on" would use a slightly different algorithm, I tried that and it actually solved the problem! although I would like to see them vids without subtitles, but hey, Im not complaining,.. happy as it is :D
 

ChrisReid

Super Soaker Collector / Administrator
EDIT: ok, after remembering, that turning subtitles "on" would use a slightly different algorithm, I tried that and it actually solved the problem! although I would like to see them vids without subtitles, but hey, Im not complaining,.. happy as it is :D
That's an excellent tip that I'd like to quote and highlight so more people see. Your whole post is a good summary of what all do to do get a bunch of the myriad HCl patches working smoothly together, and it shows that it is still possible to do on the potentially pickier new versions of Windows.
 

Robert

Veteran Spaceman
Hi, I've been trying to get WC:p to work in vista, but every time I start it, the game crashes and the following error message is displayed.

FileStreamer::read failed 0 0 998
Fs::read WaitForMultipleObjects13

What's the deal? More importantly how do I fix this?

I am using the non-gold cd version.
Hello. I was having the same problem with the retail CD version in win7-64 bit. Microsoft was no help but a solution was given me from Electronics Arts. Please do the following:

PC Troubleshooting:

Please follow these Troubleshooting steps in order to get your Issue resolved.

FLUSH DNS CACHE:
Clearing your DNS cache will help you get rid of outdated data in your internet that may be causing the connectivity issue that you are experiencing. Please see this link for the steps on how to do so: http://help.ea.com/en/article/how-to-flush-dns-cache-for-windows/ .
(Note: sorry, the links I was given didn't work, but you might be able to intuit the correct syntax for the web page.)

CLEAR ORIGIN CACHE:
Clearing your Origin cache will remove any possible corrupted file that you can download again to be corrected. Kindly click the link for the steps: http://help.ea.com/en/article/origin-my-games-list-is-blank/ .

CLEAN REGISTRY, CLEAR CACHE AND TEMP FILES:
As there may be corrupted or outdated files on your PC that may be causing the issue, you can eliminate them by following the steps here:

http://help.ea.com/en/article/how-to-use-ccleaner-to-fix-pc-issues/ .

Here is the link to download Ccleaner.
https://www.piriform.com/ccleaner/download

CREATE A NEW ADMIN ACCOUNT
Create a new user account on your windows 10 and try to the play the game. Follow this link to create an account.
https://support.microsoft.com/en-in/instantanswers/5de907f1-f8ba-4fd9-a89d-efd23fee918c/create-a-local-user-or-administrator-account-in-windows-10
(Note: I did not do this, but you may want to give it a try.)

If none of the above mentioned steps work , proceed to this one :

UNINSTALL THE GAME AND ORIGIN THROUGH REVO
(Note: I found REVO through Chrome and used it to do the uninstalls as directed.)

1. Install Revo Un-installer
2. Install and Run Revo Un-installer
3. Select the desired program (right click)
4. Select Un-install
5. Scanning Mode (Select Advanced)
6. Locate and delete left over files (Select All that apply, then delete) Choose next.
7. After Revo has removed the program please clean boot the PC and reinstall the title.
RESET WINDOWS HOST FILE

https://support.microsoft.com/en-us/help/972034/how-to-reset-the-hosts-file-back-to-the-default

CLEAN BOOT:
Performing a clean boot on your PC will help you eliminate software conflicts that occur when you run, install or update a program. Please refer to this link provided by Microsoft for the steps on how you can do this: https://support.microsoft.com/en-us/kb/929135
(Note: I did not do this step.)

Please follow these too

Hello To Clear the origin cache you must follow these instructions

Open the Start menu.
Type "view hidden files and folders" into the search bar.
Press Enter to open the View tab of your Folder Options.
Open the Hidden Files and folders menu within the Files and Folders menu.
Click Show hidden files, folders, and drives.
C:\ProgramData\Origin — Everything except for the following sub directory: DO NOT DELETE: C:\ProgramData\Origin\LocalContent
Origin folder in C:\Users\\AppData\Local\
Origin folder in C:\Users\ \AppData\Roaming\
(Note: I did not have these paths, but I believe this was written for Win 10 users.)

I do not believe that this problem is a connectivity issue, but using CCleaner and uninstalling using REVO was the biggest difference. Also, clearing the cache and temp files could also be very important. This worked for me, so I'm hoping it will work for you. This problem has to do with SQL databases from what I have been able to glean from the web.
Happy gaming.
 
Top