Wing Commander 4 DVD in WindowsXP (w/ DirectShow)

@Unregistered:
What DVD-Player/Decoder are you using? I ask, cause it seems to work best with WinDVD, so if you've got that one lying around, too, give it a try. It might help you.

Too bad Release2 didn't fix the bug, but guess it's very difficult to get it going with every DVD-Decoder. :( And as Unregistered already said: Way better than the "Can't find video" error ;)
 
Looks like it is working a bit better the the last version for me in regards of error size (it seems the gaps are way shorter, but still annoyingly big). However the new version introduced a new error for me: After all the movies are done and the mission briefing appears I am dropped back to Windows. The last frame of the movie is displayed in a window. When I alt-tab back to WC4 it works however and I can continue playing.

System: Athlon 650, Win98 SE, Power DVD and WinDVD installed (tho I don't know who is 'in charge'). Any way to select which one is?

Update: Bug is very rare and does not appear often.
Also tried to delete the powerdvd filter file now - no major change in playback
 
Another update available on the site. I'm pretty sure it's mpeg2 filters fault things aren't working for everyone so I decided to include Mpeg2dec GPL filter (the same as Media Player Classic has). The dll will first search for this filter to use, if it doesn't find it, it will rely on DirectShow to find the appropriate filter. Hope this finally solves some problems...
Another thing. Is the aspect ratio of the movies OK for you? I could swear that the DD logo was Full Screen, now I have like 1.5 cm of black borders on top and bottom...
 
Yes, the DD-Logo is full-screen normally, but for me it's full screen with your dll as well. - But what res. is that one? I ask cause my monitor seems to have probs showing 640x400 res or 640x480 in ref. rates higher than 60hz (LCD anyway, so doesn't heart my eyes, but sometimes annoying)
I'll now check if your latest release still works for me ;)
EDIT: Just checked the bat file included: So I got you right in how to change the filters :D - Now testing...
EDIT2: Good info: It's still working for me ;) - Guess I could stop testing, but well, too much fun :D :confused:
 
Yeah, I figured it out already...it was Vobsub's fault Aspect Ratio was wrong (I was checking what filters were in use). I don't change the resolution in .dll, this is all handled by the game. I think it's 640x480. If you have LCD, refresh rate shouldn't matter anyway...
But movies aside...my joystick is not working in the game :( (Microsoft Sidewinder), does anybody know something about it (in fact the buttons work, just not the steering)? Hope I won't have to make another program to handle joystick :D
 
I only have PowerDVD on my PC - it runs pretty smooth. The Dolby Digital trailer played in 4x3, which I thought was odd, but all the in game video runs in a nice 16:9.

Some of the video starts a little into it... I thought it was entirely skipping the "choice" videos after a choice selection, but the second time through, it merely started the videos half way through (variable amounts of time)...

I'll be trying the April 12th update tonight with it...

Thanks again!
 
To the Joystick: I've got the MS Precision Pro (USB), so normally your Joystick "should" work with it. - The Buttons are working you say? Hmm. Have you tried pressing Alt+J (or was it Ctrl+J?) ingame? Maybe the Mouse or so is selected. You could also try to change stuff in the options menu. (Maybe not normal Joystick, but one of the other two). Did I get you right: In the menu the joystick is working correctly, but not in the game? If so, you should be able to solve it via one of the methods I mentioned. - Have read about a similar problem somewhere in the forum, but forgot where... :(
 
You are correct! It's been so long since I've played the game I forgot all the keyboard shortcuts :) CTRL-J did the trick, 10x...
 
No problem ;) - I had the problem the other way arround: I needed to select Mouse cause no Joystick for that PC (Just for testing WCIII KS and now WC IV DVD). ^^
 
gulikoza said:
Another update available on the site. I'm pretty sure it's mpeg2 filters fault things aren't working for everyone so I decided to include Mpeg2dec GPL filter (the same as Media Player Classic has). The dll will first search for this filter to use, if it doesn't find it, it will rely on DirectShow to find the appropriate filter. Hope this finally solves some problems...

No change, none at all I'd dare say. I installed the new dxmci.dll and registered the Mpeg2DecFilter.ax. Both files are in the WC4DVD directory. No change to how it played before. If any I'd say it got slightly worse. BTW I sometimes have skippings INSIDE a running video as well (without a choice happening).
 
I'm having troubles recreating your problems on my win98 machine. In fact, I'm having troubles getting any results at all! :confused: I've tried mpeg2dec filter (which will register normally, but cannot be added to any graph - Class not registered error - this can be verified with graphedit), and both Intervideo and Cyberlink DVD filters. While these two work normally in Windows (with my sample app which uses the same DirectShow class as dxmci.dll - so I'm guessing I'm doing things correctly), graph inside the game is not built. I've tried forcing both filters to the graph but I always get Some of the streams in this movie are in an unsupported format error. So, no video, only sound, in all cases. The only difference right now I can think of is that Win98 uses Overlay Mixer and normal Video Renderer, while Windows XP defaults to Video Mixing Renderer Filter. And VMR somehow succeeds rendering the video, while OVL Mixer fails. But still, this wouldn't explain why you get video on your computer...

I have made the debug version available if you have time for some testing. You will also need DebugView to capture the log. Debug library will also create c:\graph.log file, which contains steps how DShow renderer created the graph. I will need both logs to get a better idea how the files are played on your system...
 
Like Karl I'm still having trouble. It does seem to have improved a little with the new version. Short movies are still skipped entirely. I've attached those debug logs.
 

Attachments

  • renametozip.txt
    6.5 KB · Views: 307
Thanks for the report, the logs have been most helpful. I have recreated the problem and it seems the problems are caused by Ligos Mpeg2 spillter and decoder filter used in the graph (lines 57 & 59 of dxmci.log). These filters have a very high priority and will almost always be used instead of mpeg2dec or WinDVD filters. I guess either the splitter or the video decoder filter has a bug where it will not seek to begining of the file if the source is changed. The debug build has been updated to try to force default Mpeg2demultiplexor. If that doesn't help you and Ligos filters are still used, please try to manually unregister the splitter filter (lmpgspl.ax) and then see if different filters are used...
 
I just tried the Ligos filters on Win98 and the video works. It is painfully slow since it doesn't use overlay, but still. Of course the same problem with skipping appears. Perhaps, rather than forcing other filters (which might not work on win98) I could try to create a workaroud and try to reset Ligos spiltter. Although I think mpeg2dec has a higher quality output, at least on my computer...
 
Fixed! The movies all play perfectly now. Great job.

I've attached the new logs in case you need them.
 

Attachments

  • renametozip.txt
    6.8 KB · Views: 339
Still doesn't work for me unfortunately.
I think the sound part of the movies might be playing instantly now (not 100% sure here), but the movie parts still start late. Then they fast forward a bit. Then they stutter a bit. Then they play properly. In sum more distortion then earlier.
 

Attachments

  • cff.zip.txt
    6.9 KB · Views: 308
Uh,oh...German graph log :D. But I see you use Ligos filters as well, so I didn't really have to decode it ;). In short...the update I made for KrisV was pretty much XP specific since w98 uses different filters. So it is expected things would run as previously on win98. There is a new version on the site (& debug build updated as well) that has a real fix for Ligos filters. The game should now work OK with them, no more skipping. This makes now, what, 3 successfully tested filters (WinDVD, Mpeg2Dec & now Ligos)? Any further problems, please report what filters are in use, so I can do tests and try to recreate the problem you might have. Enjoy.
 
Works 99,9% now.

I still get a gap of maybe 1/3rd second, but this more looks like a load delay then a display problem. Not having a dxr to compare I cannot say if this is normal behavior.

I also still get the problem that occastionally (1 in 20 I'd say) I get droped back to the desktop when gameplay begins and have to alt-tab back to the game. Movies won't run anymore after that (they run, sound is ok, but graphic is compressed - on the vertical axis - to maybe 5% of the screen and heavily distorted).

Both extremely minor problems. Thanks SOOOOO much for what you have done so far.
 
A gap of 1/3rd of a second? That would be hard to notice. Do you mean there's 300msec missing from the beginning of the movie or that the whole thing freezes for that amount of time? The second would of course be normal, since playback has to be stopped & new file loaded and both things take some time to process...
The second problem you mention...I just re-read this thread and you reported this behavior after the first update. This might be only win98 specific since nobody else reported it, but still - I might revert the window behavior back to as it was done in the original release. That fix didn't help anyone anyway, it seems it only created a new problem...

I also did a Google search on dxmci. It seems that a library of the same name already exists. Somebody created it to translate MCI calls in Transport Tycoon to DirectMusic :D Perhaps it would be a good idea now that it works for most of you, to change the name so it is not confused with that one. I might even have to take some time and make a better looking web page :D
 
Extremely hard to say if it freezes or skips. Its really only noticeable in cases where the FMV changes files, but there is no choice between the parts. Like in the intro. After your talk to the veteran and it skips over to the bartender (and you hear the voice of Maniac in the background). As you said it is barely noticeable.
I didn't notice it in the normal CD release however so I reported it. Of course the ammount of data to be loaded in higher for the VOBs so it is most likely related to that.
As far as the dropping to the desktop goes - note that I only had it happening twice so far. In patch 1 and 3. It is fairly rare so it might also have been in the original and the 2nd patch, just didn't occur by pure luck. I'd not worry about it too much either.
 
Back
Top