Wing Commander 3 full screen issue

xxquatroxx

Spaceman
Hi there,

I'm having a problem with wing commander 3 getting it to full screen.
I'm not talking about how to get it from a windowed version to full screen becasue thats done with ALT+ENTER.

No the thing i'm having is that i've got all black bars around WC3 when i start the game.
like 20Centimeters of black bars on each side or so.

See picture:
wc3smallscreen.jpg

And the grafics aren't all that good to.
Really choppy... and some adio interuption aswell. (some minor lagging)

I've edited some things in dosbox.conf but iwth out any result.

I'm running on windows 7 ultimate 64 bit.
Running at Resolution of 1920x1080.
Got an NVIDIA Geforce GTX 660 Ti 2GB card.
intel i5 2500K CPU overclocked running at 4.20GHz (normaly on 3.3GHz)

Set my Dosbox config back to the original state so if any one can help me with this.
Thanks a lot.
 

AD

Finder of things, Doer of stuff
If you have the screen resolution set to 1920x1080 but don't have dosbox set to scale the game it will play game in it's native 640x480 or 320x240... . As far as the choppiness, there's probably some tweaking to do with the cycles settings.
 

bsmith1702

Rear Admiral
Two possibilities with the choppiness: the first is that your cycles are set too low. The other possibility is that the cycles are set to "max". It's been my experience that the audio sounds choppy when DOSBox does this. Note that if the cycles are set to "auto", DOSBox more than likely automatically sets it to max. I run at fixed 50000. I'm not sure why *lower* the number of cycles would improve performance, but it seems to work this way.
 

xxquatroxx

Spaceman
can any post the correct settings for me please? i mean settings of dosbox.cfg. so i can try this and let you know my results. thanks
 

AD

Finder of things, Doer of stuff
First step, make sure you set your resolution in dosbox to match whatever you have it set to in windows. If your resolution is smaller then you will have extra black space around the image.

fullresolution=1680x1050
output=ddraw

(I had issues with stuttering when I switched the renderer to opengl so you might check that and see if it helps)

As far as making the image full screen... Look scroll down past the part where you set the resolution to the section labelled "render" . There's two settings of interest in this portion: Aspect and Scaler.

The lines should looks something like this:

aspect=true
scaler=hq3x

There's several different scaler options with various smoothing effects. I would just experiment with the different option till you find one that you think looks good. For scalers, none is obviously turned off. Normal3x will be fairly blocky looking. This will get your gameflow portions to fill the height of your screen. So when you are flying you won't have black space above or below the image. This will not get rid of the pillar boxing though. There will be black to the right and left of the image. I don't think changing the aspect setting fixes it and neither does changing the scalers. But one cruddy fix is to change your resolution in windows to something that is close to a 4:3 ratio. Then also change the dosbox resolution to match. This will should stretch the image width-wise. Personally the game was designed for a 4:3 monitor so I'm fine with the pillar boxing.
 
Top