Video

saf0775

Spaceman
Trying to import some video and having some problems. I'm creating new "helmets" for the in-game communications and I'm not sure of the video size or format. I know the files are .avi...but mine don't seem to be working. Is there a specific code I need to have to get these to work?
 

Iceblade

Admiral
Looking through my old emails, I found where I asked a similar question. Unfortunately I'm not sure if the following applies to all videos or just certain ones such as inflight comma or full screen.

320 x 160

.avi's of some sort with no sound. Sound should be in a separate mp3.
 

saf0775

Spaceman
I made the video that size, and one that was even smaller. All I get is a blue box where the video should be. I've tried two differnt codecs, and tried to save it in both .avi and .wmv. No joy...

My audio is also a seperate file.

I'll keep working on it...
 

AD

Finder of things, Doer of stuff
I don't know what resolution Flight Commander uses but that - on the surface - sounds too big. Sure today that sounds too small, but that would be about the size of the FMV sequences in the original games.

Take a look at the original comm files in the Flight Commander directory and copy whatever format they are.
 

saf0775

Spaceman
I don't know what resolution Flight Commander uses but that - on the surface - sounds too big. Sure today that sounds too small, but that would be about the size of the FMV sequences in the original games.

Take a look at the original comm files in the Flight Commander directory and copy whatever format they are.
Thats the thing...Windows media player won't play the video sequences. This tells me that the game is using some form of format that I don't have the ability to create. Windows tells me they are "windows media files" but everytime I click on them Media player says it's an "unrecognized format".

Grrr.
 

eddieb

Vice Admiral
So you need to save the movies in .avi format, with some .avi codec that can be recognized by your computer. The avi should not contain any audio. Instead, extract the audio and convert it to an .mp3. Comm videos need to be 128x128.

Fullscreen cutscene videos need to be 320x160.

I use virtualdub to do video conversions.
 

saf0775

Spaceman
So you need to save the movies in .avi format, with some .avi codec that can be recognized by your computer. The avi should not contain any audio. Instead, extract the audio and convert it to an .mp3. Comm videos need to be 128x128.

Fullscreen cutscene videos need to be 320x160.

I use virtualdub to do video conversions.
I already have my audio and my video in separate files. I use Sonic Foundry's Video Factory.

Thanks for the heads-up about the size. I've noticed that FC is very picky when it comes to sizes and I assumed that this was probably my problem.
 

saf0775

Spaceman
I did just reinstall XP after a virus infected my system. It's possible that the codecs are out of date. I'm going to install the game on my work PC here (which is fully updated) and see what happens.

UPDATE: Installed the game on my XP machine at work. Videos work great in the game, but media player still won't play them out of the game. Installed the codec from the FC website and the problem is fixed. Weird...but I'm not complaining.
 
Top