Run All Old WC Games in DOSBox Walkthrough

ChrisReid

Super Soaker Collector / Administrator
Then you need to tell Privateer where on the hard drive to look for the files.

Open up priv.cfg and give it a location to the .tre file. "=c:priv.tre" would be it if the tre was located in your C drive root.
 

THE_WUQKED

Spaceman
Hmm. Are you sure you mounted your cd-drive / directory as drive D with "-t cdrom" option?
And I suppose you kept EMS=False, right?
Other than that, no idea :(

EDIT: Or try what ChrisReid just said...
 

Dralthi5

Spaceman
ChrisReid said:
Then you need to tell Privateer where on the hard drive to look for the files.

Open up priv.cfg and give it a location to the .tre file. "=c:priv.tre" would be it if the tre was located in your C drive root.
So... if the .tre file was in c:\wingcommander\privateer, would I change the .cfg file to read "=c:\wingcommander\privateer\priv.tre"? I guess I just don't understand, because that didn't work.
 

ChrisReid

Super Soaker Collector / Administrator
Well, what are you mounting here? So you've got c:\wingcommander\privateer\priv.tre physically located on your hard drive.. when you go into dosbox, are you typing:
mount c c:\wingcommander\privateer\priv.tre ?
Because then the contents of c:\wingcommander\privateer\priv.tre appear to actually be in the C: root as far as the game and Dosbox are concerned. So then =c:priv.tre would be accurate because the system would think the tre file was in the root.
 

ChrisReid

Super Soaker Collector / Administrator
Exactly.. so you need to just use =c:priv.tre. It's just a logic puzzle. Do you understand? You're telling dosbox that c:\wingcommander\privateer is the C drive, so you need to tell priv.cfg to look in the C root. If you have any more questions, come on irc rather than clutter up this thread with back-and-forth posts.
 
U

Unregistered

Guest
I can not seem to get Armada to work either, I get through it all and it says
"loading wing commander armada
initializing ems" (even though I have ems disabled)

but nothing ever happens.
 

ChrisReid

Super Soaker Collector / Administrator
Unregistered said:
I can not seem to get Armada to work either, I get through it all and it says
"loading wing commander armada
initializing ems" (even though I have ems disabled)

but nothing ever happens.
5) Additionally, some games may need an additional entry to execute. Privateer and Armada run well with "loadfix -65" typed before the game's main executable (for example "loadfix -65 armada").
Don't type "Armada," type "loadfix -65 armada" to run the game. Make sure EMS=False in your dosbox.conf.
 
M

Mezz

Guest
Yet Another Privateer Post

First off, let me say thanks to all the help that everyone has been. I've gleaned so much information from this thread trying to get Privateer to work and it's so bloody close I can taste it!

But alas, I've apparently failed somewhere or I'm doomed to never play one of my Golden three games again! (WC: Priv, MOO I, and X-com). I've loaded DOSBox, set my autoexec.bat to use my c:\Games\Priv as my C: drive, and my Privateer CD copied to the HD as the D: drive. Edited the CFG files in the c:\games\priv folder to point to the mounted CD rom, and still get the dreaded No Privateer CD found. I've hit a nasty stop point and I've double and triple-checked my cfg files. Everything is as it should be, and I can't get it to run. Even tried the loadfix option. If there isn't anything that I can do from here, then I guess all is as it should be, but if Chris or someone has another suggestion, I'd appreciate it.
 

ChrisReid

Super Soaker Collector / Administrator
If he did, that might be the problem, since D is a hard drive in this case. Having the disc copied there seems unnecessarily complicated in this instance. I'd just stick it in C:\Games\Priv and have Priv.cfg point to =c:priv.tre. Are you mounting D in addition to C Mezz?
 
U

Unregistered

Guest
Howdy.

I am having a serious need to re-emerge into Wing Commander (just purchased prophecy for GBA, and want to replay all the old games) but I'm finding an apparently familiar problem. They simply will not run properly.

For Wing Commander 1 (the only one I'm trying to get work for now), I have dosbox, but when I try to use WC it tells me that I need "Win32". When I use XP, the game is superfast and unplayable.

Any suggestions?

Thanks.

Mike
 

ChrisReid

Super Soaker Collector / Administrator
I've never seen it display that error. What exactly does it say? What steps have you taken to modify dosbox from its original configuration?
 

criticalmass

Vice Admiral
I had something similar once. If it says something like this:

MIDI:Opened device:win32
Exit to error: Failed to create a rendering output

...try setting the sound output to some other mode, like overlay.
 
U

Unregistered

Guest
As far as I can tell, I have done nothing to change the config of Dosbox. I get a "Win32 required" error whenever I type in the wing commander executable file. Sorry I can't remember the exact text, I'll check when I get home from work.

I can open the game just fine from XP, and it actually plays fine, except that the it is playing about 1000 times too fast!

I don't know if I have the WC saga, or or an original version. The game was floating around on an old laptop and I transferred it to my new system.

Anybody here know if the GBA prophecy version is decent? I'm looking forward to it. I was planning on working my way back through the series (I've never played the second half of WCIII, WCIV, and prophecy), but so far I've had a bear of a time just finding copies of the first three games, let alone making them play right.

How has this game been forgotten? It blows any other flight combat game I've played out of the water (I'm talking to you, TIE Fighter). Anybody have any suggestions for other similar games that actually run on the PC or XBOX?
 

ChrisReid

Super Soaker Collector / Administrator
Well, the original DOS version would not ask for Win-anything, however the Kilrathi Saga windows version would not be running so fast. It sounds like a really odd situation. You need to look into that more so we really have somewhere to begin.

The GBA Prophecy is great, though it's a complement, not a replacement for the PC version.

You should register and post your question about other space sims in the general forum. We need to keep this thread for technical support.
 

Overlord

Spaceman
Sorry if I was off topic. I have now registered, and will take comments to the appropriate forums.

I will check the exact error message tonight.

I just purchased a copy of the Kilrathi Saga online, and that may solve all my problems (I hope), as I have had such trouble getting WC1 to run that I basically don't even want to try with the other two.
 

Edfilho

Cry some more!
I was testing the WC configs above, and I have a few problems... General Midi is Mono, while SB is stereo on all games.

My version of wc1 is a strange cd based one, and it runs without sound (only pc speaker) and no joystick support... any tips?

Update, samething happened with the cd (EA Collection 2) version of WC2.

Speech ok, pcspeaker sound and no stick...

How can I fix that?
 

ChrisReid

Super Soaker Collector / Administrator
Sounds like an incompatibility between the settings, dosbox and your sound card. Try more configurations in the installation menu. SB/Pro/16 can all work differently. DOSBox defaults to IRQ7 I believe.

Does dosbox detect the joystick as it's booting up? You need to make sure windows is detecting it properly as well. WC1/2's recognition of joysticks is pretty standard, so if dosbox sees it, they should work.
 
U

Unregistered

Guest
WC3 and all that jazz

ok i am trying to install WC3 and i did the ems=false and all. is there anything else i should change? also how should i save it? what should i save it to? do i need to change dosbox after i have installed it? lastly how does one play the game without having to go through the installation process everytime and will i be able to actually save my game. thanx!


if you want email me at sinidrax07@yahoo.com or aim me at sinidrax07
 
Top