Run All Old WC Games in DOSBox Walkthrough

K

KA101

Guest
less tweaking, more flying

since wc3 has joystick support - why use xpadder anyway!
Something about WC3's failure-to-recognize the joypad as a joystick and my having more pressing things to do in meatspace than reconcile USB keyboard/mouse/joypad.

(Did not help that I saw nothing in the manuals about reconfiguring buttons once using joystick support. Perhaps I would prefer the right trigger, button 8 or so, to use guns as opposed to the Y button, button 1. Xpadder accommodates me there.)
 

Madman

Vice Admiral
ah, fair enough - you can also use dosbox's keyboard mapping device to do the same thing (ctrl + f1) - map the up arrow key to d-pad up.
 
U

Unregistered

Guest
Change discs

I'm using DoxBox to run WC3, disc one works like a charm, no problems. The problem arises when it tells me to change to disc two. How do I do that from within DosBox? When I try to mount the virtual drive to the same emulated drive, it still tells me to insert the correct disc
 

ChrisReid

Super Soaker Collector / Administrator
I'm using DoxBox to run WC3, disc one works like a charm, no problems. The problem arises when it tells me to change to disc two. How do I do that from within DosBox? When I try to mount the virtual drive to the same emulated drive, it still tells me to insert the correct disc
So the issue is that you have the WC3 discs copied to your hard drive and can't change discs? Try mounting each disc as its own CD-ROM drive and then pressing the space bar when the disc swap prompt comes up,
 
U

Unregistered

Guest
Sorry, no, I don't have the discs copied, I'm running ISOs, mounted on virtual drives using PowerISO
 

AD

Finder of things, Doer of stuff
Sorry, no, I don't have the discs copied, I'm running ISOs, mounted on virtual drives using PowerISO
Running ISOs still ammounts to essentially the same thing as copying the disks to the harddrive. You need to mount each individual virtual drive in dosbox separately. Then like Chris said, once you get to a disk swap message press the space bar and see what happens. IF you are trying to switch it to the same drive letter, then you have to alt-tab out of dosbox and tell your virtual drive program to look for the next disk ISO and then go back to the game and it should recognize the new disk... possibly you will also need to press space bar.
 
U

Unregistered

Guest
Expanded Memory Lock-up FIXED

I figured out the issue with the game starting up in DosBox only to freeze on Expanded Memory Found text. The Status Screen was telling me that there was several files that needed write-protection removed. Most of these forums tell players to change the read only section of the files. Well that doesn't really make any sense, so I went to the games directory and right clicked on the GameData folder inside. Now click on the "Security" tab. Click "Edit" and choose full control for everything listed. Now try to launch the game and Bingo was his name oh.
 

ChrisReid

Super Soaker Collector / Administrator
Most of these forums tell players to change the read only section of the files. Well that doesn't really make any sense, so I went to the games directory and right clicked on the GameData folder inside. Now click on the "Security" tab. Click "Edit" and choose full control for everything listed. Now try to launch the game and Bingo was his name oh.
That's mostly because time is linear, and before 2007 nobody had a Windows Vista/7 that came with a "Security" tab and stringent security settings by default. That is indeed a good tip for people today who've upgraded from XP.
 

KA101

Chief Petty Officer
ah, fair enough - you can also use dosbox's keyboard mapping device to do the same thing (ctrl + f1) - map the up arrow key to d-pad up.
Will look into that the next time I have a working controller. Bloody things seem to fail every time they're packed and moved. Belated thanks, though.
 
U

Unregistered

Guest
WC privateer + (acceleration button) not working

Hey guys, sorry for popping in like this, but it looks like you might have an idea to solving my problem.

I have downloaded the classic Privateer using DosBox to play however, I do not need to load it up through DB.

Anyways, the game works fine except for my + key. Neither + key works therefore I cannot accelerate, but I can decelerate. Is there a way to fix this?

Now, my mouse acceleration works but I would rather not use my mouse. I plan to buy a joystick for the game but was wondering if the keyboard issue could be fixed.

Thank you.
 

ChrisReid

Super Soaker Collector / Administrator
It's very unusual for just one key to not work. Can you do something with the DOSBox key mapper to reassign it?
 
U

Unregistered

Guest
It's very unusual for just one key to not work. Can you do something with the DOSBox key mapper to reassign it?
Hey, someone replied back! I did not think of that, but then again I do not use DosBox much. I will try that and see if it works.

It is very strange though because that is the only key that will not work.
 

MCROCOP

Spaceman
hey i'm trying to run wing comander 3 in dosbox 0.74 with the isos mounted in daemon tools but when i try to run it with WC3.exe the game never starts and dosbox do nothing.... :(:(:(


please help
 

ChrisReid

Super Soaker Collector / Administrator
Did you follow the instructions in the Tech Support section? https://www.wcnews.com/techsupport.shtml

What does "do nothing" mean? Do you get an error message? Does it freeze?

It sounds like you probably didn't correctly mount the drives as CD-ROMs.
 
Last edited by a moderator:

MCROCOP

Spaceman
Did you follow the instructions in the Tech Support section? https://www.wcnews.com/techsupport.shtml

What does "do nothing" mean? Do you get an error message? Does it freeze?

It sounds like you probably didn't correctly mount the drives as CD-ROMs.
yeah i've read the tech support but i'm using the imgmount to have the game in a especific folder and i've added this after the autoexec line:

''mount c c
imgmount g CD\WC3_CD1.bin CD\WC3_CD2.iso CD\WC3_CD3.iso CD\WC3_CD4.iso -t iso
g:
WC3''


and when i run it it simply the game keeps loading and nothing happens but it's not freeze because i can see the little bar that's keeps flashing as it were loading something
 
Last edited by a moderator:

ChrisReid

Super Soaker Collector / Administrator
Don't mount them all as G. Split each disc to its own drive (or just use your original discs one by one).
 

Madman

Vice Admiral
it's conceivable that the game doesn't like the cd's being drive g - if you mount a single image to d what happens, what if you mount the image in daemon tools or magiciso/nero's mounting tools then mount that 'drive' in dosbox (mount the iso in daemon tools to a "fake" dvd drive E: then in dosbox:
mount d E: -t cdrom

?
 

ChrisReid

Super Soaker Collector / Administrator
And the imgmount stuff is just complicating things. Mount the contents of the disc or the actual disc as -t cdrom, not -iso.
 
U

Unregistered

Guest
Privateer Glitch

Ok so I was able to install Privateer 1 fine and play for a few hours the first time I played. However when I tried to play again a few days later I ran into problems. The game opens fine but after I load my saved game and then try to enter the main concourse it opens the personal computer again, same goes if I try to launch. No matter where I go it just opens the personal computer. I thought maybe my save game was corrupted so I started a new game but again could not leave the launch pad screen without it going to the personal computer.

Any ideas?

Scott
 
Top