Privateer Error Code: D002-FFFF

Discussion in 'Tech Support' started by Unregistered, Jun 18, 2005.

  1. Unregistered

    Unregistered Guest

    Im having a lot of trouble getting privateer to work. Ii orignally said something about not enough memory but it usually says that about games. So I used DOSBox, I then disabled EMS through the DOSBox config file. But now I get another message.

    'Memory: Original Current Used
    'NEAR 29516 28986 530
    'FAR 376252 341020 35232
    'HIGH 3456384 3495840 -39456

    Fatal Error

    Error Code: D002-FFFF
    Program halted by code.
    JEMM unloaded


    Can anyone help me?
     
  2. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,444
    Likes Received:
    330
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    I'm going to sticky this, because it comes up all the time. You need to adjust your sound card configuration. DOSBox defaults to IRQ7 (also Port 220 and DMA 1) and many people are used to picking IRQ5 in the Privateer installer.

     
  3. Darsant

    Darsant Spaceman

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Florida
    Thanks a Ton that fixed it .
     
  4. GenVagabond

    GenVagabond Guest

    CO of TCS Hyperion "http://www.geocities.com/genrisko/"

    Ran Priv CD fine on DOSBOX. Intro plays fine, even the concourse. But I try to jump into space and "zzzzztt" program crash. Different memory address but similar error. Checked Sound IRQ's wasn't it. Try disabling Sound and Music. No go. Here's my error info:

    ----
    'Memory: Original Current Used
    'NEAR 30672 21808 8864
    'FAR 370284 291756 78528
    'HIGH 7502400 6847584 654816

    Fatal error.

    Error Code: 6071-FFFF
    Program halted by code.

    ----
    If anyone needs sys specs i'll be happy to make another post.

    Please help, I've been trying to get away from Priv Gold to the old DOS favorite.
     
  5. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,444
    Likes Received:
    330
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    Usually those -FFFF ones are related to sound card configuration, but you could also try disabling expanded memory. ems=false in the .conf.
     
  6. GenVagabond

    GenVagabond Guest

    CO of TCS Hyperion "http://www.geocities.com/genrisko/"

    Thank's for your quick reply Chris, unfortunatly, received same error code. I'd love to find out what memory address that is, but I have no talent for REAL debugging. I'll have to let a pro (or near pro) handle this.
     
  7. Gestahl184

    Gestahl184 Spaceman

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Hello, I seem to be having a problem with privateer. I receive the error code below when I try to talk to a character, use the mission computer, or launch into space. Could someone please message me back concerning this. I believe my priv.tre file maybe corrupt due to a scratch from my CD, because RF works perfectly for some reason. Please advise, or if someone could give me a clean priv.tre file that would sweet.

    'Memory: Original Current Used
    'Near 30672 21566 9106
    'Far 370284 249532 120752
    'High 3783824 3183056 600768

    Error #7053, subclass 0000
    Program halted by code.
    JEMM unloaded.
     
  8. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,444
    Likes Received:
    330
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    What's the file size of your Priv.tre? Does the game still crash if you disable sound in the installer? What version of DOSBox is this?
     
  9. Gestahl184

    Gestahl184 Spaceman

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Chris,

    I have the newest version of DOSbox, version 0.70. I don't have it in front of me at the moment (I'm at work), but I'm pretty sure the file size was about 187 megs (or 187,000 kilabytes). I haven't tried disabling the sound yet, but I'll give that a shot; however, that does not explain why Righteous Fire is working flawlessly.
     
  10. Unregistered

    Unregistered Guest

    I had the same prob. I just changed the IRQ to 5 w/ ems off and the loadfix -32 in the autoexec script.
     
  11. Unregistered

    Unregistered Guest

    kinda old, but if anyone still having this problem, disabling speech worked for me
     
  12. Unregistered

    Unregistered Guest

    actually now i used thunderboard and the default settings for it and now it is working with speech. using latest dosbox
     
  13. The Answer

    The Answer Guest

    The answer to d002-ffff

    Sound card related issue, I'm using current dosbox and dfend (GUI to dosbox).

    To resolve this issue, with speech enabled..

    In Dfend (or dosbox if you wanna type it all out) Setup privateers profile with soundcard set to Soundblaster pro, Address 220, IRQ 5, DMA 1. (This is the default for privateer install)

    Setup Privateer (install.exe).

    Music set to soundblaster pro/16, address 220, IRQ 5, DMA1, or just check to make sure they're at thouse settings.

    Speech, set to thunderboard, and use same address, IRQ, and DMA Settings, 220, 5 and 1.

    and save the profile (or script)

    Presto. Sound, speech and no crashing.

    Trust me, I'm a computer Technician IRL =) Happy Gaming! My #1 Favorite Game Privateer.
     
  14. Deadman_ny

    Deadman_ny Spaceman

    Messages:
    269
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Gloversville, New York
    Had a similar prob when i tried to run p2...just had to reinstall a newer version of direct x. NOT the versoion that came with P2. This was years ago when win 98 first came out. Maybe it'll help though you prob have dx9 or 10. :rolleyes:
    my 2 cents...
     
  15. WC4Life

    WC4Life Captain

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11,935
    Also get this error

    'Memory: Original Current Used
    'NEAR 29516 28986 530
    'FAR 376252 341020 35232
    'HIGH 3456384 3495840 -39456

    Fatal Error

    Error Code: D002-FFFF
    Program halted by code. (numbers and code different though)

    I know this is caused by the soundcard, I even figured for some strange reason my SoundBlaster 16 was set to Soundblaster in the Privateer setup utility. The SB16 is fully installed, all drivers present. So I changed it back to SB16, which it should have stayed since I last time turned off my Wing Commander Gaming PC (tm)

    The PC itself is a Pentium Pro 133 Mhz
    96 MB RAM
    DOS 6.22
    MS MOUSEDRV
    etc.

    It is the same configuration I have always used for DOS computers until my last old 486 PC's mainboard battery died and got irreplaceable, so I got the Pentium Pro, which I can slow down easily by disabling cache, games load slow then, but work. Or sometimes I use MOSLO.

    It worked fine last time I played. I have limited the EMS to 16384 MB, as I found that if you let DOS or QEMM (I use multiple boot options) use a larger amount (like 32+ MB) the game started but it was very slow (some kind of memory overflow)... ok... back to topic...

    The game starts... all fine... speed is also ok, not too fast, not too slow, without disabling processor cache or MOSLO or anything... all fine... until I launch off the base... I know this has to do with sound... but I don't understand why this problem happens... The disc is ok, only minor scratches, not used very often. I can make a new copy from clean image files I stored on a DVD, but I don't think it is the disc...

    Anybody having an idea how I can resolve this? I know my computer, I know the problem, it didn't appear earlier, all settings correct, what else can it be? The only logical thing seems to be the disc, but it really was only used rarely... I think I will reinstall Privateer... maybe then it will work...

    Will try to copy the disc to HDD with this computer but I don't think it will cause any read errors...


    WC4Life
     
  16. WC4Life

    WC4Life Captain

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11,935
    Though I posted it already in the other topic...

    I also had the above described error on my computer, but I have now found another reason why it occurs, and also how to solve it.

    As it was stated here that this error is caused by soundcard or memory issues I also thought about that first, however, I have found another reason...

    The error can also be caused by harddisk problems, just read on...

    Have to say that I have been playing Privateer on my old DOS computer for a several hours now. Everything is working, no errors, just one crash.

    Last night I plugged in my Win ME computer's harddisk and installed DOS and Privateer. Since I didn't change the configuration I have now found the reason for Privateer crashing. I have tested all soundcards I have here, therefore I can be pretty certain that the error was caused by my SCSI harddrive. Don't know why exactly, doesn't make sense at all. As far as I know Origin didn't write anything about not working on SCSI hardware. Maybe the drive was slowly dying, who knows.

    Anyway... DOS is not dead... all works fine now. God knows how long it would take to get DOSbox to work. Somehow I prefer my bigger DOSbox here.

    Of course, I am not sure if this will also solve the problem if it occurs in DOSbox, but in case nothing else works for you, try a different harddrive...

    WC4Life
     
  17. Unregistered

    Unregistered Guest

    Same problem

    hey guys, i was experiencing the same problem with regards to running priv.exe

    My problem now is i am getting an error that says my install.exe 'packed file is corrupt'

    Has anyone else encountered this problem? I just d/lded dosbox 0.73 and this privateer.zip from download full games.com I am chomping at the bit to play this game, I LOVE IT!!! Please help me if you can...
     
  18. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,444
    Likes Received:
    330
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    That's the problem with a lot of pirated games. They don't actually work. Fortunately it only costs a couple dollars for a used copy.
     
  19. f4greg

    f4greg Spaceman

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I download some 8M version and disable the sound and speech to avoid same problem
     

Share This Page