Privateer 2 XP Referenced memory problem fixed!!!

  • Thread starter Thread starter Unregistered
  • Start date Start date


I kept getting "The instruction 004173ed referenced memory at 4f41c161. This memory could not be read." everytime I would try and leave a planet and caliberate my joystick. What i did was manually enter values into my DARK.CFG for my joystick (PS to USB interface). That solved the problem. The only step I have left to do is to stop this error from happening when I type alt+o in space. Here is my Dark.cfg file:

JoyOn 0
ThrottleOn 0
Joy 1
Joy Dead 0.100000
Joy cx 130
Joy cy 130
Joy lx -10
Joy ly -10
Joy rx 250
Joy ry 250
Joy2 1
Joy2 cy 0
Joy2 ly 0
Joy2 ry 0
vid trans 1
anim trans 1
global sound 1
planet music 1
space music 1
space sfx 1
booth sfx 1
comp speech 1
engine noise 1
graphic detail 1
control method 1
orientation 1
invulnerability 0

If you have any questions or further ideas please email me at

---Blonde John
I used the patch (HCl Darkening Enhancement patch) and copied my CDs to a folder in my game installation ("P2Dcds") then set Dark.FIX file as
Adding the joystick changes you made didn't help me. Deleting everything in Dark.Fix file except for the file paths did avoid the reference error until I got into the bar scene then it happened again.
I still get the reference memory error after a few cut-scenes. I'm trying the Deluxe version of P2D now. I use the No CD fix which let's me get past the "insert CD 1" issue. But whether I have DarkFix installed ("p2_patch_test3 _Enhancement patch (non-Dos Box) ") I still get this reference memory error. Help?!