Joystick troubles with Privateer 2


I use an Thrustmaster USB joystick. The stick worked fine with Privateer Gemini Gold (which I bought it for) but has little "turn to the right tendency" when i play privateer 2. (BTW, I use the Win Patch and run WIn XP home). Recalibrating only helps in one way, that the ship stays on course. But still the joystick moves much faster to the right than to the left. When i try to turn to the left just a little, it also turns to the right. When I recalibrate the joystick, the red box (IMO, it shows the max range of the stick), never goes to the left corner of the calibration field, but alway to the right corner.
I game this is really anoying because it makes it really hard to follow ships which turn to the left... :(
Thanks in advance for help:)
So.. since this just came up in the Standoff forum.. are you sure your cable connection is solid and dust-free? It seems you're never able to get it calibrated, right, so you should start there. Can you just balance the left and right sides of the red box so that your center is calibrated properly? You won't have full range of movement, but at least you won't have your different sides pulling at different rates.
Thanks for the advice. I'll try this. The funny thing is, as I said, that this just happens with Privateer 2. It worked fine with Privateer Gemini Gold didn't notice it with Secret Ops either downloaded it just for testing the Joystick, seems to be a nice game though ;) )
Recalibrating didn't work. The dot starts in the upper left of the calibration box. as soon as i touch the joystick, no matter which direction, the dot jumps in the upper right corner and i never get it back on the left side of the screen.
I tried the joystick wit standoff and it works fine there. I guess it must be some kind of software problem with Privateer 2. The Thrustmaster USB Joystick comes without any software or drivers. There are also no drivers available for download.
I did wonder if there is any kind of software i could kind of put between my winXPhome and the game?
BTW, I already tried to recalibrate the joystick in the winXP settings... didn't make any difference...:(
Yeah, lack of specific drivers could be a problem. USB wasn't even around when Privateer 2 was released, so I can see there being problems with it automatically working. That being said, if you ever had an opportunity to try the DOS Privateer 2, DOSBox converts USB joysticks into a format recognizable by DOS software. Since that works as well as it does, I'm sure there must be some software that might try to reinterpret your Thrustmaster signals for Privateer 2, but I've never really found any.
Nice idea, I never tried to run P2 in dosbox, i just used it to install the game and the copy the winpatch over it.
I followed your advice and tried it in dosbox but i can't tell you if the joystick works then, because an other problem occured. The videos break in dosbox. I don't get pass the origin intro. I also can't skip it. the game simply crashes (mean it stops) and i have to quit dosbox.
I searched the dosbox thread but haven't found a post concerned with the videotrouble...any help?

Thanks in advance...
Yeah, video trouble is quite rare in Privateer 2. When you mount the CD-ROM, are you making sure to mount it as a CDROM type? "mount d: d:\ -t cdrom" You might make sure the sound is configured correctly. DOSBox defaults to IRQ7 and most WC games default to IRQ5. There are always tricks such as execution the program with the loadfix parameter. "loadfix p2" or "loadfix -64 p2" Make sure you've upped the cycles prior to launching the program so the CPU power allocated to the game doesn't choke.
HI, I'm new and anoying... sorry.
I did what you told me and it had some certain effect. It won't launch the game anymore and dosbox tells me FILE IS TOO SMALL TO ESTIMATE DATA STREAM SPEED... :(
Just for the records:

I found an really starnge solution to my joystick problem. :)
The USB Thrustmaster runs now fine in the P2 Win Edition. :)

In just leave the joystick unplugged. Then I start the game, launch my ship, go to the options-screen, go to the calibrate joystick screen and THEN, not one moment earlier, I plug in the joystick. And now I can calibrate it without any difficulties and it will work fine... :)

If you plug it in befor you start the game it will never work - but plug it in while you are in calibrate joystick screen and everything works as well as possible... isn't that weird?

If anybody can exxplain it to me you are welcome...:)
Martini Doctor said:
HI, I'm new and anoying... sorry.
I did what you told me and it had some certain effect. It won't launch the game anymore and dosbox tells me FILE IS TOO SMALL TO ESTIMATE DATA STREAM SPEED... :(

That's because you're starting the game from CD2 or 3. Make sure you also apply the DOS patch.
Sorry, but i used cd 1. I also use the dospatch.
But my joystick works now in the windows version so running it under dosbox is not interesting for me anymore.
Thanks for the help though :)
well im using a Gamers Factory 10 button usb game controller
ive tried all kinds stuff to get it to work but the settings either crash p2 or cause it to spin down and to the left
nomatter what settings

oh and the game pad has a setup similar to a ps2 controler
What version of Privateer 2 are you using? What operating system or environment are you trying to use it in? What kind of drivers do you have for it?

I've never heard of "Gamers Factory," so my first thought is that it's just incompatible. You probably wouldn't get a signal at all running the DOS version, unless you were in DOSBox, which would probably handle the input okay if the controller is recognized in Windows okay. If you're playing the Windows version, then it's going to be more picky about the drivers, which a lot of cheapy gamepads are notoriously bad at.
Alt-O (O, the letter) brings up the game menu (and access to: joystick configuration) in-flight (crashed game with reference read error in DarkFix version of game.
So close to making the game work (Dos Box gives me full-screen) but I can't get any button or key to fire weapons and even worse the game crashes trying to access the game menu when in flight (Alt-O). I guess I'm throwing in the towel unless someone has a suggestion.
Last edited: