Alpha Test Game 4

capi3101

Rear Admiral
Turn21MP:

Moved Archon...signed out to see if I'd get any tailing data, since Wandering Soul "has a vague notion on the direction Dark Archon will take." Signed back in; nothing.

I like the buttons on the Account tab, BTW; very nice.
 

Ironduke

Spaceman
I was puzzled by that empty field report too, at first. Then I recognized we both wouldn't shoot our own fighters anyway...
Maybe put in some "Nothing to report" message if there's, you know, nothing to report. :D
 

Ironduke

Spaceman
Hm, I second capi's experience with tailing. Zeta 1 also had a vague notion of where Bravo 1 would be going next, but Zeta 1 wasn't coded in orange in the Tailing Predictions tab, and it also didn't tell me any details about Bravo 1's orders. (I went back to the main menu and checked to see if anything changed, but to no avail.)
 

capi3101

Rear Admiral
I'm currently holding off on issuing orders to Wandering Soul if this is something we want to/need to investigate...lemme know when I can proceed.
 

Avacar

Vice Admiral
I was puzzled by that empty field report too, at first. Then I recognized we both wouldn't shoot our own fighters anyway...
Maybe put in some "Nothing to report" message if there's, you know, nothing to report. :D
The 'nothing to report' only happens when a blank report comes up; because of some of the formatting, it wasn't recognized as blank. I may need to update this to use some jquery to detect a lack of text (which isn't the same as a lack of html tags... which is still text to the php but not to the jquery).

I'll look into this newest set of tailing issues later today.
 

Avacar

Vice Admiral
I'm going to be reversing and rewinding the entire movement phase and end phase processing to try and isolate this bug. I'll let you guys know when I'm done, at which point, you'll all need to re-submit your orders for this movement phase, even if you already did.
 

Avacar

Vice Admiral
... I just accidently deleted the entire piece database. I'm contacting technical support to see when the last backup was. Without it, we'll need to start a new game, and all old games would be gone. Fortunately I didn't whipe the template database :S

Good news is, I did find the bug. Tailing should start working now.

edit: Okay the database is back, but processing that turn threw... a lot of errors. The turn went through, though, although there is some serious wierdness with the field report. Go ahead and try playing now.
 

capi3101

Rear Admiral
Okay...I see the tailing report. It's telling me that it's waiting for another commander to enter their moves. I move Dark Archon and log out, then log back in...and there's the tailing prediction for Archon, though unless I'm mistaken it's not reporting speed correctly.

Something may have gotten fouled in Game 5 with all this; I'm pretty sure I input my orders for 2MP earlier today. I just put them back in. You may want to have the Game 5 folks check to make sure their orders are still in and valid (at least for those folks who have put their orders in already).
 

Avacar

Vice Admiral
yeah, as I suggested earlier, I intentionally reversed your orders for Game 4. Good point about Game 5; the orders are all undone... I better delete them to be sure they don't go in double. (side effect of destroying the pieces database).

What does the tailing prediction say? Post it here.
 

capi3101

Rear Admiral
Since I'm pretty sure Ironduke can't capitalize on it, I'll go ahead and post the message now. It says "Dark Archon will move forward with speed 2 and turns starboard 2."
 

capi3101

Rear Admiral
22MP: Dark Archon has tailed Wandering Soul perfectly...but the yellow indicator was not on, I've moved Wandering Soul, logged out and logged back in, and I don't have the tailing information...I'm getting no messages whatsoever (having moved Soul, I wouldn't get the yellow "impending tailing info" text, I know). Will hold off on moving Archon for right now.
 

Ironduke

Spaceman
I got the tailing report "Bravo 1 will turns port 2" (sic) in 21 MP. (Technically, I didn't log out and sign in again - it was enough to just go back to Game 4's main menu.
 

Avacar

Vice Admiral
Okay... so it ends up that the fix I did yesterday is allowing the tailing info to propagate, but we're back to it not updating properly. You're successfully tailing wandering soul from a turn ago instead of this turn. That means that the ship id update routine is borked again. Sadly this is one of those bugs that I can put in a fix, and then we need to wait for another tailing opportunity to test it again.

So, go forward with your orders and try tailing next time. Fix is in place.
 

capi3101

Rear Admiral
Turn22 CP:

Something's seriously messed up with the interface; when I close the orders window, I can't get any of the pop-ups to come back (not even the ones for my own ships). I have to re-load the page to regain functionality.

Still saw everything bunched up once; I saw on the Game 5 thread where that had been fixed and it's been a little while since I saw the ships bunched up, so it may be fixed by now. Still thought I'd mention it.

Something's also up with shooting...can't get the target selection box to come open for any of my weapons (on Soul or Archon). I was gonna complain about not having any valid gun targets, but I guess Zeta1 is in the correct arc/range.
 

Avacar

Vice Admiral
All that looks fine to me; I was just doing another test/update, specifically with the combat dialog to see if I could fix the jumpiness we see on the Game 5 large map. (Couldn't fix it). I've reverted the code.... see if you're having any of those issues now. You might have just been trying to use it while I was also sending up new content/changing things.

The bunch-up fix only went in around the same time I posted that; if you've seen it prior to that point, then it is possible. If you've had the page open this afternoon, there was a period where the minimap was there and worked, but we were still seeing bunchups.
 

capi3101

Rear Admiral
Still no joy on the popups/target selection box...hang on a sec. Okay; I'm still at work. Switched over from Crapfox 3 to Chrome 14 on my terminal's VM, and it looks okay. Probably just this freakin' old version of Firefox I'm stuck with, then.
 
Top