Trouble with Wing Commander 3


Hello everyone, sorry if this sort of thing has come up many times before, but I seem to be having some troubles. Basically, I have Windows 98 running and I am trying to install and play WC:3. In Windows, after calibrating my joystick, it tries to draw some object "as fast as it can," but at this point nothing happens (unless this takes a VERY long time). I have been able to load this object (a spinning cap ship) in DOS, and would be content to play in DOS mode, but I can't get my sound to work properly. I was able to choose Sound Blaster Compatible for my music, and that set up okay, but I can't find a card for my fx. I haven't tried every one yet (my actual card is a Crystal SoundFusion; anyone heard of it?), as my computer locked up in the middle of the list. Anyway, does anyone have any idea how I can fix my Windows problem, my sound problem, or both? I have managed to play the game in DOS without sound, but it just isn't the same. Thanks for any help!
Sorry to add to this, but I have one more thing. I am also unable to use my Sidewinder Joystick in DOS mode, which is unfortunate. I do have an old Thrustmaster (Top Gun Platinum) I could use, but it's a little messed up. Oh well.
oh, and sorry for not posting this in the Tech Support forum. I am new here and did not realize my error until it was too late.
No worries, a mod will move it sooner or later. Pity I can't help you with the sound problem - won't it work with the standard SB compatibles option?
Thanks for the info. I'll know where to find this post if it's gone. Here's a question you (or anyone else) might be able to answer: For those of you who run the non-KS version of WC3 in Windows 95/98, how do you do it?
Thread moved to Technical :). Hope nobody was too confused when it mysteriously disappeared from General ;).
Well, I've never had reason to put any sig on before (LOAF saying I was correct didn't sound too exciting)... but hey, it should be OK now.
Thanks for moving this thread to a more helpful location! Anyway, I tried the shortcut idea, and I've tried running it like normal off the CD, but I always have the same problem. Here's how it goes (as accurately as I can detail it):

First, I execute the wc3.exe file. Secondly, it asks me to calibrate my joystick (I have a Microsoft Sidewinder) which proceeds without any problems. So far so good. Then I hit [ESCAPE] to continue, and the screen says this:

Wing Commander III -- Install Machine/Video Speed Test:

Wing Commander III will now test the speed of your machine
by loading an object from the CD-ROM drive and drawing it as
fast we can in SVGA if you have VESA driver installed or VGA
if not. We will test the speed of your video, processor and
CD-ROM Drive. The results will displayed on completion.
Press any key to continue...

So, I press any key (usually [ENTER] or [SPACEBAR]) and my little DOS window turns gray and nothing happens. If I minimize it to, for example, type in this window, it is orange when I return. So, at this point all I can do is close the window. I have tried disabling hardware acceleration (I have a Voodoo5 5500 PCI) and changing to 256 colors, but doing that changed nothing. Like I said earlier, I am able to "install" and play the game in DOS mode, but only without sound and the only joystick I can use is my partially destroyed Thrustmaster. This is all very strange, but I would appreciate any help. Thanks!
Okay, I tried something different. I ran the install program in full screen (from Windows), and the spinning cap ship appeared and that went well. I did have to push [Y] to force SVGA mode or something like that, but that didn't seem to be a big issue. Then I got a message telling me my CD-ROM drive was faster than was possible (I guess they didn't have 40X's when this game first came out). However, the install proceeded and both sound tests went okay. However, then the install program quit and I got this message:

Exception 13 happened

CS:EIP = 0127:00001B3E
EAX = 80808080, EBX = 0000E0B8, ECX = 00001FFF, EDX = 00000003
ESI = 00001594, EDI = 00008000, EBP = 000F6C54, ESP = 000F6C0C
DS = 0117, ES = 011F, FS = 0117, GS = 0000, SS = 00CF
EFLAGS = 00010206

1) 00000000 5) 00000000
2) 00000000 6) 00000000
3) 00000000 7) 00000000
4) 00000000 8) 00000000

This error is probably the result of a bad CD-ROM read.
Please try running the game again from your latest save
game and the problem should go away. If the problem
persists, you may have a bad CD. If you continue to have trouble,
please call Origin Customer Service for more information

So, I ran it again without testing (just selected the cards), and saved and exited. This time I was able to start the game with sound (although it was a bit choppy) and even got part way through the conversation with Hobbes before it happened again. The game seems to run fine without sound, so I'm assuming it's a sound card problem. Let me know if you have any ideas, and I'll continue to provide useful updates as they come along. Thanks!
Well, it seems like it's just a sound problem now. I do have to re-calibrate my joystick everytime, which is a bit annoying, but isn't a real issue. I am doing okay with reading subtitles, but a game like this really needs sound, especially for the dialogue, as it really adds to the experience. Plus, with subtitles, it's kind of hard to know who is really speaking.
You might be able to adjust some of the digital sound settings manually. The music is just MIDIs, so you can just set that to WAV synthesizer or MIDI synthesizer or something. Go to your control panel and system settings. Double click on the icon for your sound card. There should be a tab that has "settings" on it. Click it and copy down the settings, IRQ, DMA, stuff like that. Then go to the WCIII install utility in a DOS window. In the digital audio settings options, change the settings to whatever you have. If some info isn't there, you're going to have to play around with it. Worst case is you have to restart.

Hope that helped. ;)
I tried going to my sound card like that, but there was no "settings" option. I did look at "Computer" in Device Manager, and the settings for my sound card seemed like the default ones in the installer, so I don't know what the problem is there. I had a more complete explanation typed up earlier, but I was trying to tweak with WC3 in the midst of it and my computer locked up. Oh well. Hopefully I'll get this figured out soon, otherwise I'll just resign myself to playing with subtitles.