Sound prob with Privater 1


I've been playing through some old dos games and my friend gave me Privater to play(he said I might like it) anyway, it seems to run fine untill someone shoots lasers.. When I fire my lasers it starts to stutter, I know it's the sound becuase it doesn't do this with the sound off but the strange thing is that the laser sound seems to be the only sound that makes the game stutter. In the intro the ship sounds and speech is fine but when the gunfight starts(lasers) it stutters.
I've also noticed that if I fire just one laser it's fine but if there more than one, it's stutter time..

I'm useing a A3 sound card and every other game works fine when I pick any Sound Blaster or Adlib as my sound card but Privater just doesn't want to work right.

Anyone know what could be wrong?
One possibility is that you've got too much memory. Priv sound screws up when it's got more than 16mb.
Well that didn't work =( It's strange because it's not just the sound that stutters it's the game, it's like it's pauseing and unpauseing over and over untill the sound is done.

I guess I could try putting my card on differant settings and see what happends..
Hmm could the sound file be bad? I mean this is an old game.. My friend coppied all his old disk games to cds in hopes of saving them but maybe he was too late..
Just to be safe on this: make sure your EMM386 line in config.sys is as follows:


If that's not the problem, then the sound settings probably aren't correct. You mentioned using an A3 sound card; did you mean A3D? One of the Aureal cards? If so, check the device manager for an entry under Sound, video and game controllers labelled Sound Blaster Emulation. Check its resource settings, make sure the SET BLASTER line you're using is correct, and then make sure you installed Privateer using those settings.
My EMM386 line from my config.sys is:


I'm not really sure what the I=B000-B7FF does but if I don't have it there I'll only get 564 Conventional but with it there I'll get 604.

It's a Avance Logic 3D sound card, it came with my PC. It's a PnP card and I installed some dos drivers, the setup never gave me a SET BLASTER line but it has worked with 5 other dos games(some much older than Privater). I've tried installing the game with Sound Blaster, SB16,SBPro and they all have the same problem. The music is fine no matter what so is the speech from the intro and the sound works ok untill there's more than one of the same sound( Like the 3 Pirate ship flyby sounds from the intro and more than one laser firing).

Any ideas?
The I=B000-B7FF means that EMM386 includes that memory range (which is actually 32K as opposed to 2K because those are segment addresses) in its optimizations, which is why you have 32K more free conventional memory with it than without. I think those segments actually refer to video memory that's used when SuperVGA graphics are employed, which is why it's not normally included in EMM386's optimizations. Since Privateer doesn't employ SVGA, you don't need to worry about it; its 320x200 graphics start at the next segment: B800.

Thank you, assembly programming class.

As for the sound card, the only thing I can think of is that maybe it doesn't support enough simultaneous audio streams; I doubt that, though, because then it should still work if you choose vanilla Sound Blaster. It's not a memory problem. Perhaps there's some other TSR that's interfering with things. What do you have loaded?
Well I'm useing a boot disk (one I made a while ago)I forgot what I used to make it but it gives me an option to boot with EMS or without so I've been useing it with all my dos games, worked fine untill now.

Here's my Autoexec.bat:

LH /L:0;2,4688 /S C:\GLIDE\GLIDE

And my Config.sys:


The Glide is my mouse and the Gravis Grip is my gampad. I don't think it's my gamepad though because I've played 3 other dos games with it and the sound worked fine.
Whoa! What on earth are your Files and Buffers settings doing so high?? No wonder you don't get much conventional mem without the B000-B7FF inclusion. You might try lowering both to 25 or 30, then removing the B000-B7FF inclusion to see if that is in some way interfering with things.

What is this Glide thing? Is that your mouse driver, or is it related to the gamepad?

Remove the second DOS= line, and add NOAUTO to the end of the first.
Glide is my mouse, it's one of those touchpad mice. Ok I'll try what you said.. I'm to put NOAUTO at the end om my DOS= command? So it'd be DOS=HIGH,UMB NOAUTO right?

Well that didn't work.. Without the B000-B7FF command I can't get more than 550 Conventional mem but even with the other changes it still didn't fix it. Maybe it's my Sound Card...

Well thanks anyway, if you think of anything else feel free to post it, I'll keep checking back for a few days.

[This message has been edited by Phoenix (edited May 11, 2000).]
There are certain drivers that Windows needs active in order to load (such as IFSHLP.SYS and a few others), but are useless to normal DOS operation. NOAUTO forces the operating system to not load these drivers, thereby giving you a little more free conventional memory. Windows won't work with NOAUTO active, though, which is why you should never put it into your actual CONFIG.SYS.
Hey Fighters

I just got the Priv CD, after recently spilling coffee all over my Priv floppies. Here's the thing, my sound has never worked. I have a Toshiba Infinia w/ a 400Mhz AMD chip and 64 Mgs RAM, and a Yamaha OPL3 SA sound chip. I'm using a boot disk to run the game and although it get's choppy between sequences (death explosions, and such), it runs fairly well. Except for the sound! I'm going to attempt to use some of the fixes described below, but if they didn't work for Phoenix, I don't see them working for the Spankster. If someone out there has a system similar to mine and the sound works, I'd appreciate the assist. Fight the good fight men!
No need; the file you're looking for is called SETUPSA.EXE. Do a search on it, then run it from DOS. It'll configure your sound card.
Yeah... OPL3 SAs are very easy to get running in DOS. Damn, I wish I had one of them here, instead of this accursed CrystalFusion beast.
Last edited by a moderator:
Hey guys;

I tried to use the setupsa program but no go. Here are my boot disk settings.



Enable CD-ROM support in MS-DOS.
Enable mouse support in MS-DOS.






By the way, if it's useful to know, my sound is the chip on the board, not a seperate card. At any rate, still no sounds- I want to hear "You're about to suck void, pal" before I blast him into atoms!

Thanks for the assist!
As I recall, you need to add a line to the config.sys as well. But I can't remember what the line was. Wait for Stinger
Last edited by a moderator:
I never had to add a line to config.sys for it; do you have the SETUPSA.EXE file, Spanky? If so, did you run it from DOS or from Windows? It should be run from DOS, just before you play a game.
I had a line in the config.sys, but I took it out since it was doing me no good and I didn't see one in Phoenix's files below. I'll try the setupsa twice- once in pure DOS and once after I do the boot with the floppy- any suggestions to that effect?