Running Privateer 1 on Windows ME


Rear Admiral
Help, I got it all installed but when I try to run the program I get the error message "Network driver detected. Cannot switch to protected mode safely. "

I dont know what that even means, i dont have the internet or anything running while I try to run that program. Can someone help me?
FYI, I have a Dell Dimension 4100 1Ghz Pentium II and I am running Windows ME, and I have a Creative Sound Blaster Live! (WDM).

I got the same error message when I tried running it on my Compaq Persario 233 mhz Pentium II. HELP!
ME does not support DOS. P1 is a DOS game. If you are trying to run P1 from ME it just wont work without a lot of work. I have not yet hear of anyone getting P1 to work on ME. Now you can use a win95/98 boot disk which can be modify to play P1 on your ME machine. I have a SBLive card so setting it to work in DOS mode is no problem.
But you also have to take into account that I tried running it on my Compaq which has Win 95, and I got the same error message. Has anyone else got a similar message to what I got?
I have successfully run Privateer on two Compaq systems (486DX4100 and P166) using Win95's pure DOS boot. No sweat.
Technically pirated? Downloading from an abandonware site is the very definition of piracy, MadDog. How many times must we say this? DO NOT talk about this stuff here. Most importantly, DO NOT provide such links.
Trying to run Dos games meant for Dos on WinME is like trying to fit a square peg into a round hole. You might be able to force it, but dont expect good results afterward!

Im sorry, it didnt seem like it was pirated. I was just trying to help those who may not of had the game.

Wedge, How did you do that, with the DOS boot? And what is the command line you type in to get it working?
Originally posted by RFBurns
Trying to run Dos games meant for Dos on WinME is like trying to fit a square peg into a round hole. You might be able to force it, but dont expect good results afterward!


I Play WC3 in my ME very well.
Apples instead of teapots now? :)

Originally posted by MadDog243
Wedge, how did you do that, with the DOS boot?
Upon seeing the words "Starting Windows 95..." press F8 and select Command Prompt. Assuming you have your drivers set up correctly, Privateer should run fine.
Assuming you have all your drivers set up, that your comp has the right amount of mem, and your game installed properly, just head straight into the game.


How hard is that?
Wedge: Oh, 'tis a random process :).

MadDog: Look, I know how difficult it is to get old games, but right now abandonware is still considered a form of piracy (never mind if you think abandonware is a good idea or a bad one - this stuff is not to be discussed here). The CIC maintains ties with Origin, so it cannot tolerate software piracy in any form. Hence we've got rule 11 - no talking about piracy, abandonware, et cetera.
Quarto, I was aware of that rule, hell ive been here for over two years now. I just didnt stop to think that what I was doing was piracy.

I have been looking to get a replacement for privateer for a while, i bought it a few years ago and could never get it too work, it said some of the files were corrupt. Beleive me my mistake will not happen again, I just wish my original copy worked.

Wedge, ill play around with the settings and get back to you.
Ok, heres an update. I went into the dos prompt, coppied the command line out of the properties window, it wasnt like you said wedge but oh well. On my compaq I went into Ms-Dos, and I typed cd\wcpriv~1\privat~1 Enter, then Priv and it said "Protected mode driver is not responding to ems function calls. Make sure your ems driver is not configured with the noems option. If it is, replace the option "NOEMS" with "RAM". "

I looked all over my computer for the EMS driver, I dont even know what it is and didnt find it. Does anyone know what it is, and or what I need to do?
Erm... modify that to


Of course, if you already have an EMM386 line, just change it so it matches the one above. And if you're changing your original config file (as opposed to one on a boot disk), then remove the I=B000-B7FF part.