Run All Old WC Games in DOSBox Walkthrough

That maybe something worth checking on...I've got WC1, SM1 and SM2 all working from the same directory, with one subdirectory called GAMEDAT.
The main directory has these files:
install (app)
sm2 (app)
trans2 (app)
transfer (app)
wc (app)

I know the transfer applications are for moving a pilot record over from WC1 or SM1 to SM2. Whether or not you have them would depend on your original downloads.

The GAMEDAT directory has 83 files in it; I won't list them out just yet. But do you have the same number of files in your gamedat directory?

CAMP.002 locally is only 1 kB in size.

I've also got a couple of .DRV files; may want to check to make sure they're present.
TM.DRV (30 kB)
Are these files present, and are they the same size?

And just making sure here, you did copy the SM2 files in the same directory as your WC1 files, right?

I don't have either wc.vlp OR the sm2.vlp file. I'm not sure what those are, admittedly. But I do have all the other files you listed in your main directory. I also have those .DRV files, and the sizes match up, and the SM2 files are in the same directory as WC1.

Here's where it gets a little off: I have one GAMEDAT directory for WC1, which contains 68 different files. For the different copies of SM2, I've got two different...things. In the SM2 that has a seperate GAMEDAT directory, that GAMEDAT directory has 32 different files, and in the version of SM2 which has all the files in the same directory, there are 28 different files. I'm afraid to start combining directories; some of the files have the same names. I'm gonna try to move over any non-matching files from the SM2 directory that did NOT contain the GAMEDAT subdirectory first. If that doesn't work, I'll try the files from the SM2 that DOES have the sub-directory. And I'll be smiling the whole time....

HOLY CRAP! IT FRIGGIN WORKED! I will make an altar to WC CIC where I will worship for eternity! Over the top? Maybe, but I've been banging my head against the wall for a while on this one. Sometimes literally

So, I copied all the files from the version of SM2 to my WC1 GAMEDAT sub-directory. If there were any duplicates, I did NOT replace them. Then I made sure I had teh app for SM2 in the same directory as WC1, and Ca-ching! Thank you, capi! Ralgha nar Hallas, here I come! Oh, that was nerdy, even for this place...
Just got myself a brand-shiny-new computer, and re-downloaded WC1, 2, 3, and 4 from GOG. When I went to launch WC1 for the first time, the picture doesn't fill the screen, It goes all the way to the top, and the edges, but stops about two inches from the bottom. This gives the game a horizontal, stretched-out look. Anyone run into this before? Any suggestions?
Yeah, and when I ran SM2 through DosBox manually, it doesn't happen. WC2 and SO1 & 2 work just fine. Weird stuff...
I hope I'm not double posting here or anything but I need help. I have an original disc, from which I installed wc1 in dosbox .74 easily enough and it played, but simply would not find secret missions. Tells me it can't find the disc or the files. Then there's trying to install that, and also same for wc2, during the installation everything goes well up to the point where it asks from which drive to copy the files. Doesn't matter what I type here it simply does not go any further. Is it my version of dosbox maybe? Any help would be appreciated. If you say that GOG version runs fine then I'll buy that but kind of silly when I already have an original copy (CD Version) Thanks!
Okay I've figured out that part. Now after installation all files I have in my wing directory are transfer.exe a config file and the gamedat directory. So now what??
Well... yeah. The GOG versions will be more or less the same as what you have, but preconfigured. Anyway, on the WC1 and WC2 CDs the root directory should have a bunch of batch files that you can ignore. Instead of running the installer, you can just copy the wing2 directory to your hardrive. From there you can run winstall.exe to set up your sound, and then run the game.
Ok great! That simple...thanks! Just a teensly problem with game freeze in the second mission now (WC2)

Yeah... I guess it's a memory issue. You need to start the game in dosbox by typing " loadfix -32 wc2 " in dosbox... or you can add the line to the end of the dosbox config file if you want to launch the game from a shortcut.
Hi everyone, I know this thread's been quiet for awhile, but I have an issue here.

I'm trying to run the DOS version of WC4 in Boxer on a mac. I got everything to install correctly, seemingly, and the game starts up and runs fine through the into movies and the bar fight scenes. As soon as we take off though and it has to switch to spaceflight mode, it crashes. I get the following error:

"Open failed on file: ../../DATA/PALETTE/WC4SPAL1.IFF

This error may be the result of a conflict with your system configuration and Wing Commander IV. Please try running BOOTDISK.EXE to make a floppy boot disk that may remedy this problem. If you continue to have trouble, please refer to the README.TXT file on the CD for troubleshooting information."

I can't find any relevant help in the Readme file. I've tried every combination of video settings in the install/setup, VGA, SVGA 8bit, SVGA 16bit. All produce the same results.

I tried to find this file, WC4SPAL1.IFF, and couldn't. It's not in the install folder I copied all the disc files to, and I re checked all the CDs to make sure I didn't miss it. I can't find it. So I'm really not sure what this file is.

I'm pretty bummed out on this, I never got around to playing WC4 back in the day, although I lived, ate, breathed, and slept WC1-3 and Privateer. I was excited to see it on gog, then depressed to see it was only for Windows. So I bought the dos version on ebay, and lo and behold, I can't play it.

I've never had any problems running other games through boxer or dosbox, so I'm at a bit of a loss here. Any help would be greatly appreciated.

Last edited:
Maybe you can still use the GOG Windows version; @wcnut uses WINE to play wcdx, so maybe WC4 will also work (and you'll get the DVD movies).
Last edited by a moderator:
I fear wc4 dvd version doesn't work, at least not on OSX with the way the movies are relayed to quicktime, (quicktime player not supporting the proper codecs) doesn't do it. on Linux however I have heard of some success with Prophecy DVD version, so maybe holds true for WC4. For now though we are stuck with the CD release on Dos.

As for WC4 dos, it could be Boxer's shadow copying getting in the way, and things are getting mucked up. I would do a complete clean install, shadow copy is intended to save player profile data in your home folder so each game can save in the user homefolder, like a modern application. problem is it saves all the games data files too on install, and management is rather clunky and I don't think it was fully realized. There is the File -> Player Data -> Merge into Game, which copies evreything that's in the shadow copy back into the .boxer wrapper. (you would do this after install). Then delete evreything in the .boxer folder and try again.
In Wine try setting ddraw to gdi instead of OpenGL in the windows registry. I found that that fixed a lot of compatibility issues with Kilrathi Saga and WC4 DVD. There should be a way to wrap the MCI stuff in wine. I had some success with it years ago by installing codecs etc in wine.
In Wine try setting ddraw to gdi instead of OpenGL in the windows registry. I found that that fixed a lot of compatibility issues with Kilrathi Saga and WC4 DVD. There should be a way to wrap the MCI stuff in wine. I had some success with it years ago by installing codecs etc in wine.
Are you on OSX? GDI I would not recommend as it is a performance hit and wouldn't effect the way MacWine does it's video rendering. Kiltrathi Saga wcdx is the way to go for 1 and 2, though i haven't tried WC3.
I *probably* should post this on the Privateer entry on the DOSBox site, but I feel I'm more likely to get an answer here.

Since upgrade to Windows 10 (x64) some of my games have audio issues, ranging from skipping, to crackling to simply just not having audio. Privateer in DOSBox is one such example, the SFX are ok, but the music is scrambled; it's hard to explain. It's not the same issue as the 'slow' music glitch, that one seems quite's more like the music has a high amount of reverb and crackle. I may have to make a recording.

Non-GOG version; this is the vanilla install originally from 3.5" (non speech pack)

Anyone encountered the same in W10?
Last edited:
I just installed WC3 GOG version and its running fine exept for one thing and that is my joystick seams to have a big deadzone and movement seams to be a bit rough and unprecice.
I have a Thrustmaster T16000M. Does anyone have an idea how to make it work more smooth?

I installed the Origin version and it ran smoother. After taking the values from that version my GOG version runs also smoother but it dosn't look as good. More pixelated but at least I can aim better now.
Last edited: