No Joystick in WC1 (KS)


Rear Admiral
ok, i got a problem with my gravis firebird and wc1 of the kilrathi saga. i just cant use my joystick. its calibrated correctly and i can use under dos (and in other win games i suppose - havent tried). im using win98 se and ive installed directx8. i tried almost every possible combination of keys to enable the joystick (wasnt it ctrl+j in the dos verision or something like that?), but i wasnt succesfull.
ich searched around in this forum, but everything i could find was to install the directx version deliverd with KS. but that would be directx2!!! i dont think that could help.
so is there any combination ive not thought of or any other hints???
Why don't you try it? Using DX2 would be the first thing anyone here would recommend..
doesnt installing directx2 cause conflicts with other (newer) games? if yes, thats not a real good advice. but if theres no other possibilty, ill try it...
i think that game is worth to risk stablility. ohhh, it remebers me. wc1 was one of the first games i ever playes (well, REAL games). and i completed it without knowing what to do, cause i couldnt speak english. man, that was funny :)
Hmm... the last time I let KSaga install DX2, it caused a mess. I wouldn't recommend it, myself.

Two suggestions... first of all, check if the joystick works in other Win9x games. If it doesn't, then it's not KSaga's fault. Second, try it without the joystick. Mouse is good...
mouse is good?? wow, no!!! i played it with the mouse one time (cause we didnt have a joystick), but that was the one and only time!
now, i installed dx2 restarted windows. but theres no change. wc2 doesnt work with my joystick neither. and i checked my joystick with other games, it works fine!
any suggestions?
i really dont get it. in the help file is said, that the games use the joystick-applet of windows. so that shouldnt be a problem...
has ANYONE ever had the same problem? if yes, PLEASE help me! i want to play these games! finally!

oh, before you ask, i cant update the windows driver for my joystick. its the driver delivered with windows. and on gravis page, the latest driver for my joystick is from 95...
and no, i dont want to buy another one. it works fine (it has about 15 functions, cause its plugged to the keyboard also).

but i just dont get it...
I don't know what ChrisReid is thinking, but installing DX2 is most definitely not what I'd recommend. The game should still work with most later versions of DirectX.

What you need to do is check the joystick applet in the Windows Control Panels. Make sure your stick is actually listed; it sounds to me like it isn't.
A lot of people have resolved problems with their joystick and other things by letting KS install its DX2. And the latest versions of DirectX handle it much better than older ones (and are much more friendly about a blanket reinstall of DX7 or DX8 when you're done).
ok, guys, i searched around a little bit (well, actually not a little bit. way too much...), and finally i found a workaround for my problem. somewhere i read that changin the joystick in the applet from "Gravis Firebird" to "CH Flightstick Pro" would solve a problem in another game. ok, desperated as i was, i tried that. and it works!!! i dont know why, but now i CAN use my joystick! its a miracle! ;)

so, i finished wc1 and im no looking forward to SO1+2...


thanx anyway. for your effort.
My, that's a first... never heard of that particular solution before.

Gravis Firebird, eh? I'll have to remember that for future reference.