New Privateer 2 Patch Adds Deinterlace Feature & Makes Numerous Improvements (October 1, 2013)

Hello everyone,

I scoured the thread in hopes for a solution.
I use GOG, installed the game, the game works fine, mouse works, sounds/midi, graphics and inverted spaceship flight mouse control but effectively the de-interlacing is really hard on my eyes.

So I looked in GOG support for the game and I found the unofficial patch "".

Darkfix.exe fixed the de-interlacing. It is great to look at those animations and actors. unfortunately, I am no computer wizard, my mouse does get stuck right away, down at the bottom and somewhere to the right. I found a post mentioning Norton, I turned off all norton functions for 30 minutes, re-launched darkfix.exe but the mouse issue persists, the mouse get stuck way at the bottom and somewhere to the right, so that solution was not for me

Is there a way to apply darkfix.exe from or to GOG launcher and using DOS emulator that comes with the game on GOG?

Incredible to find such oldies still with great appeal, thanks in advance.
I'm sorry to reference a 4 year old problem, but I ran into the same problem and couldn't find any discussion, that has mentioned or fixed this exact mouse problem yet.

Game starts up fine, videos are de-interlaced, but as soon as I see the Sinner's Inn Bar, the mouse cursor ist locked in the lower right corner. By right clicking, I can cycle the interaction options and I can see the cursor jumping to and hovering over the different options, but left clicking does only sometimes work and is really finicky. While trying different click sequences, I sometimes manage to select an option and can even travel to the customs, but as soon as I'm in the booth, I am stuck because I can't cycle through interaction options by right clicking. In the dialogue selection at the bar, I can only select the lower option. After releasing the right mouse button, the cursor immediately jumps from an interaction option straight back to the lower right corner again. Pressing alt+p to open the PDA the exit button is immediately selected and I can only click left or right to exit, but nothing else.

When I try to run the game via the GOG Galaxy launcher or another DOSBox app the game runs just fine, but only in the 17.0e version without the enhanced patch. So this tells me there also should be a way to make it work with the darkfix.exe, with the problem being just a minor setting I'm missing.

I would really like to play through the game with the de-interlaced videos and use the features in the enhanced patch. Or is there a way to apply the patch in a DOSBox environment?

By now I tried the following:
- used patch
- used
- set compatibility to Win 95 and 98/SE
- ran darkfix.exe as admin
- changed the drive letter in dark.fix and dark.cfg to the correct install path
- tried the gog troubleshooting steps for keyboard/mouse not working at
- tried praying to the omnissiah

Any help is appreciated!
I tried this patch on Windows 11 and it crashes. I can't get it working at all.

Soo, someone needs to look into that since we are all moving to Win11 at some point.
AH. I did not try to change the drive letter. That may be the issue. The patch files could be pointing to the wrong spot.