Yet another Privateer Sound Issue

Curly

Spaceman
Hello
I've been going through this phase of playing all my old dos games lately, and all work in DOS, except for Privateer. The music is fine, yet the sound and speech is just screechy static. I've looked through the different posts in the archives and tried making shortcuts to ms-dos etc, but nothing works.

I have a P2 350, with 128 megs ram, 2 6.4 gig HDs, 24x CD, 4x CD-R, Diamond Viper v770 TNT2 Ultra 32mb video card and a Diamond Monster Sound mx300 sound card. Using the ms-dos shortcut or regular ms-dos startup autoexecs end in the same way, so I'll post the shortcut files:
-------------------------------------
Config.sys
DOS=HIGH,UMB,NOAUTO
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE RAM 16384 /I=B000-B7FF
BUFFERSHIGH=25
FILESHIGH=25
devicehigh=c:\cd-rom\d011v110.sys /d:mscd000 /n:1
------------------------------------
Autoexec.bat
@ECHO OFF
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
LH C:\WINDOWS\AU30DOS.COM
SET BLASTER=A220 I7 D1 T4
LH C:\WINDOWS\COMMAND\mscdex.exe /d:mscd000 /m:18
------------------------------------
Dosstart.bat
c:\windows\command\mscdex.exe /d:mscd000 /m:18
LH AU30DOS.COM

LH C:\PROGRA~1\MICROS~4\MOUSE\MOUSE.EXE
------------------------------------
Using the shortcut to ms-dos I have 616k of Conventional Memory, even with the CD-Rom drivers running. I have yet to try it with the mouse.
Thanks for any help.
 

Stinger

Vice Admiral
Hmm; are you sure you're setting up your sound drivers correctly here? I noticed you're using an Aureal card; the settings it uses in DOS are based on the settings it uses in Windows. Go into your Device Manager and check the resources listed for Sound Blaster Pro Emulation.
 

Curly

Spaceman
Yeah, the settings are the same as what I'm setting them as in Privateer. All my other dos games' sounds work fine, Wing Commander 2, Privateer 2, Tie Fighter etc. Just Privateer I have a problem with.
 

Stinger

Vice Admiral
Mad Hatter, are you limiting your free EMS memory to 16 megs? To do so, just put the number 16384 in your EMM386 line in your config.sys, like so:

DEVICE=C:\WINDOWS\EMM386.EXE RAM 16384 /I=B000-B7FF
 

Mao Tse Tung

Spaceman
Wow! I was having the same problem with Privateer as Curly and Mad Hatter, but limiting the amount of expanded memory to 16 MB worked! Thanks so much for the solution, Stinger, even though it was not directed at me! I really missed the sound effects and voice-overs.

Now I have another question. Why is Privateer this picky about the amount of expanded memory that is available?
 

ChrisReid

Super Soaker Collector / Administrator
Well.. it was one of those oversights.. like a limit of 640 k of conventional memory or two digit years..
 
Top