Yet another Privateer 1 sound question

GetCool

Spaceman
Hi all,

After spending five hours, I finally got P1 to run on my computer in DOS with sound :D. At first I was having memory issues, then I couldn't get it to run with sound, but I finally got it working. However, I am still having a problem; when I play the game, the music cracks and pops and lags, and the sound quality is generally terrible.

I have a SBLive! 5.1 card, and the main reason I was having trouble getting the sound working at all was because I could not find any DOS drivers on my PC to use in autoexec.bat. So, I poked around in this forum a bit and found this thread and followed Johnl12's instructions on how to get SB16 emulation working. I downloaded the SBLive! DOS drivers from here, placed them in my C:\SBLive folder, and used the following config.sys and autoexec.bat files to load DOS and run the game:

CONFIG.SYS
---------------

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE 16384 D=64 FRAME=E000 /I=B000-B7FF RAM
DOS=HIGH,UMB
FILES=30
BUFFERS=30
DEVICEHIGH=D:\DOSUTIL\OAKCD\OAKCDROM.SYS /D:MSCD0001
STACKS=0,0

AUTOEXEC.BAT
-------------------

PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
PROMPT $p$g
SET CTSYN=C:\SBLIVE
SET BLASTER=A220 I5 D1 H5 P330 T4 J200
LH C:\SBLIVE\SBEINIT.COM
LH D:\DOSUTIL\CTMOUSE\CTMOUSEP.COM
LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001

Now all this probably has nothing to do with poor sound quality, I just thought I'd post it in case. Anyhow, I was wondering if my problem could either be because (A) The DOS drivers for the SBLive! family stink, (B) I am using SBLive! DOS drivers with a SBLive! 5.1 card, or (C) I should choose different sound options when installing Privateer. I explored the possibilities of (C) somewhat and chose all the different sound options, but none were any good. Choosing General MIDI or WaveBlaster as the music device gave more consistent performance, but the MIDI quality is crap. No matter what I tried I got poor sound quality.

I'm guessing there's nothing I can do about it and it's just poor drivers, but if you can offer any info please do. I used to be a big fan of Sound Blaster products but now I am very disappointed in Creative Labs and their software (i.e. Bloat!Ware for Windows).

Thanks for your input
 
Top