Yes, it's Privateer again. :)

Earthworm

Spaceman
This post is to Stinger/TC, or some other DOS experts. My OS just crashed (damn Windo-crap), and while instaling it again I lost everything that was on my HD, including the shortcut that Stinger helped me to make so I could play Priv. I instaled Win 98 Second Edition (over the old Win 95) and started instaling my WC games thinking that I'll have to come here and ask for help with Config.sys and all that other stuff for Priv. Well, I instaled Priv and it worked withough me having to modify any files, and without copying the .TRE files to my HD. So, now you'll asking why I'm here if it works. Well, the mouse doesen't work, and moving around the space stations and planets is a real bi*** with the keyboard. So if you could help me get that mouse working Earthworm would be very happy.

Here's the Autoexec.bat, (I think this is the one with the mouse lines, but if not I'll post Config.sys later):

SET TEMP=C:\WINDOWS\TEMP
SET MSINPUT=C:\MSINPUT
SET BLASTER=A220 I5 D1 T4
EM ENABLE MOUSE SUPPORT IN MS-DOS.
EM C:\MSINPUT\MOUSE\MOUSE
SET CLASSPATH=D:\PHOTODELUX\ADOBECONNECTABLES
PROMPT $P$G
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:TOSCD001

CLS
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
ECHO
C:\WINDOWS\msg_priv.com


Thanks.

------------------
A good soldier is not the one who die for his country, it's the one who makes his enemy die for his.
Gen. Patton
 

Quarto

Unknown Enemy
Umm... is the EM C:\MSINPUT\MOUSE\MOUSE actually REM C:\MSINPUT\MOUSE\MOUSE ?
If so, then I imagine that removing the REM bit will get the mouse running. Try that. If it doesn't work, come back here and wait for the real experts to answer your pleas
.
 
Last edited by a moderator:

TC

SubCrid
I find it weird that it clears the screen and echos a bunch of blank lines... That seems like a strange batch file to me...
(When text output isn't important that is)

TC

------------------
CAG of the Blacklance HQ
"Canadian and proud of it"-TC
 
Last edited by a moderator:

Earthworm

Spaceman
<BLOCKQUOTE><font size="1" face="Arial">quote:</font><HR>Originally posted by Quarto:
Umm... is the EM C:\MSINPUT\MOUSE\MOUSE actually REM C:\MSINPUT\MOUSE\MOUSE ?
If so, then I imagine that removing the REM bit will get the mouse running. Try that. If it doesn't work, come back here and wait for the real experts to answer your pleas
.<HR></BLOCKQUOTE>

No, it's just EM.

TC, I don't care how many echos there are as long as the game works. And it does.
 
Last edited by a moderator:

Quarto

Unknown Enemy
That's odd... but it's probably supposed to be REM, since I've never heard of anybody having EM in their autoexec.bat. Well, try removing the EM from the above-mentioned line. That should be even easier than removing REM, since it's one character less to remove
.
 
Last edited by a moderator:

Earthworm

Spaceman
OK, I removed the EM's, and when I tried to play it said ther's not enough EMS memory and I couldn't play. Anyhow, I copied the .TRE files to the HD (it's only 160 megs) removoed the CD lines and some other useless stuff from autoexec.bat, and now the mouse works.


------------------
A good soldier is not the one who die for his country, it's the one who makes his enemy die for his.
Gen. Patton
 
Last edited by a moderator:

Stinger

Vice Admiral
Don't worry about the echoes. It's just to make the Priv message nice and pretty, centered on the screen.

Now, Earthworm... what's so bad about going around the screens without a mouse? TAB cycles through the hotspots, and the cursor will move with the joystick.

Oh, yes, that EM thing was probably supposed to be REM; wonder how it got screwed up. So, if you can stand playing without the mouse, just put REM where those EMs are (in fact, you can delete the line with "ENABLE MOUSE SUPPORT..." entirely; it's just a comment). Otherwise, post your config.sys.

Also: is this file your actual autoexec.bat, or is this attached to a shortcut/boot disk?
 

TC

SubCrid
Oh, ok I've never actually used a game made boot disk (always made them myself) so I wasn't sure what those echos would be for. Thanks

TC

------------------
CAG of the Blacklance HQ
"Canadian and proud of it"-TC
 

Matrix

Rear Admiral
Earthworm: You could try put "LH" in front of "C:\MSINPUT\MOUSE\MOUSE" and that might give you enough RAM for the CD-ROM drivers. I wouldn't try it unless it you think it's fun, or you're desperate for HD space though.
 
Top