Wing Commander Prophecy High Res cutscenes are interlaced

Discussion in 'Tech Support' started by Phlogios, Aug 20, 2010.

  1. Phlogios

    Phlogios Spaceman

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hi guys!

    I recently downloaded the HCl High Res patch for Prophecy, and was surprised to see that the videos are interlaced.
    I have installed the Mpeg2DecFilter.ax file, and the AC3 filter.

    What's really interesting is that when I play the files in VLC, they are interlaced too. BUT, when I play them with Windows Media Player, they're not.

    By "interlaced", I don't mean that the videos have black horizontal lines, but whenever something moves, the image gets jagged edges, just like on an interlaced LCD TV.

    Is it interlaced for you guys too?
     
  2. Wedge009

    Wedge009 Rogue Leader

    Messages:
    10,102
    Likes Received:
    42
    Trophy Points:
    69,385
    Gender:
    Male
    Location:
    Sydney, Australia
    I think the interlaced scanning may be an artefact of this particular encoding. Your particular decoder used with WMP may be doing something extra to avoid any interlaced scanning artefacts.
     
  3. Phlogios

    Phlogios Spaceman

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    This is what it looks like. Horrible.
     

    Attached Files:

  4. Wedge009

    Wedge009 Rogue Leader

    Messages:
    10,102
    Likes Received:
    42
    Trophy Points:
    69,385
    Gender:
    Male
    Location:
    Sydney, Australia
    Firstly, they're a huge improvement from the videos in the original CDs, don't complain.

    Secondly, you need to switch on de-interlacing in VLC, if you want to avoid these artefacts. See below for the same frame with de-interlacing switched off and on, respectively.
     

    Attached Files:

  5. Bandit LOAF

    Bandit LOAF Long Live the Confederation!

    Messages:
    28,824
    Likes Received:
    560
    Trophy Points:
    69,485
    Gender:
    Male
    Location:
    Ashton, MD, USA
    Is this just a blurry scene? It just doesn't feel right to me.
     
  6. Phlogios

    Phlogios Spaceman

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    So the short answer is:
    Everyone has the same problem.
     
  7. Wedge009

    Wedge009 Rogue Leader

    Messages:
    10,102
    Likes Received:
    42
    Trophy Points:
    69,385
    Gender:
    Male
    Location:
    Sydney, Australia
    Given that everyone is using the same source material, I would say so.

    The scene begins watching the people play their card game, then pans to the right to view Casey entering the Rec Room. Hence the camera movement and subsequent blurring.
     
  8. kirby2000

    kirby2000 Captain

    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    11,875
    Did anyone ever find a solution to this?

    As far as I can see, the original files are interlaced. You can fix this by playing them outside of the game, but can you fix them in game by using a different decoder or a patch?
     
  9. Sammy75

    Sammy75 Spaceman

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Gender:
    Male
    FIRST BACKUP YOUR VOB-VIDEO-FILES!

    I had the same Problem with Interlace-Lines in the Video.
    So i put all VOB files in a Folder (134 items), and created a subfolder "deint" for the new deinterlaced Files.

    I Downloaded ffmpeg 3.2.2 and copyed the ffmpeg.exe to the Folder where the VOBs are.

    I created a file "deinterlace.bat" with the following code inside:

    for %%a in ("*.vob") do ffmpeg -i "%%a" -c:v mpeg2video -c:a copy -vf yadif -b:v 9000k "deint\%%a"
    pause


    Then i start "deinterlace.bat". It deinterlaces all VOB files and saves them in the "deint" Folder.
    These new Files can now be used in the movie Folder of the Game.

    Have Fun!

    Interlaced.png deinterlaced.png
     
    Last edited: Jan 18, 2017
  10. AD

    AD Finder of things, Doer of stuff

    Messages:
    5,011
    Likes Received:
    132
    Trophy Points:
    51,885
    Location:
    BC, Canada
    Thanks for posting what worked for you. Many codec packs do come with configuration tools that you can set to deinterlace Mpeg2 videos as they play. However, this isn't usually the default settings and requires you go in and tweak settings. Having the videos deinterlaced to start with is definitely easier.

    However you do have to beware as the method you mention here uses a standard Yadif deinterlacer. The prophecy VOBs *are not* interlaced in the normal sense. They are Telecined. That means there's 3 non interlaced frames followed by two half/interlaced frames. If you step through the video in a player with auto deinterlacing turned off (the newest version of MPC I tried had it turned on by default) you will see this five frame sequence repeated... 3/2/3/2/3/2 and so on.

    Running a standard deinterlacer gives really un-even results and you will find you will still have some frames left over with jagged lines and other funny artifacts introduces in some of the previously non-interlaced frames. To get the best results (if you want to pre-process them using virtual dub or some other conversion software that will mostly leave the frames that aren't interlaced alone) you will want to run a reverse-telecine pass on the videos and then you can either leave the frame rate as is with 4 full frames plus one doubled frame, (which might make it stutter a bit) or run a 'decimate' pass to remove all the duplicated frames and then adjust the frame rate to match the audio/original video running time.
     
  11. Sammy75

    Sammy75 Spaceman

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Gender:
    Male
    I just will it keep simple for non advanced Users in Video editing.

    If there is a way to do de-telecine with ffmpeg maybe i could add it to the batch-file.

    How i can i find out witch mpeg2 decoder WCP uses?
    I installed ffdshow and set deinterlacing to always.
    I also set the mircrosoft mpeg2 decoder to always deinterlace.

    But i has no effekt.
    Seems there is another mpeg2 decoder installed on the system.

    BTW: First i had video but no Audio.
    But in windows media player audio works.

    After installing AC3Filter Package Audio works now.
     
  12. AD

    AD Finder of things, Doer of stuff

    Messages:
    5,011
    Likes Received:
    132
    Trophy Points:
    51,885
    Location:
    BC, Canada
    There might be. I mostly just do everything in Virtualdub though so I'm not familiar with what options there are for working directly with ffmpeg. There might be other options in the deinterlace filters (as a function of them instead of being their own specific filter) to do undo the "3:2 pulldown". You could search for IVTC or Inverse Telecine filters as well, but I always found I had to really experiment with different settings and filters to get the best results, which can be time consuming.
     
  13. AdamPH

    AdamPH Petty Officer

    Messages:
    61
    Likes Received:
    3
    Trophy Points:
    635
    Gender:
    Male
    Is that just the way the screen was taken, or did you manage to get the movies in 4:3?
     
  14. AD

    AD Finder of things, Doer of stuff

    Messages:
    5,011
    Likes Received:
    132
    Trophy Points:
    51,885
    Location:
    BC, Canada
    The movies in the DVD versions are encoded in a 4:3 ratio but the actual picture is a hardcoded (aka leterboxed) 2:1 aspect. The videos themselves are "widescreen" just not enhanced for widescreen TVs or monitors which means if yo display them natively you have both black bars above and below but also to the left and right. of the picture. The DVD patch basically applies a bit of a zoom so that the picture is not distorted but fills your screen with just a bit of black above and below.
     

Share This Page