Will program for free (Bored and Unemployed)

KillerWave

Spaceman
Strange about the turrets, i copied the info for the turrets from the midway, so in theory, it should work the exact same way...:(
I dont see anything that might be related to the turrets hitpoints, i will talk with Thomas, he might have some info on that.

Nice about the vdus

Im sending to you the detroyed version of the Dauntless i just made...take a look at the bridge when you destroy it (someone should take care of those lights ;)), along with it, there is a updated ship file for the ralari, adding 2 missile turrets to it (dont forget to add the hardpoints for it: mturret_01 and mturret_02 with the hardpoint editor, otherwise the game will crash), you will have to replace the vdu info on both ship files again...let me know what you think about the destroyed textures.

[Edited by KillerWave on 07-03-2001 at 16:35]
 

KillerWave

Spaceman
Oh, and that vdu for the dauntless you sent sometime ago doesnt work right...guess you have a new one ;)

About the turrets, try this Thomas sent (in the ship.iff):

There's a bug in the iff decoder and compiler that causes this. Try this (notice the inserted "byte 0"):

FORM "GTUR"
{
CHUNK "DATA"
{
cstring "turret_01_midhtr"
cstring "midhtr"
byte 0 // nothing
float 800.0 // hitpoints
}
...

I tryed it myself and it appears to work, but my guns right now are much different from the original WC ones (for the B5 mod). You will have to add this for each turret. dont forget to compile afterwards.;)

[Edited by KillerWave on 07-03-2001 at 20:50]
 

Quarto

Unknown Enemy
Hmm? No, I'm still using the same Dauntless VDU. It should work. What exactly goes wrong?

I'll try the turret thing and the new files as soon as I can. Unfortunately, I've still got some lectures today.
 

Quarto

Unknown Enemy
The textures don't work... you forgot to send the palettes. For now, I'll try it with other palettes, though it'll look wrong.
 

KillerWave

Spaceman
The palettes are on the way ;)
Btw, did the turret problems fix worked out?
And what about that i told you in the e-mail about the graphics?
 

Quarto

Unknown Enemy
Yes, the turret fix worked out. It took me an effort to get it running - WCPPas doesn't decode ships properly, and some of the data about engines gets lost. Needless to say, the game refused to work (which is actually what led me to edit the VDU data with a hex editor in the first place) until I fixed it. But now it works, and the BWS Dauntless is one ship you don't want to mess with ;).

Actually could you just check if this is what an engine is supposed to look like?

Code:
      FORM "ENGN"
      {
        CHUNK "DATA"
        {
          cstring "gun1"
          cstring "D_eng1m"
          cstring "D_eng1dm"
          float 2000.0
          float 0.0           //acceleration
          float 6.58963815173089E22//afterb. speed
          float 3.43149284738197E27//afterb. acceleration
          float 6.58963815173089E22//afterb. fuel
          float 1.30901063819197E22//Y
          float 0.0           //P
          float 3326409216.0  //R
          float 0.0           //YPR rate of change
        }
      }
I think it goes without saying that some of those numbers look wrong ;). Still, the game seems to work...

As for the graphics, do you mean the way the blue thing on the front of the bridge waves around? If so, then yes, it happens to me too. I've only noticed this on the Dauntless, though... I'll check if I see it on others as well.

BTW, about the Dauntless' collision tree, Thomas says that there isn't much he can do, since he's using the same tree-builder as you.
 

Quarto

Unknown Enemy
I wish they wouldn't send us those Academy hotshots!

...Because they always forget to turn the lights off when they die ;). That dead bridge is just so damned neat :D.

Speaking of textures though, I think I saw a mirror-image "BWS Dauntless" sign on the ship's side (next to the bridge)... anything we can do about that?
 

KillerWave

Spaceman
Originally posted by Quarto
Actually could you just check if this is what an engine is supposed to look like?

Code:
      FORM "ENGN"
      {
        CHUNK "DATA"
        {
          cstring "gun1"
          cstring "D_eng1m"
          cstring "D_eng1dm"
          float 2000.0
          float 0.0           //acceleration
          float 6.58963815173089E22//afterb. speed
          float 3.43149284738197E27//afterb. acceleration
          float 6.58963815173089E22//afterb. fuel
          float 1.30901063819197E22//Y
          float 0.0           //P
          float 3326409216.0  //R
          float 0.0           //YPR rate of change
        }
      }
I think it goes without saying that some of those numbers look wrong. Still, the game seems to work...

WOW, not really, its supposed to look just like this:

Code:
	FORM "ENGN"
	{
		CHUNK "DATA"
		{
			cstring "engine"  //hardpoint
			cstring "D_eng2m" // mesh
			cstring "D_eng2dm" //destroyed mesh
 			float 2000 //hitpoint
		}
	}

dont use wcppas to edit ship iffs, use a simple iff compiler. its much simpler and reliable.
As for the graphics, do you mean the way the blue thing on the front of the bridge waves around? If so, then yes, it happens to me too. I've only noticed this on the Dauntless, though... I'll check if I see it on others as well.

Yes, it happens with some original WCP ships too for me...wanted to know what causes it, and if its just me...if you get closer, it stops happening.

BTW, about the Dauntless' collision tree, Thomas says that there isn't much he can do, since he's using the same tree-builder as you.[/B]

Then its the case we put a hangar on it, i will try later to make a new hangar, (transparent), and place it on the dauntless, so it would appear that part is actually the hangar. There is any hurry in getting an hangar anyway?

I wish they wouldn't send us those Academy hotshots!

...Because they always forget to turn the lights off when they die. That dead bridge is just so damned neat.[/B]

Glad you liked it :D. I tough it would be a nice touch to add it. Also the engines (with that broken glass type of teffect) looks really nice in my opinion.

Speaking of textures though, I think I saw a mirror-image "BWS Dauntless" sign on the ship's side (next to the bridge)... anything we can do about that?[/B]

Im not sure i understand what you mean about it. can you explain it better? About the vdu pic, it looks almost all transparent to me, i can see only a few blue dots.Maybe the one i had got corrupted anyway.

Dont forget to send me back a copy of the dauntless (mesh and ship file) when you're done with it. :D
 

Quarto

Unknown Enemy
Wow, that is some mess :). I'd better inform Thomas about it... I can see that WCPPas isn't quite reliable enough to use for this stuff right now, but it would be nice if it eventually got to be that reliable.

Yes, it happens with some original WCP ships too for me...wanted to know what causes it, and if its just me...if you get closer, it stops happening.
Eh, well, it must be some peculiarity of the Vision engine... nothing important :).

Hmm, if you put in a transparent hangar, won't that mean that if it gets destroyed, no damage will be shown? Anyway, there is no hurry in getting a hangar... I mean, by now the Dauntless has reached the stage where we can start using it in missions anyway. The only difference is that we'd be able to use built-in landing procedures.
Other than the hangar, however, I have found another problem with the collision tree - one of the engines (eng1, I think) is extremely well shielded. You've gotta come in at a certain angle to be able to hit it... unfortunately, this is not the angle that AI ships attack at. But yeah, when I manage to destroy it, it looks nice ;-).

Im not sure i understand what you mean about it. can you explain it better?
Well, on the side of the Dauntless, right next to the bridge, there is a spot where there's a "BWS Dauntless" sign. But on one side of the Dauntless, the sign is upside down, while on the other it's backwards like in a mirror.

I'm basically done with the Dauntless now, so I'll send it in a moment, along with another copy of the VDU.
 

KillerWave

Spaceman
Originally posted by Quarto
Wow, that is some mess. I'd better inform Thomas about it... I can see that WCPPas isn't quite reliable enough to use for this stuff right now, but it would be nice if it eventually got to be that reliable.

Sometimes, a mess like that doesnt create probs, and i believe its ignored, but sother times it damage all the ship iff...


Eh, well, it must be some peculiarity of the Vision engine... nothing important .

It appears to be related with when some polys join with each others, the ship component absolutely have to. no big deal anyway ;)

Hmm, if you put in a transparent hangar, won't that mean that if it gets destroyed, no damage will be shown?

No, the mesh and the destroyed mesh are independent one from another, one can be transparent, while the other can have some texture to show damage.

Anyway, there is no hurry in getting a hangar... I mean, by now the Dauntless has reached the stage where we can start using it in missions anyway. The only difference is that we'd be able to use built-in landing procedures.

That means you wont need a hangar, or you still need one?

Other than the hangar, however, I have found another problem with the collision tree - one of the engines (eng1, I think) is extremely well shielded. You've gotta come in at a certain angle to be able to hit it... unfortunately, this is not the angle that AI ships attack at. But yeah, when I manage to destroy it, it looks nice
.

I noticed that, but if im not wrong, thats not the tree fault. If you notice it really well, when you get a torpedo lock on engine 1, you notice that it lock exactly in the middle between the engines, wich means that if you fire straight at it, the torpedo will not hit it, notice that it wont happen with engine 2. Its a case of editing the original model of the engine to place the center IN the engine, so the torpedo hit it. Can you manage to do it? Using the 3D exploration plugin to extract it, center and send me in a 3D format or should i talk with Wildcat?


Well, on the side of the Dauntless, right next to the bridge, there is a spot where there's a "BWS Dauntless" sign. But on one side of the Dauntless, the sign is upside down, while on the other it's backwards like in a mirror.

Well, if one side looks fine, and the other dont, its texturing fault...dont think there is much i can do about it. One option would be to completely remove it...:(


[Edited by KillerWave on 07-04-2001 at 10:48]
 

Quarto

Unknown Enemy
Well, I can manage without a hangar. Landing procedures are pretty complex though. They're worth the effort when you can also have the player land manually, but things being as they are, I'd be happy if I could use the built-in landing procedures. Still, if you don't have time to do it, that's fine :).

I can do something with the engine if you get it converted first... you could ask Thomas to convert it to 3DS format. Hmm... maybe I could even split the two engine models into five separate engines?

Well, if one side looks fine, and the other dont, its texturing fault...dont think there is much i can do about it. One option would be to completely remove it...
That may well be the best option. Heck, there's already a huge "BWS Dauntless" sign in another spot, so it's not like we desperately need this one. I'll look for the MAT with it, and take care of it.
 

KillerWave

Spaceman
Soberb work placing the turrets Q! :D
I must also say that i rather stay friends with it...thats a lot of guns! Even that i know its on my side, it gets me nervous with so many guns pointing my way...
The turrets also "blink" (quickly appear/dissapear) tough...
Btw...leave the textures as they are for now...Wildcat plans on changing the textures, and i will probably need to recompile all the meshes. Dont worry, i think we will manage to keep the turrets placement.
The VDU still dont work for me, im sending a pic for you to see.

Originally posted by Quarto
I wish they wouldn't send us those Academy hotshots!

...Because they always forget to turn the lights off when they die

Maybe we should put a warning on the wall:
"Please, remmember to turn off the lights before you die, because i dont think you will be able to do it afterwards" :D

But you isnt the only one that can say cool quotes, after seeing the Dauntless done, i need to say:

Bet you wish you had one of those during the war...it would put the fear of God into the bugs!



[Edited by KillerWave on 07-04-2001 at 14:00]
 

Quarto

Unknown Enemy
Well, carriers don't fly themselves :).

I have absolutely no idea why that VDU won't work for you :(. Could it be something to do with your graphics card? Looking at that picture, it quite obviously is the Dauntless VDU, but most of the lines have disappeared. Can you try it in a different graphics mode, perhaps?
 

KillerWave

Spaceman
Well, carriers don't fly themselves.
Technicaly, in SO game engine they do :rolleyes: ;)

Tryed in software mode, direct3d mode and glide mode. The VDU only works in software. Have you played in direct3d mode? Sometimes what looks fine in software, doesnt look good in directd3d.

I think its time to sent it to the others (Pedro and Thomas), then we can take a look if it works with them. Thomas has the same video card i have, so i think it may not work for him too, but i would like to know if the problem is my pc. Can you do it?

[Edited by KillerWave on 07-05-2001 at 02:01]
 

Quarto

Unknown Enemy
Yes, yes it is the SO game engine, isn't it? ;)

Yeah, I always play in D3D (don't have 3Dfx, and I'm sure not gonna use software if I don't have to ;)), and it works. Since the Dauntless is just about ready to use, I'll send it out to the rest of the UE team today, along with the VDU.
 

KillerWave

Spaceman
Originally posted by Quarto
Yes, yes it is the SO game engine, isn't it?

Well, reports are that your vdu run into a little trouble in its way here.
Ah, law and order, concepts that seem to be crumbling through the vdu pic management ;)

I've tryed to extract the midway vdu and convert it again to mat format to replace your dauntless vdu to see if it worked, but it gave me the same problem. Have anyone else found this problem?

I've got the Fralthi engine, thet wherent centered, but using milkshape, i managed to center it, but i cant center the dauntless engine, since milkshape only accepts one texture per object...

Later i will see if i can make it work with 4 engines instead of 2...or if it will give me the same error the ralari had. Wich is strange, since im sure the vesuvius in SO have 3 engine hardpoints

Btw, when you looked at the rotating part of ships, have you managed to make it rotate on the z axis? Thats the one i want to make the omega i have rotate, but the game refuses to rotate in this axis...Snuzzle had managed to make it work sometime ago, but everytime i used autopilot, it started to rotate the wrong way. And now Snuzzle dissapeared...again...:(


[Edited by KillerWave on 07-07-2001 at 00:25]
 

Quarto

Unknown Enemy
Originally posted by KillerWave
Well, reports are that your vdu run into a little trouble in its way here.
Ah, law and order, concepts that seem to be crumbling through the vdu pic management.
Well, these are transitional times, KillerWave :).

(Amazingly enough, we're still making sense... sort of)

I still haven't gotten around to sending the Dauntless off to the rest of the group... must do that today. Then we can see if they also have this problem. But I just don't understand why that would be... I mean, there's no reason why these don't work, if the hardcoded ones do work.

The Vesuvius definitely had 3 engines. However, notice that the Vesuvius' engine hardpoints are all at 0,0,0 - it must be that the models themselves are not centred. This might have something to do with it.

I only looked at rotating parts briefly - all I did was rotate them on the x axis. I'll experiment with y and z rotation later on.
 

KillerWave

Spaceman
Originally posted by Quarto
Well, these are transitional times, KillerWave.
[/B]

Yes, but in the turreting we had a common enemy, it was turret editor finest hour. Now we cast about uncertain...
You've seen for yourself the vdu problem. Its the transitional times or is there something else with the pc here? :D

(Amazingly enough, we're still making sense... sort of)
[/B]

Really amazing it still makes sens...sort of :rolleyes:
Check your e-mail...again.



[Edited by KillerWave on 07-07-2001 at 02:29]
 

Quarto

Unknown Enemy
Do you see a strategy or a design behind it? :D

Checked, replied. About to send you the Armada ships, as well ;).
 

Wedge009

Rogue Leader
Every time I connect the dots, I am guided back to our long-time allies in the WC CIC CZ. I think they've gone insane. ;)

Sorry, I couldn't help myself.
 
Top