WCProphecyHDPack Install Insert CD 1 probelm

AD

Finder of things, Doer of stuff
I believe we solved this over on Discord. For anyone else looking for a solution, make sure you install the patches in the correct order. There's a few different steps where it could break.

For reference:
1. Install the game - Most likely this will only be an issue with the GOG version anyway as if you install off the CDs you can just leave disk one in the CD drive and not worry about it
2. Unzip the WCP Enhancement pack patch into the WCP directory but don't actually install it
3. Copy the HD pack videos in the the 'MOVIE' subdirectory within your prophecy folder.
4. (OPTIONAL) install the Model upgrade packs.
5. Copy the updated DLL file into the Prophecy folder overwriting the one from the WEP
(https://www.wcnews.com/chatzone/attachments/gl_00007-zip.12178/ - The model upgrade pack might also include a version of this DLL. If you don't use that one you will definitely need to do this step. Even so, you might have better results with this one anyway and might want to use it regardless.
 

Freespacer

Spaceman
I believe we solved this over on Discord. For anyone else looking for a solution, make sure you install the patches in the correct order. There's a few different steps where it could break.

For reference:
1. Install the game - Most likely this will only be an issue with the GOG version anyway as if you install off the CDs you can just leave disk one in the CD drive and not worry about it
2. Unzip the WCP Enhancement pack patch into the WCP directory but don't actually install it
3. Copy the HD pack videos in the the 'MOVIE' subdirectory within your prophecy folder.
4. (OPTIONAL) install the Model upgrade packs.
5. Copy the updated DLL file into the Prophecy folder overwriting the one from the WEP
(https://www.wcnews.com/chatzone/attachments/gl_00007-zip.12178/ - The model upgrade pack might also include a version of this DLL. If you don't use that one you will definitely need to do this step. Even so, you might have better results with this one anyway and might want to use it regardless.

What about the OpenGL patch, should it be installed after the WCP enhancement pack patch?
 

LividLiquid

Rear Admiral
I need the same informatioon. Seems like I can get the movies working, run in full screen, or get rid of the cursor in the middle of the screen, but never all three at the same time.
 

AD

Finder of things, Doer of stuff
What about the OpenGL patch, should it be installed after the WCP enhancement pack patch?
Almost certainly. Similarly to if you wanted to use the model update pack, you would unpack the WEP into your prophecy directory (but don't run the installer), apply the openGL patch and then finally copy over the updated DLL. Let me know if that gets you up and running.
 

Panther1.0

Captain
this worked for me:
Install WC-Prophecy from the CD's or install the GOG version.
extract the HCl's WCP Enhancement Package straight into the WCP folder. Make sure you DON'T overwrite Prophecy.exe or WCPHR.DLL files.

Install Pedro's OpenGL Package, this is the 1.2 version or 1.22 if I remember correctly.
OpenGL-WCP_setup.exe

Right click on Prophecy.exe, change Compatibility and remove anything like Windows 98 compatibility or try with it, run as administrator, remove the "All users settings" tick at the bottom.
(From old notes, possibly windows 7)

Copy / Replace the DVD movie files into a folder called "Movie" in the WCP folder, use the new VOB's from ODVS (WCP-HD PACK)
I'm not sure but I think in MP4 format they also worked, I used "media player codec pack'' update for the DVD /HD quality files to play correctly.

In the graphics settings use OpenGL mode. you have to install a Codec pack like the one I mentioned above for the movie files to play correctly. this is mpeg2 and ac3 codecs in your system. Mpeg2dec and ac3filter are recommended.
 
Last edited:

LividLiquid

Rear Admiral
Unfortunately, this isn't possible, as after installing with GOG, the compatibility settings on Prophecy.exe are grayed out.

I can get the game to run now, and the movies play and in the right size if I set the OpenGL patch to 640x480, but there's that damned mouse cursor stuck in the middle of the screen and none of the cutscenes can be skipped.
 
Last edited:

Panther1.0

Captain
Very strange. are you using intel internal graphics or older graphics card ? Which o/s ?

I get fullscreen, full movie playback and no crashing mouse cursor 😳
 
Last edited:

Panther1.0

Captain
That's a 10 year old card but it should work fine, maybe try an older driver? Don't know, could you try it on another PC or at a friend :-/

I got it working with internal graphics on my laptop (onboard intel hd graphics)

Cheers
Panther
 
Top