WCArmada in Win98

Rocky

Spaceman
Recently I installed WCArmada onto my computer under Win98. When I try to load it, it says, "EMS driver is not VCPI compliant." What is the problem and how can I fix it?
 

Matrix

Rear Admiral
Here we go again...
smile.gif


I know that's not very helpful, but the solution is similar to all those that are given for running WC1/2 and Priv. Basically you'll need to make a DOS shortcut that starts Windoze in DOS mode with EMM386. Of course that means you'll probably need to init your soundcard under DOS...so you might as well start by giving us your C:\AUTOEXEC.BAT, C:\CONFIG.SYS and C:\WINDOWS\DOSSTART.BAT
 
Last edited by a moderator:

Rocky

Spaceman
C:\AUTOEXEC.BAT
-------
SETBLASTER=A220 I5 D1 H5 P330 T6

-------

C:\CONFIG.SYS
-------
DEVICE=C:\WINDOWS\himem.sys
DEVICE=C:\WINDOWS\setver.exe
DEVICEHIGH=C:\WINDOWS\emm386.exe 1024

FILES=15
BUFFERS=3

-------

C:\WINDOWS\DOSSTART.BAT
-------
C:\WINDOWS\CTCM

c:\logitech\mouse\mouse.exe


-------


THESE ARE ALL THE THINGS INSIDE THE FILES...
 

Stinger

Vice Admiral
Good, glad to see that the first part of business has already been taken care of. Now, to provide you with new config files. These should be placed in shortcut settings or on a boot disk; I'll describe the method for creating the shortcut in my next post.

Config.Sys:
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE 16384
FILESHIGH=30
BUFFERSHIGH=30

Autoexec.Bat:
@ECHO OFF
SET PROMPT $P$G
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET BLASTER=A220 I5 D1 H5 P330 T6
LH C:\LOGITECH\MOUSE\MOUSE.EXE
C:\WINDOWS\CTCM

Note: the Autoexec.Bat stuff listed above isn't quite complete; you'll get digital sound and mouse control, but you might not get MIDI. If you don't hear any music during the game, do a search (Start->Find) on AWEUTIL and tell us where it's located.

Second note: The CD-ROM drive won't work with these settings, so if you're using the CD version of WCArmada, be sure to copy it all to the hard drive first. It's not large.

With these settings, the game should work.

[This message has been edited by Stinger (edited March 09, 2000).]
 

Stinger

Vice Admiral
Now, onto creating shortcuts:

Hit Start->Programs and right-drag (right-click-and-hold) the entry labelled "MS-DOS Prompt" onto your desktop; select Copy from the menu that pops up. You should now have a shortcut on your desktop labelled "MS-DOS Prompt."

Right-click on the shortcut and choose Properties. Then, hit the Program tab and the Advanced button. Make sure the following are selected:

MS-DOS mode
Specify a new MS-DOS configuration

The two text fields should now be available for you to edit. Delete whatever's there and replace it with the stuff from my previous post. Hit OK and get out of the shortcut settings. When you double-click on this shortcut, your computer will reboot and take you to a DOS prompt. At this point, the game should work fine.
 

Matrix

Rear Admiral
Is it just me or should there be RAM after the line:
DEVICE=C:\WINDOWS\EMM386.EXE 16384

Oh, and add (to CONFIG.SYS):
DOS=HIGH,UMB
 

Stinger

Vice Admiral
Matrix: There are two possible settings where that's concened: RAM and NOEMS. I believe the default is RAM (and if I weren't lazy, I'd check it out).
 

Matrix

Rear Admiral
Stinger: I'll take your word for it.
smile.gif
But if I recall correctly, EMM386 defaults to NOEMS when run under Windoze. Not sure about the DOS shell of it though.
 
Last edited by a moderator:

Death's Head

Spaceman
I'm running Win95 and I can't find any .exe files for a mouse in dosstart.bat or anywhere else.

When I run Armada now, I have the joystick and key commands, I can't move the cursor by mouse and the joystick isn't all that accurate, which make gameplay hard except combat. When I go to alt-o to change commands, the game freezes.

Please help.

[This message has been edited by Death's Head (edited March 19, 2000).]
 
Top