wc4 in dosbox

AD

Finder of things, Doer of stuff
Choppy sound is normally the result of incorrect IRQ/DMA settings for the sound card. Make sure that your WC4 installation has the sound ports configured the same way that they are in your DOSBOX configuration file.

except that he's running the win95 version in XP. You don't get to set the IRQs, so that is irrelevant.
 

AD

Finder of things, Doer of stuff
I am getting it all the way through, both movie and game. The same in the dosbox.

Did you give turning your sound hardware acceleration off a shot? Go to contol panel, then "sound and audio devices", then click the Audio tab. Then click "advanced" under the default device section.
 

AD

Finder of things, Doer of stuff
The hardware accelerator was turned off.

It's possible it's an issue with your hardware. What are your system specs (cpu etc)? Did the sound improve if you turned up the sound hardware acceleration?

It's possible other directx issues (including video acceleration) could be affecting the game so you could try adjusting those settings as well.

If you are having sound stutters in dosbox, adjusting the cycles might improve things.
 

nectech

Spaceman
I went into dosbox and played with the cpu and frame rates. I got the sound to smooth out with the settings of cpu 20000 and frame rate at 10. Thanks for the suggestions.
 
Top