WC3 KS Version fix on XP

Discussion in 'Tech Support' started by Mincemeat, Jul 1, 2006.

  1. Darkmage

    Darkmage Vice Admiral

    Messages:
    905
    Likes Received:
    18
    Trophy Points:
    31,435
    Location:
    Australia
    WC replacement discs?

    Here's a question regarding the warez stuff not about the pirate side of it. With regards to damaged/missing discs. Does EA have any sort of replacement program? I know with Thrustmaster I can get replacement parts for my HOTAS Cougar for like $8 each. Does EA offer a similar service? I would be interested in this for replacing a kilrathi saga disc I lost with a legit replacement and I am sure other people would be interested in it too.
     
  2. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,447
    Likes Received:
    332
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    Yes, Origin had a disc replacement service back in the day, but it is no longer available. Very little software is supported like that more than a decade after its release. Do you have individual damaged files or will the disc not read at all?
     
  3. Darkmage

    Darkmage Vice Admiral

    Messages:
    905
    Likes Received:
    18
    Trophy Points:
    31,435
    Location:
    Australia
    I actually took my disc to school and it was stolen. I was just wondering if EA could still replace it. I fashioned a replacement disc using the .tre files from the wc3 dos edition and the wc3music.tre file from another kilrathi saga disc. seems to work fine. It was disc 3 of kilrathi saga. The wc3 equivalent was disc 2. the only file I'd need to replace to be an exact copy would be wc3music.tre from kilrathi saga disc 3. I may be missing music it has the other disc did not have.
     
  4. Tex

    Tex Guest

    Hi guyz

    i´ve tried all the solutions and suggestions on this thread but nothing seems to work on my main system Athlon X2 5000 clocked to 2.8 Ghz running XP SP2. But there are a few things that i have noticed:

    1.The game only locks up when playing videos or navigating and interacting through the Victory, it breaks everywhere on the lift, berths, living level bridge level flight level even when acessing main terminals or trying to enter the briefing room. Pressing ESC to skip vids do not help all the way when i hit ESC the vid freezes on a black screen if i let the vid go all the way it freezes the last frame of it or something. But as i mentioned before game also breaks while navigating or acessing a room or the main terminal so whatever causes the problem with videos freezing the game causes the exact same problem while accesing rooms in the Victory. So i´m not sure if xanlib.dll module is responsible for this.

    2.The game runs flawlessly while playing missions never locks at least it never happened with me.

    3.Compatibility does not work for me actually i think it just makes things worse

    4.Setting .exe affinity for one processor core only and lowering priority does not work at all for me also.

    5.Processor clock doesn´t seem to be the problem i lowered my system to just 600 mhz and same problems all the way as i mentioned above.

    6.Something interesting i´ve noticed i have an older system Athlon XP 1.7Ghz with 133 fsb running XP and you may not believe me but although the problem persists it crashes much fewer times than on my main system so maybe fsb causes this but i find it hard to believe.

    I´m pretty sure i´m not saying nothing new at all but we have to brainstorm every single idea we have we need to patch KS let´s do it guyz

    Thank you all hope you reply
     
  5. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,447
    Likes Received:
    332
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    It was primarily for discs that became scratched, floppies that lost their magnetism and things like that. I don't think they replaced lost disks.

    Here it is: http://www.wcnews.com/chrisreid/WC3MUSIC.TRE


    I think video card hardware/drivers may be an important part of this. You should include your stats there as well.
     
  6. Tex

    Tex Guest

    ks

    Chris i´m going to try to switch my video card on my older switch i have several that i kept all over the years.

    3DFX Voodoo Banshee
    Matrox G400
    Nvidia GeForce 2 Ti

    Actually voodoo banshee won´t work cause there are no win xp drivers for it i think unfortunately cause this card would be great for playing prophecy.

    I´m not so sure if it is just hardware/driver problems actually i think the main problem is DirectX.

    By the way i made an experience a few days ago installed Virtual PC2007 and i created a win98 SE virtual machine and this virtual machine runs KS great no crashes at all. The only problem is that videos are laggy and jump all the way with video and voice acting out of sync. Needless to say that win98 Second edition comes with Directx 6.1.

    But i got it running stable with no crashes on an even older system i have also kept

    AMD K6 300
    66mhz fsb
    128mb RAM
    3DFX Voodoo Banshee
    integrated sound chip on MB C-Media something sound chip
    WIN98SE
    DirectX6.1

    Ran great 0 crashes. The only thing is that i don´t want to play on this system integrated sound sucks and that old MB doesn´t even support PS/2 or USB mice so have to play with an old ball serial mouse.

    And this isn´t solution cause we all want to play on XP. Too bad i just have KS instead of DOS WC3.

    Maybe with XP without service packs with an older directX version we can get better results and answers also. I only have SP2.

    Hope you reply soon
     
  7. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,447
    Likes Received:
    332
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    There must be Windows drivers for the Banshee. It came out at the end of 1998. Which video card are you experiencing all this with? Have you gone in and tried to disable options like FSAA?

    You might try running the discs off the hard drive for this virtual PC experiment.
     
  8. WCblitz

    WCblitz Captain

    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    11,935
    Gender:
    Male
    Location:
    md
    Been trying to run KS WC3

    I do get into game, I can walk talk to Hobbies, use the lift talk to Maniac, go to B room etc but when I try to start the mission, I get into cockpit then game freezes. Also the whole thing plays in a window it will not switch to full screen. I have combatability mode set to Win 98 for files on cd as well as on the hd, I even went into the Document menu under my name and set the KS files there to Win98. (without doing al the Win98 settings the game would freeze at the starter video).

    My system is p4 2.4 ghz HT ATI 9800 xt 256megs ram on card. 2gigs ddr system ram.
    running XP SP3.
     
  9. ChrisReid

    ChrisReid Super Soaker Collector / Administrator

    Messages:
    13,447
    Likes Received:
    332
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    Does it seem to freeze during the loading or right as the mission starts? You might try a -D or -NO_SOUND command line switch when you start the game to try to get to the root of the problem.
     
  10. The Fur

    The Fur Spaceman

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I have the original WC3 DOS CDs and am trying to get it running on this dell I have a my office. (specs below). I have found that if I clicked the "Y" during the setup to force the alternate movie mode the vidoes locked up and had to hit "Esc" to skip it. I if hit the "Esc" to run them normally they played fine.
    I am having issues with the sound. I can get the music to play with the Waveblaster/Roland selection, but the digital FX is stumping me. Any help would be appreciated.

    Intel Pentium Dual E2160 1.8ghz
    2gb RAM
    SoundMax Integrated Digital HD Audio
    Intel G33/G31 Express integrated Video
    XP Pro SP3
     
  11. AD

    AD Finder of things, Doer of stuff

    Messages:
    4,936
    Likes Received:
    105
    Trophy Points:
    36,885
    Location:
    BC, Canada
    ARe you just trying to run the game straight out in windows? Or are you trying to use dosbox. Don't forget that dosbox defaults sound to IRQ 7 so you need to set up the game accordingly. The problem with running the game in windows itself is that windows doesn't always support some of the legacy hardware that the game wants to find.
     
  12. The Fur

    The Fur Spaceman

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I got the Dos ver. of WC3 to work great on the XP machine listed above with VDMSound. I took the disks home to see what I could do with my Vista Home Premium I have at home. When I tried the VDMSound, I got an error about not being able to use "fullscreen mode". So I decided to head the Dosbox route and got everything configured and installed like a champ...except I am gettting the following error when I start to play the game.

    Open failed on file ..\..\data\sound\gfsample.iff.

    The error goes on to state it might be a bad CD-Rom read. blah, blah, blah. I have seen a couple of post with the same error but not really a fix. Any suggestions?

    Dell DIME521 AMD 64 Dual Core 3600+ (1.9ghz)
    3.25gb RAM
    Windows Vista Home Premium SP1 (32bit)
    650gb hard drive
    NVIDIA GeForce 8800 GT (1gb RAM)
    SigmaTel High Definition Audio CODEC
     
  13. Madman

    Madman Vice Admiral

    Messages:
    976
    Likes Received:
    4
    Trophy Points:
    32,385
    Location:
    Wakefield, West Yorks, England
    Did you mount the CD properly? (obvious question but it makes a huge difference)
     
  14. The Fur

    The Fur Spaceman

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I have a folder I am mounting for saved games c:\WC3
    (mounted as "mount c: c:\WC3")
    Then I am mounting the CD drive (vista doesn't want to let me move the files to my hard disk for some reason)
    (mounted as "mount e: e:\")

    I then change to my e drive and type wc3. It starts loading then the message pops up.
     
  15. AD

    AD Finder of things, Doer of stuff

    Messages:
    4,936
    Likes Received:
    105
    Trophy Points:
    36,885
    Location:
    BC, Canada
    That's the wrong mounting line for a CD-rom. it should read more like: 'mount e: e:\ -t cdrom'

    The second 'e' is whatever letter your CD-rom is in windows and the first can be anything but that is what drive letter you will use to access the cdrom from within dosbox.
     
  16. The Fur

    The Fur Spaceman

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    That worked like a champ! the only minor issue is the sound from the movies (the FX) are just a bit choppy. I am guessing a possible IRQ issue, but haven't had the chance to tweak it. I will update here and let you guys know what the fix is. Maybe after 14yrs I can finish this game I loved!

    PS. Does anyone know why Vista won't copy the Disk to my hard drive? I can do the 48mb install but if I try to copy and paste the files on the CD I get a weird "The files aren't in their location" message. Just curious.
     
  17. The Fur

    The Fur Spaceman

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I went into my conf. file and edited the CPU from auto to 25000 and it is working like a champ. The only thing not working is my TAB button for afterburner....
     
  18. Black Friday

    Black Friday Guest

    Hi, I recently tried this game out again, and I've run into a problem where I crash on transitions between movies, areas, or any action on the ship, seemingly at random. I've tried Mincemeat's patches, but they haven't worked. Is there anything else I can try in order to stop this from happening?
     
  19. AD

    AD Finder of things, Doer of stuff

    Messages:
    4,936
    Likes Received:
    105
    Trophy Points:
    36,885
    Location:
    BC, Canada
    If you don't mind not seeing the transitions, you could try and turn off the transition videos. That might get rid of it a little.

    You could also toy with the hardware acceleration settings in your directx panel. Turning it off or down has varying success for different people.

    Make sure you are turning off any programs running in the background. It might be good to suspend things like antivirus software while running the game.
     
  20. Black Friday

    Black Friday Guest

    Turning off the transitions doesn't help, and I've already tried cutting off programs, but I'll see about the hardware acceleration.
     

Share This Page