WC3 KS Version fix on XP

U

Unregistered

Guest
i have the same problem... my WCKS WC3 freezes when i change rooms due to movie playback... i cant even view the whole scene where angel dies because the game halts after she lies dead on the floor... :( i have to skip the movies just to play the game, but it's the cutscenes i wanna watch, i've beaten the game tons already... i have XP SP2 and i tried the patch already. Any1 know how i can fix the video problem?
 

AD

Finder of things, Doer of stuff
Unregistered said:
i have the same problem... my WCKS WC3 freezes when i change rooms due to movie playback... i cant even view the whole scene where angel dies because the game halts after she lies dead on the floor... :( i have to skip the movies just to play the game, but it's the cutscenes i wanna watch, i've beaten the game tons already... i have XP SP2 and i tried the patch already. Any1 know how i can fix the video problem?

**Do not use the Patch if you are running wc3 Kilrathi saga version**. Uninstall everything as well as any remnants in the registrty just to make sure. Reinstall without the patch. Did you apply the compatability settings? Experiment a little. Set the wc3 EXE to win95 and if that doesnt help set it to win98. Have you tried adjusting your hardware acceleration settings in windows? Does that alleiviate some of the problem. If it won't go away entirely, you can always turn off the transition videos. At least you won't have to skip through them. It could be either your sound drivers or video drivers causing a conflict.
 

lxi

Spaceman
lots of great info in here... my problem is with my LCD... WC1 and WC2 run fine but they are up in the top left corner and a little bit of the screen is cut out...

any suggestions?
 

ChrisReid

Super Soaker Collector / Administrator
It could be possible your LCD screen isn't capable of going into the resolution/refresh mode that the game wants. Can you manually adjust that stuff before the game launches?
 

Kilrathikiller

Rear Admiral
I have tryed everything that is suggested here and i think i did it right but I still have the problem of it crashing on me when i go to start a video sequence and can't even do the first mission. I hope there is a way to get this to work, i don't have much money right now to even pick up the dos version.
 

Kilrathikiller

Rear Admiral
Pentium EE 3.73ghz and the one thing i didn't try that i believe shanky said cuz i don't know how to do it and sorry if it was explained earlier
 
R

Ringil

Guest
Not that it will help anything, but I have the same problems with the KS. I'm running an intel 3.4 on an ABIT motherboard with an ATI video card. I've tried all the compatibility modes/patches to no avail. My problem seems to be when I watch a video sequence all the way through and then try to move to a different area of the ship the game will hang.

A couple of years ago I know there was a post where people were posting their rigs (that were having the same problem on XP) in hopes of finding some kind of solution. I don't know if anything ever came of this or not. Here's to hoping that someone, at some point figures out what the problem is...
In the meantime, Ebay and dosbox sound like the only solution....
 

ChrisReid

Super Soaker Collector / Administrator
Ringil said:
A couple of years ago I know there was a post where people were posting their rigs (that were having the same problem on XP) in hopes of finding some kind of solution. I don't know if anything ever came of this or not.
What you see in this thread is pretty much what people have come up with.

Ringil said:
In the meantime, Ebay and dosbox sound like the only solution....
Kilrathikiller said:
Pentium EE 3.73ghz and the one thing i didn't try that i believe shanky said cuz i don't know how to do it and sorry if it was explained earlier
I don't understand what you're trying to say in this post, but if you have an Extreme 3.73 computer, I would figure you could afford WC3 for $12 or so.

Edit: Could you be talking about the priority thing? Hold control+alt+delete and go into the processes tab. Right click on Kilrathi Saga while it's running and try lowering the priority.
 

Mav23

Swabbie
Banned
I just wanted to post my enthusiasm that thanks to Windows Vista RC1, I have just completed the first mission of WC III. I tried everything I knew about with XP but just couldn't get it to work, or even get in the cockpit. The game is still buggy and crashes during videos occasionally but a quick reload usually gets me through. Finally! :D
 

Kilrathikiller

Rear Admiral
the priority lowering didn't work and i even tryed raising it but still no go. Its not really that I can't afford the dos version and i might even have it laying around somewhere but i can't get it at the moment and would like to see if there was a way still to get this working.

Also I still can't get the joystick for WC4 to work. The readme file is telling me to delete a joy0.dat but i can't find it.
 

Mav23

Swabbie
Banned
Okay I take what I said about "occasionally" having to restart back. I have to restart at least once in between every mission. However I am still excited as at least I am getting through the game as before I couldn't even start it.
 

ChrisReid

Super Soaker Collector / Administrator
the priority lowering didn't work and i even tryed raising it but still no go.
So what were the other things that you did try? Many people who say they've tried "everything" have not.

Also I still can't get the joystick for WC4 to work. The readme file is telling me to delete a joy0.dat but i can't find it.
It's in the WC4 folder on the hard drive if you've configured a joystick. Did you try the WC4 Joystick patch?
 

Kilrathikiller

Rear Admiral
I have tryed the compatablilty tool that mincemeat gave out and the superpatch which included what skank tryed. I have also tryed the Windows 2000 patch. Of coarse have just tryed regular compatability mode in everything available there. There might be one or two more little things i have tried but can't remember off hand.

And yes,I have the WC4 joystick patch.
 

ChrisReid

Super Soaker Collector / Administrator
I would suggest looking at the sound and video card. Go into the control panel and dxdiag program and disable or tweak the sound and video acceleration sliders. If there's anything you can turn off/on like full duplex audio, try that. Disable universal FSAA and let the program choose. Stuff like that.
 

Kilrathikiller

Rear Admiral
With what you last suggested i can do the game like Mav23. I have to restart at least once between each mission. If there is any other ideas i would appreciate it. Otherwise thanks a lot. At least i can get through the game it seems.

I also might post back if i can t get the joystick working on WC4, still got a couple things to try out to get it working.
 

Mav23

Swabbie
Banned
Finally, it is done. I'm proud to say that I got through the game again, and it couldn't feel better after all the time I've had to wait since I got this computer. :)
 
U

Unregistered

Guest
Thanks!

Using the method first posted on this thread I now have KS: WC3 working at %99!!! Great work!

I have always had problems with KS: wc2 and secret ops in xp, but I stumbled upon a solution that works for me.

Just use the standard compatibility options and use windows NT 4.0!

(right-click on exe file -> properties -> compatibility tab -> windows NT 4.0)

I just started trying everything, but for whatever reason this works! No more stuttering sound or video!
 
Top