WC3 Kilrathi Saga WinXP

GrayFox

Spaceman
The Problem is a lot easier. What our french friend found out - but did not realise - that pressing ALT+ENTER sets the game into window mode. Not running a special software in the background does the trick but going into window mode itself does! Wing Commander III is - it seems to be only THAT simple - unable to switch the video modes it needs when running on modern computers, especially when running high resolutions, high screen refreshing rates etc. with state-of-the-art monitors. Remember that back the days in which WC3 was released most players only had a 15inch screen at best. When I try to START the game in full screen it blocks in 95% of all (re)tries. When starting up in window mode it works. Once in the game I can play fullscreen. All I need to do is getting over with the intro scenes in window mode and thats it. After that the game runs fine, except for the very rare crashes (mostly after a video scene ends, or when skipping them by pressing escape) mentioned. So it seems to be a video initialisation problem regarding the startup and the video scenes. This has nothing to do with Intel or AMD or NVidia versus ATI. That's all sheepdip ... Hunter would say ^^

I use an AMD Athlon 64 3000+ Venice CPU on a ASUS A8N-SLI Premium Mainboard.
2048 MB of RAM
NVIDIA GeForce 7900 GT/GTO with 256 MB RAM
OnBoard Yamaha AC97 based 8-Channel Soundsystem (works perfectly)
300 GB Samsung HDD ATA133
LG DVD-RAM Multinorm Disk ReWriter
Samsung DVD-ROM
Sony 1,44 and 2,88 MB 3,5" Floppy Drive

Monitors (in Nvidia Dual View Setup, second monitor extends the desktop):
Primary: Fujitsu Siemens 19" LCD TFT @ 1280x1024 75Hz
Secondary: Belinea 15" CRT @ 1024x768 85Hz

Deactivating the secondary monitor did NOT affect Wing Commander III KS

Furthermore: After playing WC3 KS (REAL Ks, not the patched Dos Version) some time by switching between window mode and fullscreen, I was asked to put in disk number 3 (in KS, WC3 starts with disk 2, then disk 3, 4 and 5). After loading the disk image (I use disk images instead of the real CDs of course) I clicked with my mouse to signalize readiness. The game loaded and crashed then, telling me it was unable to find some kind of ingame video file on that disk. Anyone had similar errors ?
 

SoulSkorpion

Spaceman
Sorry for the bump, I figured it would be better to keep related info in one thread.

I'm trying to get WC3 KS to work on my Win XP machine. The intro cutscene runs fine and, after setting Windows 95 compatability on WC3W.EXE, I can get into the game. However, the game freezes at random points. Initially, it was only happening if I tried to speak to someone if I had already spoken to anyone else since starting up the game. It also happened once simply by trying to click on the computer console to save my game, after having spoken to someone. Finally, just now, it's crashed right smack in the middle of the cutscene that plays while launching to the first mission.

I *have* been able to use the simulator, and it behaves perfectly while inflight.

These are the things I have tried, pretty much in order (so these are cumulative):
  • Setting compatability mode to Windows 95.
  • Using Microsoft Compatibility Administrator 5.0
  • Checking that the processor affinity is restricted to CPU 0
  • Using the above with Mincemeat's "WC games Superpatch v0.1"
  • Checking that the priority is set to "normal" while the game is running.
  • Copying the contents of the CD to the same dir I installed WC3KS.
    • It seems that it IS now loading fromt he hard disk rather than the CD because I'm no longer hearing the CD spin up ang things load faster. This hasn't fixed the problem, however.
  • Trying to alt-enter out of the game when it freezes.
    • It does not even respond to alt-enter at this point
  • NStriker's Windows 2000 patch.
  • Changing the priority to "Below Normal" while the game was running

The frustrating thing is that it works but doesn't STAY working. To play now, I'd have to run the game, watch a custscene, save, try watch another one and have it crash, kill the process, start again, watch another one, etc.

System Specs:
  • OS: Windows XP Professional SP2
  • CPU: Intel Core2 Duo E6400
  • Motherboard: Abit AB9
  • Graphics card: Innovision Inno3D Geforce 7900 GS 256mb
  • RAM: 2 x 1024MB 800Mhz

While we're at it, is there any way to run the Kilrathi Saga in DOS mode? I have a feeling I can actually get it to work using DOSBox, after sucessfully trying to run the DOS demo.
 

Wedge009

Rogue Leader
While we're at it, is there any way to run the Kilrathi Saga in DOS mode? I have a feeling I can actually get it to work using DOSBox, after sucessfully trying to run the DOS demo.
Not that I'm aware of: Kilrathi Saga was designed to run on Windows 95 since the original games were DOS-based.

I haven't played WC3 for a while, but I think last time was on a Windows 98 system. I think I was having trouble getting it to work with WinXP.
 

SoulSkorpion

Spaceman
Process monitor log here. It's 6.23 mb compressed, something like 43 uncompressed. It's a log of everything going on while running WC3KS, not just WC3KS itself, in case something else is screwing it up.

I've been playing around with the compatibility tool some more, and I've found ways to break it even further but nothing to certifiably fix it. That said, I *think* that at the moment clicking on things no longer causes freezes (haven't tested exhaustively) but now it sometimes fails to come back from black after a cutscene. Process Explorer says that most of the game's threads are waiting for user input, though that might be their normal state (I don't know a lot about thread statuses).

I hope someone has some idea of how to fix this. I've been waiting ages to play this game :/.
 

arch 14

Spaceman
I've been working with this for a while...and I can't get very close to getting WCIII from the KS to run.

If I install the Win2000 Patch, Run in Win2000 mode, Lower Priority, and run 640c480 resolution then sometimes I can get it to work for a few minutes. Otherwise it freezes as soon as I try to talk to Hobbes.

Since the last post in this thread was over a year ago, I was wondering if there was any more progress (maybe in a thread I missed).

Thanks.
 

arch 14

Spaceman
Of course, as soon as I post that, I try Win98 compatibility and it seems to work. Bizarre. I'll update if it crashes later in the game.
 

ChrisReid

Super Soaker Collector / Administrator
Glad it works. To answer your question, I don't think there have been massive WCKS compatibility breakthroughs in the last year.
 
Top