WC3 Kilrathi Saga WinXP

THE_WUQKED

Spaceman
@ The_Wuqked Is that you who just won an auction (Kilrathi Saga) on ebay.de for just 59€ ?
Hehe, you got me :)
Yes, ok it's strange that I already had KS before - That was cause I searched for a KS quite some time and was unable to get one, but really wanted to have it, so I downloaded it (illegal, I know :( ) - But then I suddenly saw it at ebay.DE. But there I was bid in the last 3 secs (no joke!), although I would have payed much more. And I was so happy when I saw another auction (the one you mentioned). - Btw, my bid limit was 135€ this time - just to be safer ;)
Ah, already looking forward to finally have the original in my hands :D

@Vanion: Yes, it seems that it only sometimes helps. For me it was @normal by Default, btw. - But didn't help. :(
 

Edfilho

Cry some more!
I just tried Alt+tabbing out of the origin movie and setting the priority to normal and IT WORKED.

I played one simulator mission and talked to the people in the Victory. It freezed when I clicked a second time in Rachel, but othr form that, it works.

For the record, my system:
-athlon 1.3ghz
-256mb ram ddr2100
-WinXP Pro sp1
-Gforce 4 440MX
-SB Live! 5.1
 

THE_WUQKED

Spaceman
played one simulator mission and talked to the people in the Victory. It freezed when I clicked a second time in Rachel, but othr form that, it works.
That is not EXACTLY what I call working ;) - I once managed to play 20mins till it crashed, but that was just random luck. Or did you just mean Alt+Tab itself? Anyway thx for the system input etc :)

EDIT: You might also want to try out the Det 40.72 if your WC3 crashes again.
 

Edfilho

Cry some more!
Well, If one does not re-click a played dialogue, it works fine...
I won't mess with my drivers...
I played the 1st mission, walked around the Vic and talked to everyone without any further trouble... I'll try a longer test later today.
I started the game, and while the movies played, I alt+tabbed, openned Task MAnager and set the priority to normal.
Worked twice so far.

BTW, I'm using WC3KS with no extra patches and no compatibility settings on
 

THE_WUQKED

Spaceman
Well, If one does not re-click a played dialogue, it works fine...
I won't mess with my drivers...
I played the 1st mission, walked around the Vic and talked to everyone without any further trouble... I'll try a longer test later today.
I started the game, and while the movies played, I alt+tabbed, openned Task MAnager and set the priority to normal.
Worked twice so far.
Hmm, that's strange, whether I reclick a played dialog or not doesn't make my PC crash. For me it mainly crashes at new scenes.
And I just suggested the drivers cause you are using a Gf4MX anyway, with which they should work. BUT if you are also playing DirectX 9 games, I wouldn't do it either, if I were you - Just remembered that those drivers are DX 8.1 only.
And good luck, hopefully yours works this way ;)
 

Edfilho

Cry some more!
Hey, been playing for a few hours (with some pauses) and it worked well. I just had a freeze after talking to flint in Locanda, but that's no big deal, 'cause I can just load a game.

As far as I'm concerned, the game is quite playable. this ocasional freeze is not that bad. And it never happens during missions, which is very important.

thanx all!
 

THE_WUQKED

Spaceman
Glad to hear that it works for you :) - One less WC Fan having trouble to play it, so we are getting closer to finally solve it totally, I'd say ;)
 
U

Unregistered

Guest
Final good news report

Well for the nvidia chipset users the 40.72 drivers are the way to go. I just finished the entire game without a lockup. I had a total of 3 errors causing a CTD but restoring from the last save position allowed it to continue just fine. Movies, sounds, flight dynamics, interactions, everything ran flawlessly.

For those playing additional games as well, keep a copy of 40.72 on your drive and install when you plan to play. When you want do something else for a while use the driver rollback and the newer version is back in place and ready to go.
 
U

Unregistered

Guest
no one's found any ati catalyst drivers that work, have they?
 

THE_WUQKED

Spaceman
no one's found any ati catalyst drivers that work, have they?
At least not for ATi 9800 cards, but for my M8's R9700Pro the Cat3.6 worked fine. - Haven't tried them out with my Shuttle XPC yet, only with my 98000Pro rig, for which they did not help :(
 
U

Unregistered

Guest
Now played 5 or 6 mission. No complains. Used my DOS Version with the Kilrathi Saga files from the net.
 

THE_WUQKED

Spaceman
It's not "the only way" - it's just luck of the draw. But it's maybe the easiest way - if youa re not unlucky and get problesm to get sound working etc. with older pcs. And keep in mind: even a 450Mhz suffers the crashing :(
Btw, I got my KS version yesterday - and although it was shown without the box at ebay, it came with the box. - everything in perfect conditions :D Man, I'm so happy. Especially cause I "only" payed 59€ for it, while most others go away for over 100€/$ ;) And I thank teh guy who beated me in the first bid (105€) :D
 
U

Unregistered

Guest
Sorry to bump an older thread, but I found a copy of Kilrathi Saga at a local yard sale (saw it for five dollars, and bought it immediately) and WC3 works sporadically. I'm running XP, and after installing the 2k patch, the game will run in Win2k compatibility mode. Not all the time, but it will run. However, it will still freeze sometime while playing.

Here are my relevant specs, for reference

Windows XP Home SP1
Athlon XP 2000+ 1.667 GHz
GeForce 4 Ti4800 SE
768 MB DDR RAM
SoundBlaster Live! 5.1
 

THE_WUQKED

Spaceman
No, it's a good idea to bump this Thread. This way everything is at one place ;)
Hmm, I already tried the Win2k patch, but not with win2k comp mode. Will try that next week myself ;)
 
U

Unregistered

Guest
Just a small addendum to my post, the game runs fine in-flight. The lockups occur only when a movie is supposed to play, and never when the opening cutscene appears. Also, a lockup may occur after this cutscene, when you should appear on the hangar deck.

This is my first time playing WC3 in any format, so I hope I can get this to work properly. I'm still messing with the compatibility settings, but the game only runs on Win2k mode. The other checkbox options don't seem to affect anything.
 
U

Unregistered

Guest
I have a pentium 4...... 2.6 ghz....Geforce5 i gig of ram
but i have one thing you guys havent mentioned yet.....DUEL BOOT !!!

In Win98 its perfect......In XP i get lock up......My point is i dont think the hardware has much to do with it......I think its all down to XP :(
 

THE_WUQKED

Spaceman
Well, it's truely not the hardware itself, but the drivers, cause I know plenty of WinXP systems that can run the game perfectly. So it has indirectly to do with Windows XP and indirectly with the hardware ;) :(
 
U

Unregistered

Guest
I've gotten WC3 to work perfectly now! Little did I know, but there is an option to run the game in a windowed mode, instead of fullscreen. Simply hit ALT and ENTER. Now, after I did this, I CTRL-ALT-DEL'd to look at the processes running. WC3W seems to run in high priority mode. I switched that to Normal, and everything runs fine.

To recap, here's what I have:

WinXP SP1
DirectX 9.0b
Athlon XP 2000+ (clocked at 1.667 GHz)
GeForce 4 Ti4800 SE (61.40 drivers)
Some shitty VIA mobo
SoundBlaster Live! 5.1 (running Audigy 2 drivers)

Windows 2000 patch applied
WC3W.exe set to Win2k compatibility mode
ALT-ENTER to windowed mode
Set priority for WC3W.exe to Normal

Now, off to fry some more cats.
 
U

Unregistered

Guest
Hi, this may seem like a stupid question but how do you set a program from high priority to normal priority?

I'm using Windows XP Professional w/ SP1. Thanks.
 
Top