WC3 in Windows 98


Vice Admiral
howdy, I got a problem with WC3. the movies play really fast and then freeze and I cant communicate with anyone during spaceflight. Ive tried the patch for WC3 but it does not work. can anyone help? btw Im running win98SE, with 128mb RAM. thx for any help.
If you are running Win98, why not just boot to DOS and run it from there. WC3 was built for DOS so that is the best environment to run it in.
well, i tried it but it didnt work. my wc3 is on cd and dos cant access the cd but Ive heard theres a way to let dos access the cd drive. if it matters, my cd drive is a LG CD-ROM CRD-8522B and its D:\ drive on my comp. Ive tried to copy the files to the harddrive but my comp is really screwed up and it wont let me.
You need to have your CD-ROM initialized through config.sys or autoexec/dosstart.bat before you can use CD in DOS. Does it look like it's initialized?
As for being unable to copy the files, I can't think of a reason why it would NOT work. Chances are your CDs are... in less-than-stellar condition.
Try bringing down the sound-hardware acceleration a notch or two (or three), like the fix for WCP.
It would be a lot easier if you posted more info on you machine and better description of the errors... We may be good, but we're not telepathic.
well, Im having two problems with wc3. first one is that the movies play for a second really really fast then freeze and the second problem is that i cant communicate with anyone in spaceflight so I cant request landing clearance so yeah. i think i might have a fix for it. I copied all the cds to my harddrive and i will try running it in pure dos.


ok, so running it in pure dos didnt work. it said i didnt have 8 megs of RAM (I have 128 megs) so Im guessing that the RAM needs to be used by dos or something. can this be done?
alright, I guess I will never play WC3 again since no one will help me with these problems. so, anyone want a copy of WC3? its pretty much brand new, just got it last week off of ebay.
I wish I could help you, but my knowledge is primarily limited to getting Privateer running, since I never had much of a problem out of WC3.
Cut the crap, please. We are always happy to help, we try our best, we have people here who even modify or create patches so that the games work in the most systems possible. But we're not OSI employees, we're not payed to do this and we can't just stop everything we're doing just to attend to your wishes.

But i see that we asked you about your config and what EXACTLY happened with your game, but you failed to supply the info. We can't help you if you don't help us.

What do you mean by you cannot comunicate? what do you do and what happens? what's your config.sys? what's your autoexec.bat?

You either help us or quit playing the victim.
For instance, maybe the problem with the comms is that the game can't play the movies, so perhaps you can get them to work by turning the comm movies off. there's a keyboard shortcut for that.

But I can't say if that's the right solution because you can't explain to us what happens to the comms.
what happens when i try communicating is nothing. sometimes it works and the movies play but usually nothing happens. the movies play super fat for a second then freeze totally. I dunno where the config files are, if i did, I wouldve put it up here, but since I dunno, I cant post it.
and I got WC4 installed on the same comp but the movies play fine in wc4. are the movies encoded with different codecs or something? would downloading the latest direct x help?
dont mean to triple post but I cant edit my last post. I figured it out. the problem was the sound. I disabled it at the install window and now teh movies work and the comms work and the whole game works again. but now i dont have any sound. can I get some help with that then?
Have you tried out idfferent soundcard settings yet? I mean sound blaster instead of Sound Blaster Pro or Sound Blaster 16 or the other way arround, or something else? When using VDMS I had similar crashes with SOME sound-settings, but not all. (Didn't post that yet, cause vdms only emulates that + it's under XP and it's quite buggy for wc3 anyway)
Ive tried every option on the list that comes up for the sound. none of them have worked. Im just running it in win 98, without any emulators, and Ive tried using vdms before but that never worked for me.
Im just running it in win 98, without any emulators, and Ive tried using vdms before but that never worked for me.
No wonder VDMS didn't work, it's for Win NT systems only. I'd say the best thing you could do is create a DOS boot disk. There are plenty of threads about how to create one, just check out the stickies. ;) If you are getting into any problems or have got further more question just ask. - Oh, and post your config.sys and autoexec.bat, like someone else already suggested. Maybe someone knows which settings are wrong for wc3 ;)
Wrong - you can also use VDMSound on 9x systems. But support is worse then for NT. Never tried it however as my Awe32 works without any hacks.
Really? Wow, didn't think so, cause Win9x can use real Dos Soundcard drivers. - I guess it's just similar to DOSBox: It runs under 9x as well, but nearly no-one uses it, cause you've got real DOS, too. And so it's said to not run under 9x (at least I've read that several times. But then I tried it out myself, and it works)
So thx for correcting me ;)
howdy, well I got it to work. the problem with my comp was the cd drive, it wouldnt read cds so I changed the cd drive and tried wc3 again and it works fine now.