WC3 GOG Sound Stutters In FMV and Gameplay

Getius

Veteran Spaceman
Hey I'm getting stuttering in the audio for both gameplay and fmv in WC3 GOG version. It was working until just the other day. I tried looking on the GOG forums and found nothing that would help.
 

AD

Finder of things, Doer of stuff
If you have extra programs running at the same time it could just be getting bogged down. Otherwise, both setting cycles too low and too high can make the sound and video stutter. Usually it will be the cycles are set too low in DOSBox though. I don't remember what the GOG version is set too (possibly automatic...) but it's probably a good idea to just set a fixed cycle rate for the game - 35,000 cycles for Wing Commander 3 with normal core and 50,000 cycles for dynamic core though you can go higher on most modern CPUs without issue.
 

Getius

Veteran Spaceman
If you have extra programs running at the same time it could just be getting bogged down. Otherwise, both setting cycles too low and too high can make the sound and video stutter. Usually it will be the cycles are set too low in DOSBox though. I don't remember what the GOG version is set too (possibly automatic...) but it's probably a good idea to just set a fixed cycle rate for the game - 35,000 cycles for Wing Commander 3 with normal core and 50,000 cycles for dynamic core though you can go higher on most modern CPUs without issue.
Before I read your reply I set the cycles to Fixed 70000 and the game play sounds normal. I'll try what you suggested. Mind you the FMVs still stutter but the sound during the gameplay is solid.
 
Last edited:

Getius

Veteran Spaceman
If you have extra programs running at the same time it could just be getting bogged down. Otherwise, both setting cycles too low and too high can make the sound and video stutter. Usually it will be the cycles are set too low in DOSBox though. I don't remember what the GOG version is set too (possibly automatic...) but it's probably a good idea to just set a fixed cycle rate for the game - 35,000 cycles for Wing Commander 3 with normal core and 50,000 cycles for dynamic core though you can go higher on most modern CPUs without issue.
I tried what you suggested and no luck it still stutters and skips.
 

AD

Finder of things, Doer of stuff
I tried what you suggested and no luck it still stutters and skips.
I think you said you had a newer system you were running the game off of. I don't know why it might make a difference but can you list your system specs and tell us a bit about how you're running it? Is it off of an SSD? You said it was working the other day. Were there any changes to your system between now and the other day such as any driver updates or other hardware changes? If so, could you try rolling back your drivers and see if that changes anything?
 

Maze59077

Petty Officer
[cpu]
core=auto
cputype=auto
cycles=fixed 60000 (or 70000)

[mixer]
rate=44100
blocksize=1024
prebuffer=10000

thats my perfect setting ..and works absolutly fine without stuttering
for WC3 and WC4
 
Last edited:
Top