WC3 and AGP?

junior

Spaceman
I tried installing WC3 last night for the first time in a long time. Joystick calibration routine ran okay, got the message saying it was about to test video, processor, and CD speed, and then the program froze.
Tried it on a second computer, and the same thing happened.
Tried it on a third computer, and everything ran as it was supposed to. Installation finished properly, and the game started up smoothly.
Both computers that the game froze on have a Voodoo 3 AGP video card installed. iirc, the computer that the game ran properly on has a PCI video card. Presumably, the problem is from the video card. Is there a known work around for this, or am I stuck with the PCI video card if I want to run the game?
 

junior

Spaceman
Couple of quick clarifications.

The original machine is as follows:

Pentium II 350
Win 98se
Voodoo 3 AGP
SB Live Value

The other machine that froze up is almost entirely different. The only similarities between the two machines were the OS and the video card.

The third machine is also a Win98se machine, so the problem seems to be focused on the video card (which is different in the third machine).
And, of course, the fact that the set up program hung when it was supposed to start the video test sequence is also a hint that the video card is the root of the trouble.
 

Saturnyne

Vice Admiral
Hm... well, the sound card MIGHT also be to blame... in the machine it worked in, is the sound card different?

Video cards should presumably work, since all I think you really need are drivers that support VGA or SVGA resolutions in DOS. From what I've seen, the SB Live tends to be pissy with WC, or at least with Prophecy. I don't know about the others.

Also, if anything, make sure your glide drivers are updated.
 

junior

Spaceman
All three machines have different sound cards, and the first machine is the only one with a Creative Labs sound card.
So I'm fairly certain its not a Creative Labs issue.
Glide - I don't know when the last time I updated the drivers was, but I have done it a few times in the past. WC3 is old enough that I don't know if this would make that much of a difference, though.
 

junior

Spaceman
Heh. Found a possible solution while looking for information on a video related problem for Steel Panthers.
Apparently Steel Panthers, which gets screwed up when you attempt to run it with a Voodoo 3, needs to have a shortcut set-up specifying that it needs to be run in full-screen mode. After I get home tonight and find out if this is the solution for Steel Panthers, on my machine, I intend to try the same thing for Wing Commander 3. WC3 attempted to run the set-up program in a window, so its entirely possible that specifying full-screen will take care of the problem. I certainly hope so. The stupid thing will only close through the task manager when it crashes, and requires you to shut down two applications (Oldwinpro and Gateway). And then, for some odd reason, after the applications are closed, Windows won't shut down properly.
At any rate, if anyone knows of another idea that I should try, please let me know. If not, I'll post a note about whether the full-screen mode trick worked.
 
Top