WC Saga Mission Editor

maniacmagic

Spaceman
Hi,

One of the polls in www.wcsaga.com tells us that there is a wcsaga mission editor. I just wanted to check and see what I can do with the editor (cause I have a few ideas which I think would be interesting to add in single missions).

So I downloaded the editor guide and the editor (If I’m not wrong they were Fred.rar and freddocs.rar) files. But when I unzipped and try to open editor a massage told me that Freespace 2 is required to run Fred.

Unfortunatelly I don’t own a copy of Freespace 2 .

Is there way to launch editor without installing freespace 2 (just like playing WC saga standalone)?
 

maniacmagic

Spaceman
Thanks

Thanks mancubus.

I tried it and it worked. By the way do you know which program can extract the movies in WC IV the one with .TRE extensions.
 

Winnyfred

Rear Admiral
Uhhh, how do you set this up? I have a bunch of options and I am kind of lost... Things like features, Audio, Joystick, etc.
 

Tolwyn

Vice Admiral
ehh... what? The game? It is already preconfigured. If you have a joystick or gamepad you have to select it in the launcher.
 

Winnyfred

Rear Admiral
I am having the same problem that maniacmagic had. So I'm getting FreeSpace Open 3.6.9 I believe that is what I need correct?
 

Mancubus

Rear Admiral
it is someware in older news on the wcsaga frontpage. the link is old - it was once posted on HLP by Tolwyn but it seems it doesen't to work now, sorry :(
 

Winnyfred

Rear Admiral
I can't get it working here is what it says:

Error:
Web cursor bitmap not found. This is most likely due to one of three reasons:
1) You're running FreeSpace Open from somewhere other than your FreeSpace 2 folder;
2) You've somehow corrupted your FreeSpace 2 installation;
3) You haven't installed FreeSpace 2 at all.
Number 1 can be fixed by simply moving the FreeSpace Open executable file to the FreeSpace 2 folder. Numbers 2 and 3 can be fixed by installing or reinstalling FreeSpace 2. If neither of these solutions fixes your problem, you've found a bug and should report it.
File:J:\src\cvs\fs2_open_3_6_9.final\code\Graphics\2d.cpp
Line: 1526
[This filename points to the location of a file on the computer that built this executable]

Call stack:
------------------------------------------------------------------
fred2_open_3_6_9.exe 0064f296()
fred2_open_3_6_9.exe 0064f4b2()
USER32.dll 7e418734()
USER32.dll 7e41d05b()
USER32.dll 7e41b4c0()
USER32.dll 7e41f9fe()
ntdll.dll 7c90eae3()
USER32.dll 7e41fecc()
USER32.dll 7e41ff66()
fred2_open_3_6_9.exe 0064f9d2()
fred2_open_3_6_9.exe 0064fa5a()
fred2_open_3_6_9.exe 006649ba()
fred2_open_3_6_9.exe 00664a07()
fred2_open_3_6_9.exe 006502d8()
fred2_open_3_6_9.exe 0064f296()
------------------------------------------------------------------

Use ok to break into Debugger, Cancle exits.

I go into debugger and it says Fred2_open 3.6.9 has encountered a problem and needs to close.


How do I fix this????
 
Top