WC 3 sound canvas problems

Wynout

Spaceman
Hello everyone,
I'm running WC 3 (original, not the KS-version) on a Pentium II, 233 mhz (asus p3b-f mobo), SB AWE Gold and a Geforce 2 MX. My Sound Canvas mk II is connected to the Midi out-port of the AWE (at address 330) . The game itself runs fine via pure DOS (6.22 and 7) and Win95-dos-environment. After flying a mission for a while, the midi music starts to act wierd: strings suddenly sound like pan flutes etc. This is most notable after winning a mission and returning to the Victory. Or when I enter the berths, sometimes an instrument is played on midichannel 11. The display of my SC doesn't give my any indication what's happening in those situations.
When I play the game in DosBox, the music behaves normally., but DosBox has other problems in displaying the FMV's of course (graphic glitches) so I'd like to play the pure dos version. I tried softmpu, another Sound Canvast 55 (mark 1, version 2), lowering the speed by disabling the internal cache and a MPU-IPC-T.
Does anyone recognize this problem?
 
Nope, only WC3. It works flawless on DosBox, but on real hardware (either with the midi-out of the AWE64 or my ISA MPU), there's always something wrong. I noticed that after the mission-victory music loops after the first time, the instruments sound right. I bought a pentium 200 mmx. Curious to find out if it's something P2-architecture related.
 
Hmmn WC3 runs fine on my P2-400 and SC-55 (a later-release Mk1) under DOS 7 with an ESS sound card, so I don't think that's it. I don't believe WC3 expects MPU intelligent mode (maybe for MT-32?), so I doubt it's an IRQ issue... Very strange!
 
Yes, that's almost the same setup. I wonder why DosBox doesn't have problems and pure dos does, either using intelligent mode of my MPU-IPC or the uart mode of my soundblaster AWE and my SB16. One thing I noticed is that the music from "Berths" always sounds good on the MPU-IPC, and about 50% of the time sounds wrong with the UART-mode of the Sound Blasters. I tried 3 different Pentium II CPU's, all varying from 350 mhz to 450 mhz and 3 different mobo's, all with the BX-chipset. Well, the Pentium I bought will arrive shortly. I'll see how that goes..
What midi-cable (brand) do you use?
 
I have a few different gameport to MIDI cables; I think the best one is an old Roland one, the others aren't labelled, but work fine. They all appear to be properly opto-isolated but I haven't opened them up to make sure... At the very least I expect the Roland one would be. I was going to mention cables, as I've definitely had a bad one (flaky wire). But since only WC3 has issues...

Is your ISA bus clock adjustable? There may be other ISA bus settings worth a look too but I don't know what options are available.
 
I have two cables for gameport to midi in/out. Both have the problem. And the strangest thing is that everything is as it should be when using dosbox 0.74-3 or windows xp (midi only, no VDMsound since that doesn't work well with WC3). ISA bus-settings are limited to choosing the busclock for 16 and 8-bit. I changed that as suggested by people on VOGONS, but still no luck. Sometimes the test music from the install menu sounds weird too, but after I reset the SC, it's fine. The Hanger music is sometimes using the wrong instruments (sound like long stretched strings). I've used the SC mark I, SC mark II, MU128 and MU2000, and all have this problem.
 
Well, the Pentium 166mmx I orderded had the same problem. Every soundblaster/MPU card I put in it, gives problems. I ordered an ESS1868f now and a new gameport -> midi cable. My cables are unlabelled too by the way.
When I play the wc3 midi-files via GSPLAY, everything sounds fine, but the game itself seems to make problems. The Tubular Bells that should play in the Berths are replaced by Violins and the French Horns playing during the mission victory are replaced by Violins too. Very strange this one. Wonder if this is a software or a hardware problem?
 
Are your cables with electronics on it or just plain cables? The game port to MIDI cables I see often have buffers and optoisolators (as required by the MIDI spec) in order to work properly. Many cheap USB-MIDI adapters have similar problems because they cheap out on those components and it often results in MIDI-IN not working.

Here's the schematic of how it's supposed to be done (Sound Blaster and such use it on their official cables)

The buffer on the MIDI OUT line may be missing. Maybe instead of trying to use a generic Chinese crap adapter cable, seek out an official Creative MIDI cable. It's not going to be $10 (I paid around $70 or so in the end) and not had a problem with it. Given it works in DOSBox and such, I would discount the problem being software. I would discount the Sound Blaster and the MIDI romplers to have issues as well. That really leaves the cable, and it can generally be the source of all the problems.

(Cheap USB-MIDI adapters often skip the optoisolator on the MIDI IN, which causes numerous issues including missed messages and such that are resolved by installing the missing part used to save a few cents. I would not doubt that the MIDI OUT may require a buffer to properly drive the MIDI IN of the device).
 
Thank you for your answer.
My 2 gameport to din cables that came with my soundcards don't have aname on it (type or brand). Coming out of the main plug that you put in the mpu-port are a short wire for the joystick connector and to wires for midi in and midi out. Any way to find an official Creactive cable? Searching the internet, I can only find the usb to midi versions. Does anyone have a link maybe? Should I buy this one? https://maximumacoustics.eu/midi-cable-maximum-acoustics-mc-2-game-port

That still leaves me with the following questions:
1. Why does the game play certain midi's (berths, approaching enemy, mission victory) wrong and the others right and why does the windows media player and GSPLAY play all seperate midi files correct?
2. Why does my mpu-ipc-t/breakout box/din to din cable setup have the exact same problem? This setup doesn't use an mpu-cable.
3. What does DosBox/VDM-sound do differently from real hardware in terms of speaking to the General Midi device.
4. Are there different versions of WC3 around. I have the EN/FR/GE-version.

Thanks for you time everybody. If the new cable and ESS don't solve the problem, I'll leave it at that and play the KS version instead.
 
All I can suggest cable-wise is that the proper ones will usually be quite chunky, like so:
mvkzfxjk6mfyt0proyjj.webp


Because they need to fit (usually two) chips inside the DB-15 connector to be properly MIDI-compliant. Unfortunately there's no way to tell if they're actually set up properly without buying a known-good (non-faked) brand, taking them apart or making one yourself...

Are you running an expanded memory driver (e.g. EMM386)? Because WC3 doesn't need one and it might possibly interfere depending on settings, which driver etc. If you haven't already I'd strip back your boot to bare minimums... You've probably tried that though.
 
Last edited:
Well mine look exactly the same, although the metal parts on yours shine a bit more :). And the ones I see in webshops look the same too. Too bad they're not branded or have number so you can tell which brand it is. Can't take them apart too without completely destroying them.

No, in Win95, no EMM386 is loaded if I recall. In dos, I only load himem, and the cd-rom driver and mouse. Blastersettings are done via SET Blaster=etc etc and then running diagnose.exe. The Roland UM-One MK2 I own seems to fare a little better, but it only works in XP (so no digital sound).
 
Thank you. If the new cable and sound card don't work out, I'll look for one of those on ebay. And may I ask what system you run WC3 dos on? I run a Pentium MMX, clocked at 166 mhz, S3 video card, 64 mb of EDO ram and of course a couple of different sound cards and operating systems.
 
I didn't try WC3, but I have had it on a Pentium 266 MMX laptop with a NeoMagic graphics and a Crystal sound chip. It has a docking station that exposes a standard game port with MIDI.

I'm going by the fact that if WC3 had a MIDI problem, we'd probably all know about it and there would be workarounds in DOSBox and such to get it working, but as you've said, it works fine.

For me, I simply opted to buy the official cable because I was wary of cheap MIDI adapters and cables. In that schematic I posted, there was an optoisolator on MIDI IN, and many cheap adapters omit it to save a buck in manufacturing costs. But the issue became that you will get dropped notes and other things because of the missing part (the use of the optoisolator on MIDI IN is a requirement in the MIDI spec). So instead of worrying about those issues, I bought official MIDI adapters and cables that are guaranteed to be properly made. It would not surprise me if China made cables that bypassed the buffers and optoisolators to save a few bucks - they "work", just you'll probably miss like 10% of the notes, but hey, they can sell you a cable cheap.

So even though I could've bought a cheap cable, at the time I decided since the official cables were constantly showing up in my eBay listings to just pay the price and buy it.

No issues using it between my MT-32, SC-55, SC-88 Pro, MU2000EX, or my Integra 7.

What you're seeing is definitely unusual, and likely something that no one else experienced even back in the day. But then again, back in the day there weren't people trying to cash in on the retro-craze and sell newly manufactured cables for an IO port that disappeared decades earlier.
 
" But the issue became that you will get dropped notes and other things because of the missing part" ---> This!! But only in pure dos/Win95 dos environment. Never in DosBox.
But the strangest thing is that while I have my cables and my mt32/CM-32/SC55 etc. for almost two decades (since 2005), I never experienced this problem because I use Dosbox 99% of the time. I never knew the importance of the official cables.
And like you said: I couldn't imagine that nobody ever has encountered this problem. So it couldn't be a bug or something else on the programming side.
I had ruled out the cables in the beginning, because in DosBox WC3 sounded fine. And I couldn't imagine that both my MPU cable and both my DIN -> DIN cables (that must be used with the breakout box of the MPU-IPC-T) were faulty. My ESS will arrive shortly, so changes are high that the problem still occurs. Attached by the way is a photo of one of my cables. The adapter plug seems a tiny bit thinner than the official ones I see on Ebay.
 

Attachments

  • cables.jpg
    cables.jpg
    1.8 MB · Views: 5
Back
Top