Video problems.

Knight80

Spaceman
I have to use two different graphics to to watch the cutscenes (OpenGL) and another (Direct3d8) to play the missisions.

in OpenGL the chuncks of the models are missing and crashes.

In Direct3d8 the cutscenes are distorted and a color negative of what it's surposed to be.
 

Death

gh0d (Administrator)
I'm not familiar with FS2 code (or the SCP implementation thereof), but knowing a little more about your system would probably be a good start. In particular, what OS, drivers, and hardware you're using would be helpful.
 

Tolwyn

Vice Admiral
I'm not familiar with FS2 code (or the SCP implementation thereof), but knowing a little more about your system would probably be a good start. In particular, what OS, drivers, and hardware you're using would be helpful.

that's right.

Usually upgrading your GPU drivers helps :)
 

ChrisReid

Super Soaker Collector / Administrator
In some cases, if the drivers are similar enough (upgrading within the same manufacturer), the same problem could persist. I'd suggest trying to attack the problem as it exists. Is there any reason why you're using DirectX 8? Make sure you have secondary effects like antialiasing and anisotropic filtering disabled.
 

gevatter Lars

Vice Admiral
AA settings via the graphiccard tools can cause problems but I haven't encountered them for a long time now. So using AA and filtering shouldn't be a problem. Still disableing them could help.
 

darkloard3k

Spaceman
Sorry for digging up this thread but let me explan here. The SCP for freespace 2 has very little (if not none) direct X support. If you do use direct X there is a nodicible decrease in graphics quality so it is OpenGL or deal with it.

And cutscenes can work with direct X (although off center of the screen) but in the saga mod they just don't.
 

RGHawk2000

Spaceman
Cutscene blinking...

The video looks fine but the background blinks as soon the cutscenes starts. Any idea how to fix that. The game itself works fine. Also, Is there an Saiteck X45 support? the throtle and some buttons dont work. Anyway Could I assign their functions manually?

Thanks in advance...

RG.
 

Tolwyn

Vice Admiral
the video flickering problems are very rare. You could try updating your drivers and see if it helps.

As to throttle: you can assign absolute throttle axis in the options/controls/ship option screen (double click and then move your throttle control). Same goes for other keys.
 

GenVagabond

Spaceman
Have same problem with cutscenes, couldn't get to gameplay under DX8 cause of "front-end" graphic bleeding, also during cutscenes i have the same negative-positive color swap and off-center movie. The video error looks a "little" like a monitor refresh bug. My LCD only works on 60 Hz so that could do it if the video was setting the refresh rate too high. OpenGL cutscenes work but gameplay is a little iffy. Sometimes I get the "front-end bleed" but it's random. Go Fig. I have gotten a Kernel error but can't replicate as of this post as I need to do a fresh re-install to see if I can correct anything.

Here's my Rig:

Self built Win XP SP2 PC
AMD Athlon XP 2600+ 2.09 Ghz edition
Nforce2 Asus A7N8X Motherboard
2x512 GB DDR2 3200's
GeForce 6600 OC (most recent driver build)
SBAudigy! SE (most recent driver build)
DirectX 9.0c (October 2006 build)

Anything else, let me know. I'll keep ya posted.
 

gevatter Lars

Vice Admiral
DirectX isn't supported anymore since their aren't any coders working on it anymore so OpenGL is what you should choose.
Beside that what do you mean with the gameplay is iffy? Do you have slowdowns or graphical glitches?
For the fonts their is an option in the luncher that should fix font problems with some cards.
Also do you have AA enabled via your hardware, Nvidia has an option to do so outside the program and by that forceing them to run. That gave me some trouble with it but appreaded again since the latest build with the Prologue came. Still you could try out to dissable the forced AA mode.
Its just an idea. From you config, except using DX mode it seams to be ok.
 
Top