Prophecy Movie Upgrade Patch Released (October 24, 2006)

Damec

Spaceman
ok if these is a problem. I ll dld other two packs. I was understanding that i need to dld just pack 3. So I ll try to dld other two packs and try again
Thx
 

HCl

WC EXE archaeologist
I just uploaded a new DLL, it should fix the issues reported by Sordid and Walter. If you're having problems, give it a try and let me know if it helps!

Link.
 

Beckmen

Captain
So is Maniac going to somehow use this footage for his Prophecy DVD movie? That would be sweet...

(well, I PM'ed asking him directly, but can't seem to find out how to delete this message. Sorry)
 

Mincemeat

Doomsday's Neighbour
I don't know if it's just my particular setup, but the winning endgame movie (after the wormhole has been demolished) gets skipped and I go straight to the animated credits.

Other movies seem to play just fine in-game.

Edit: After installing the 27 Oct build, it seemed to work fine now. Or maybe because my hands were off the keyboard and joystick when the cutscene cut in.
 

Sordid

Rear Admiral
HCI, you are a true genius!!!!!

the new dll fixed my problem! Just fantastic! Thanks!

Btw.: Wat was the error you fixed?
 

maniac89

I love Wing Commander: Prophecy
YES!!!! Thank you, HCl, I don't know how, but the new DLL you posted did the trick! No error messages! Thanks again!!!!!!!!!!!!!!!!
 

Wingolof

Spaceman
The patch works ok. Buti have a problem(besides glitches), the movies are not fully resized. I mean there is narrow black line on top and bottom. So movies are not in 16:9 ratio. They are 16:8,8 or simething. I know its not a big problem but anyway to fix this?
 

Sordid

Rear Admiral
Wingolof said:
The patch works ok. Buti have a problem(besides glitches), the movies are not fully resized. I mean there is narrow black line on top and bottom. So movies are not in 16:9 ratio. They are 16:8,8 or simething. I know its not a big problem but anyway to fix this?


Yeah...I realised it, too. The ratio is different than the one I get with WinDVD


and...the Dolby movie at the beginning doesn't run smoothly...no big deal though
 

ChrisReid

Super Soaker Collector / Administrator
Wingolof said:
The patch works ok. Buti have a problem(besides glitches), the movies are not fully resized. I mean there is narrow black line on top and bottom. So movies are not in 16:9 ratio. They are 16:8,8 or simething. I know its not a big problem but anyway to fix this?

Are you sure there's a problem? The movies seem to be encoded in 4:3 with black bars on top and bottom. Even if that is getting all cropped off (leaving the 16:9 area where the image is), are you sure your monitor is that aspect ratio? Most widescreen LCDs for computers are actually 16:10. What resolution are you running in?
 

Wingolof

Spaceman
Yeah, the movies are encoded in 4:3 aspect ratio (16:9 is the image).
So when i play the game, video is not resized to 4:3. My desktop resolution is 1280x1024, which is not 4:3. I thought this was the cause so i changed it to 1024x768 and then run the game. Video was resized more, but still not to 4:3.

When i play prophecy movies in powerdvd for example, they are properly resized.
 

AD

Finder of things, Doer of stuff
Wingolof said:
Yeah, the movies are encoded in 4:3 aspect ratio (16:9 is the image).
So when i play the game, video is not resized to 4:3. My desktop resolution is 1280x1024, which is not 4:3. I thought this was the cause so i changed it to 1024x768 and then run the game. Video was resized more, but still not to 4:3.

When i play prophecy movies in powerdvd for example, they are properly resized.

They're not exactly 640x480 either though. They, along with the wc4 DVD are encoded at the DVD resolution of 704 x 480 which is about 4.4:3
 

HCl

WC EXE archaeologist
Glad to know the last build helped with some problems reported here:)

Mincemeat: i did not touch the keyboard code, so i am assuming you accidentally hit some key at the time. However, i will be changing the patch behavior to skip the movies only when ESC is pressed, to avoid this situation.

Regarding movie aspect ratio: I think the issue here is, as Chris said, that the movie aspect ratio doesn't exactly match your monitor aspect ratio. Even if you have a widescreen display, small portions on top / bottom of the display remain black because of this. This happens on my laptop as well, at resolution 1280x768.
 

Dominator

Rear Admiral
I've had a problem with hi-res video but fortunately I've solved it. I post solution here in case other people have (or will have) the same problem.
I've installed wcp, enhancement pack and vob patch, then started the game - but instead of dvd video there was a blank screen (there was sound). When I've Alt-Tabbed from game I've noticed that video is played in ActiveMovie window. After some googling I've found a solution - you have to disable "Use Overlay Mixer" option in your MPEG video decoder.
 

Sordid

Rear Admiral
Regarding movie aspect ratio: I think the issue here is, as Chris said, that the movie aspect ratio doesn't exactly match your monitor aspect ratio. Even if you have a widescreen display, small portions on top / bottom of the display remain black because of this. This happens on my laptop as well, at resolution 1280x768.


I know...on 1280x1024 you actually have an aspect ratio of 5:4. But you get those black lines at the top and the bottom to GET a 4:3 picture.

And there still is the unanswered question why WinDVD gives a different aspect ratio (imo a better one)...
 

ChrisReid

Super Soaker Collector / Administrator
Dominator said:
I've had a problem with hi-res video but fortunately I've solved it. I post solution here in case other people have (or will have) the same problem.
I've installed wcp, enhancement pack and vob patch, then started the game - but instead of dvd video there was a blank screen (there was sound). When I've Alt-Tabbed from game I've noticed that video is played in ActiveMovie window. After some googling I've found a solution - you have to disable "Use Overlay Mixer" option in your MPEG video decoder.

How do you do that? I don't think I've ever gotten anywhere where I had options to change things with my "mpeg video decoder."
 

Dominator

Rear Admiral
How do you do that? I don't think I've ever gotten anywhere where I had options to change things with my "mpeg video decoder."

I open vob file in my video player, click on "filters", then click on (in my case) Ligos MPEG video decoder - and there are some options there
 

pvd_addict

Spaceman
Hello all !

I installed the files following the instructions... I can see the videos, but no sounds (with either subtitle on or off)... any ideas to fix this ??? Thanks a lot !!
 

AD

Finder of things, Doer of stuff
Hello all !

I installed the files following the instructions... I can see the videos, but no sounds (with either subtitle on or off)... any ideas to fix this ??? Thanks a lot !!

You probably need to install something like AC3filter to play the 5.1 audio.
 
Top