Prophecy High Res Patch Upgraded For Vista (May 13, 2008)

ChrisReid

Super Soaker Collector / Administrator
HCl's Prophecy Enhacement Pack is a super cool thing. It runs WCP in high resolution, adds online multiplayer, allows DVD quality videos to be patched in and fixes bugs that were part of the original game. Recently, as adoption of Windows Vista has gradually increased, a small number of people reported problems running the high res installer included with the pack. HCl has investigated the issue and developed a workaround. If you have experienced crashes while running install.exe in the Enhancement Pack, unzip install_gui.exe into the game folder and run it instead.




Here is a fix for the High-Res patch installer. It should solve a crash which is most common on Windows Vista, but may also occur on XP in certain circumstances. If you are experiencing trouble running the regular installer, give this fix a try and let me know if it solves the problem for you.

--
Original update published on May 13, 2008
 
Last edited by a moderator:

Jumpstart

Rear Admiral
HC, it's awesome to see you're still doing your magic after all these years, keep it up man!

Thanks for all the contributions to the community!
 

Zurga

Spaceman
Hi everybody,
I have previously played WCP on my old computer with XP and the hires pack without any trouble, but with my new computer and Vista and the widescreen, I experiment troubles when I try to install the patch.

I use the vista fix, and select Direct3D and my 1440x900 definition screen. Everything seems well working, but when I try to launch prophecy, the system said that 1440x9000 is not supported.

I have found a hires.txt file with this definition, I have change to the correct one (1440x900), I manage to launch but at this time, but the displaying is very weird, it seems that the hires patch have really put 9000 instead of 900.

Has someone an solution for this ?

Thanks in advance.
 

Zurga

Spaceman
To get further on my investigation:
I remove the dust from my old computer (XP) and launch the HiRes patch with 1440x900. Everything seems goes well.

I copy the patch.tre and hires.txt files in my modern computer.
When I launch the game, it said to me that the mode 1440x900x16 was not found.

I put the patch.tre file in the patch directory instead of deleting it, I remove the hires.txt file.
And I try to see if the HiRes moviepack works.
Surprisingly, when I try a simulated mission, the displaying was something like 1440x900.....

But the movies (HiRes, very cool stuff) with subtitles weren't synchronized and I see the inside carrier before the movie ends, I was able to ear the end of the dialogs.

It seems that this is the description for the video-fix patch, but with all the moviepack/hires enhancement pack I'm not sure that overwriting the dll will correct my trouble.

Any ideas ?
 

Edfilho

Cry some more!
The High Res patch isn't very widescreen friendly. Especially considering it uses glide.

Better to use HCl's movie fix and the OpenGL patch provided by the UE guys.
 

Zurga

Spaceman
Which patch do you speak about ?
Where can I have it ?

By the way, I use Direct3D and not Glide for my tests.

Edit: OK found it. This patch is not in the files page, but with some search in the news, I was able to find it.

I will try it and let you know the result.
 

Derailed

Spaceman
Hi guys

I too was having trouble running the HCI high res fix for WCP in Vista. It was crashing after entering the resolution and then running the conversion. I worked around the problem by booting into XP and running it from there, which worked fine.

But I just stumbled across this thread and downloaded the Vista fix, and the install_gui executable worked a treat for me. So thanks again! You guys have skills!
 
U

Unregistered

Guest
Secret Ops??

Can we also get the Secret Ops (packaged in Prophecy Gold) into a similar high res mode? How? I know there used to be a patch, but that didn't go as high in resolution as this current version. Would it be as simple as also unzipping it into the Secret Ops directory and then running install?
 
U

Unregistered

Guest
Thanks! Looks like the new patches (like those in the main game) are in the works, so I'll keep checking in for them. In the meantime, this should be an improvement over what I had.
 

Vendi

Spaceman
I'm having a pretty unique problem with this, I installed the enhancement package and the first set of movies (which btw looks great) but when I play the movies I have no sound, I've been browsing haven't seen anyone else that's come across this problem so far, any ideas?

Nevermind I actually figured this one out from a readme file, apparently I needed to download ac3 codecs.
 
B

Baeleron

Guest
glide hi-res

Sorry if this has already been discussed elsewhere, but I haven't seen it.

I notice that in hi-res glide mode there is kind of a windshield artifact on screen that isn't present in direct3d mode. Here's a screen shot:

http://www.stickpics.com/germ/glide1024x768.jpg

Notice the curved blue lines in the top left quadrant, corresponding to the normal 640x480 windshield size. Perhaps something didn't get scaled in the hi-res patch that didn't get noticed since the patch was mostly tested in direct3D mode?

Anyone else seen this?
 

AD

Finder of things, Doer of stuff
Sorry if this has already been discussed elsewhere, but I haven't seen it.

I notice that in hi-res glide mode there is kind of a windshield artifact on screen that isn't present in direct3d mode. Here's a screen shot:

http://www.stickpics.com/germ/glide1024x768.jpg

Notice the curved blue lines in the top left quadrant, corresponding to the normal 640x480 windshield size. Perhaps something didn't get scaled in the hi-res patch that didn't get noticed since the patch was mostly tested in direct3D mode?

Anyone else seen this?
Yeah, this is a known bug that shows up in 3DFX mode with a glide wrapper. Basically certain elements of the hud are resizing wrong. I thought HCl had fixed it in some of the versions (possibly by just removing the oval) but maybe I'm remembering wrong. Are you using the latest version of the patch?
 
B

Baeleron

Guest
Yeah, this is a known bug that shows up in 3DFX mode with a glide wrapper. Basically certain elements of the hud are resizing wrong. I thought HCl had fixed it in some of the versions (possibly by just removing the oval) but maybe I'm remembering wrong. Are you using the latest version of the patch?
I'm using the Prophecy Enhancement Pack downloaded from this site (https://www.wcnews.com/news/update/7962) which I assume is the latest. It's the only version of the hi-res patch that I could get to install on Vista.
 
Last edited by a moderator:

super9co

Spaceman
Hey. I don't know if this has anything to do with the patch, but i have some control difficulties. Every time i play, the ship cannot be controlled after a while. no matter where i turn or how i change thrust it just drifts off in a given direction. anyone else experience this? i can turn the ship, and engage enemies, but if i turn 180 degrees it keeps going the same way. backwards. the game is completely unplayable like this. hope any of you can help. thanks.
 

ChrisReid

Super Soaker Collector / Administrator
I haven't heard of any problems like that relating to the patch. How are you controlling the game? Keyboard or joystick? I would recommend unplugging all other USB devices and seeing how it controls. What operating system are you in? Do you have compatibility mode enabled?
 
Top