prophecy dvd movies won't work. wcphr.dll 2004 does lowres

finnagin

Spaceman
some get audio AND can can produce video but the player is in the background in a small window called ActiveMovie Window. have to ctrl-alt-del and alt-tab to view. just need a way to force the ActiveMovie Window to play fullscreen and upfront. 2004 one works but uses low res movies instead of vobs. everything is set proper but those newer versions won't work. any suggestions? ATI/AMD win7 64 bit
 
Last edited:

Pedro

Vice Admiral
some get audio AND can can produce video but the player is in the background in a small window called ActiveMovie Window. have to ctrl-alt-del and alt-tab to view. just need a way to force the ActiveMovie Window to play fullscreen and upfront. 2004 one works but uses low res movies instead of vobs. everything is set proper but those newer versions won't work. any suggestions? ATI/AMD win7 64 bit
Are you using with DirectX or OpenGL? The method changes a bit, here's the CIC link for OpenGL (which would require a clean install):
https://www.wcnews.com/news/2015/02/11/upgrade-your-gog-wc-prophecy-with-dvd-video
 
Last edited by a moderator:

finnagin

Spaceman
Are you using with DirectX or OpenGL? The method changes a bit, here's the CIC link for OpenGL (which would require a clean install):
https://www.wcnews.com/news/2015/02/11/upgrade-your-gog-wc-prophecy-with-dvd-video
Using opengl(latest 17mb installer) on the cd version and that patch is working ok(including QeffectsGL running). It plays using the latest wcphr.dll (2013)but for some reason it is in a separate window behind the game. If I could force the ActiveMovie Window to play fullscreen and upfront it would solve it.
 
Last edited by a moderator:

Pedro

Vice Admiral
Using opengl(latest 17mb installer) on the cd version and that patch is working ok(including QeffectsGL running). It plays using the latest wcphr.dll (2013)but for some reason it is in a separate window behind the game. If I could force the ActiveMovie Window to play fullscreen and upfront it would solve it.
Are you you using the most recent version of HCl's patch? I know he updated it for the OpenGL version which was creating it's own window, the original version didn't work with it.
 

AD

Finder of things, Doer of stuff
Also, the order in which you apply the various patches makes a difference. Can you double check that you followed all the steps?

1/Make a clean install of the game.

2/Download the Enhancement Pack: https://www.wcnews.com/wcpedia/Enhancement_Pack (needed to run the DVD videos and also adds a simple multiplayer mode). Unzip this into your prophecy install directory but **don't run any of the executables.**

3/Copy all the dvd video packs into a directory within your prophecy install called "movie"

4/Finally, install the openGL patch .

That should be it. If you still have video playback issues, it's possible it could be a problem with the way your mpeg2 decoder is configured.
 
Last edited by a moderator:

finnagin

Spaceman
Installed in that order. still plays in the ActiveMovie Window. Also installed AC3 ,MPEG2 and FFDShow. Also tried 6 different wcphr.dll files. Aug 2004 the 48k one does lowres but works. The others except AUG 2011 will work but windowed with that issue. AUG 2011 forces me to audio only and can't be skipped (Esc).

dates of files are AUG 2004, SEP 2008, SEP 14 2009, SEP 20 2009, AUG 2011, NOV 2013

I grabbed the vids way back in 2009 I wonder has anything changed? they are just a bunch of .VOBs in the "movie" folder?
 
Last edited:

AD

Finder of things, Doer of stuff
Can you check the compatability mode settings on your prophecy EXE as well as the launcher EXE? Try setting them to Win98/95/XP and see if that makes a difference.

Also make sure that you don't have "run in windowed mode checked in the opengl setup window.

Out of curiosity, do you have any other sofware DVD players installed on your PC? Depending on what codec pack you installed pr what software player is running, you might need to configure it for playback.
 

finnagin

Spaceman
win98 compatibility set on them already and the GL setup is set for fullscreen. Have VLC and recently MP Classic installed. Seems something messed with VLCs playback as it studders really badly now but MP Classic is ok. Will reinstall codecs and get back to you on that.

...fixed vlc and installed K-lite 64bit version. vids play but are still in the sub window although it is fullscreen now. for some reason it plays in the background?
 
Last edited:

Pedro

Vice Admiral
win98 compatibility set on them already and the GL setup is set for fullscreen. Have VLC and recently MP Classic installed. Seems something messed with VLCs playback as it studders really badly now but MP Classic is ok. Will reinstall codecs and get back to you on that.

...fixed vlc and installed K-lite 64bit version. vids play but are still in the sub window although it is fullscreen now. for some reason it plays in the background?
My guess is that HCl is the best man to address this as he resolved a similar issue to this by editing the DVD patch once before. That said as this weekend is probably my last before becoming a father of twins - I'll take a look and see if I can reproduce it and if there's anything to be done with the OpenGL patch (I have a couple of fixes I've been sitting on for a while), but if I can't figure it out this weekend it'll be a while before I get to take another look.
 

Pedro

Vice Admiral
Ok I've been able to reproduce this (sorry things got away from me). It seems intermittent, sometimes the movie is ontop, sometimes not. Looking into it.

Ok - the appearing in a different window seems to have come from having the wrong wcphr.dll, and the opengl installer doesn't seem to overwrite it. Can you try deleting it and then re-running the opengl install?
Do try different codec pacs, my first choice didn't work at all, and my second is less than flawless.
If possible select your native monitor resolution (and be sure not to check windowed) in the OpenGL setup page.

I'm still having an issue where it's only filling the top corner of my screen, the cause of that I've not yet tracked down.

I'd love to re-write the patch to work in the same way as the DivX patch HCl made some time ago and avoid the second window. Does anyone know if he released the source for that one, and if so where it was? Using a resolution over 640*480 caused a crash in the old renders but not OpenGL.
 
Last edited:
Top